aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.38
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2023-07-04 14:22:05 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2023-07-11 20:10:58 +0000
commit0b59b9276418ce4fce8a73871a13598397ab2f2e (patch)
tree697ac479c7cefec1e718cab91938acffbe84fc6c /lang/perl5.38
parent21e620488c1e545a0af680a7c5d1aecc50fd04ce (diff)
downloadports-0b59b9276418ce4fce8a73871a13598397ab2f2e.tar.gz
ports-0b59b9276418ce4fce8a73871a13598397ab2f2e.zip
Diffstat (limited to 'lang/perl5.38')
-rw-r--r--lang/perl5.38/Makefile2
-rw-r--r--lang/perl5.38/files/patch-hints_freebsd.sh43
2 files changed, 34 insertions, 11 deletions
diff --git a/lang/perl5.38/Makefile b/lang/perl5.38/Makefile
index 572c3299f05f..cf0ea90b5f2e 100644
--- a/lang/perl5.38/Makefile
+++ b/lang/perl5.38/Makefile
@@ -1,6 +1,6 @@
PORTNAME= perl
DISTVERSION= ${PERL_VERSION}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN/../../src/5.0
DIST_SUBDIR= perl
diff --git a/lang/perl5.38/files/patch-hints_freebsd.sh b/lang/perl5.38/files/patch-hints_freebsd.sh
index 9907c745ded7..966f04d1262a 100644
--- a/lang/perl5.38/files/patch-hints_freebsd.sh
+++ b/lang/perl5.38/files/patch-hints_freebsd.sh
@@ -1,24 +1,47 @@
Remove libs that are not here on FreeBSD.
---- hints/freebsd.sh.orig 2022-06-19 19:29:35 UTC
+--- hints/freebsd.sh.orig 2020-12-18 09:58:48 UTC
+++ hints/freebsd.sh
-@@ -88,6 +88,8 @@ case "$osvers" in
+@@ -88,8 +88,6 @@ case "$osvers" in
esac
libswanted=`echo $libswanted | sed 's/ malloc / /'`
libswanted=`echo $libswanted | sed 's/ bind / /'`
-+ libswanted=`echo $libswanted | sed 's/ dl / /'`
-+ libswanted=`echo $libswanted | sed 's/ c / /'`
- # iconv gone in Perl 5.8.1, but if someone compiles 5.8.0 or earlier.
- libswanted=`echo $libswanted | sed 's/ iconv / /'`
+- # iconv gone in Perl 5.8.1, but if someone compiles 5.8.0 or earlier.
+- libswanted=`echo $libswanted | sed 's/ iconv / /'`
d_setregid='define'
-@@ -102,6 +104,10 @@ case "$osvers" in
+ d_setreuid='define'
+ d_setegid='define'
+@@ -102,8 +100,13 @@ case "$osvers" in
;;
esac
libswanted=`echo $libswanted | sed 's/ malloc / /'`
+ libswanted=`echo $libswanted | sed 's/ bind / /'`
-+ libswanted=`echo $libswanted | sed 's/ dl / /'`
-+ libswanted=`echo $libswanted | sed 's/ iconv / /'`
-+ libswanted=`echo $libswanted | sed 's/ c / /'`
;;
esac
++libswanted=`echo $libswanted | sed 's/ c / /'`
++# Use -pthread so the compiler adds -lpthread at the right place on the
++# linker command line so its init functions run early.
++libswanted=`echo $libswanted | sed 's/ pthread / /'`
+ case "$osvers" in
+ 10.*)
+@@ -269,19 +272,6 @@ EOM
+
+ esac
+
+- case "$osvers" in
+- [1-4]*)
+- set `echo X "$libswanted "| sed -e 's/ c / c_r /'`
+- shift
+- libswanted="$*"
+- ;;
+- *)
+- set `echo X "$libswanted "| sed -e 's/ c //'`
+- shift
+- libswanted="$*"
+- ;;
+- esac
+-
+ # Configure will probably pick the wrong libc to use for nm scan.
+ # The safest quick-fix is just to not use nm at all...
+ usenm=false