aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.8
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2002-08-20 20:58:32 +0000
committerAnton Berezin <tobez@FreeBSD.org>2002-08-20 20:58:32 +0000
commit61b7290c3276ab8160e7acfa8a56d2dd64396229 (patch)
treeeafb52e6250aeac4e0ff89b61ce32a8a3f5e6502 /lang/perl5.8
parent9699b0a25f0f61359fb8a063e942ff755d0359cd (diff)
downloadports-61b7290c3276ab8160e7acfa8a56d2dd64396229.tar.gz
ports-61b7290c3276ab8160e7acfa8a56d2dd64396229.zip
Notes
Diffstat (limited to 'lang/perl5.8')
-rw-r--r--lang/perl5.8/Makefile2
-rw-r--r--lang/perl5.8/files/patch-lib_pm45
2 files changed, 46 insertions, 1 deletions
diff --git a/lang/perl5.8/Makefile b/lang/perl5.8/Makefile
index d2c263853678..c866070f6db1 100644
--- a/lang/perl5.8/Makefile
+++ b/lang/perl5.8/Makefile
@@ -7,7 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VER}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
${MASTER_SITE_LOCAL:S/$/:local/} \
diff --git a/lang/perl5.8/files/patch-lib_pm b/lang/perl5.8/files/patch-lib_pm
new file mode 100644
index 000000000000..b3299535adfd
--- /dev/null
+++ b/lang/perl5.8/files/patch-lib_pm
@@ -0,0 +1,45 @@
+$FreeBSD$
+
+--- lib/lib_pm.PL.orig Wed Jun 5 03:05:46 2002
++++ lib/lib_pm.PL Tue Aug 20 21:32:55 2002
+@@ -71,30 +71,31 @@ sub import {
+
+ my %names;
+ foreach (reverse @_) {
+- if ($_ eq '') {
++ my $path = $_;
++ if ($path eq '') {
+ require Carp;
+ Carp::carp("Empty compile time value given to use lib");
+ }
+
+- local $_ = _nativize($_);
++ $path = _nativize($path);
+
+- if (-e && ! -d _) {
++ if (-e $path && ! -d _) {
+ require Carp;
+ Carp::carp("Parameter to use lib must be directory, not file");
+ }
+- unshift(@INC, $_);
++ unshift(@INC, $path);
+ # Add any previous version directories we found at configure time
+ foreach my $incver (@inc_version_list)
+ {
+ my $dir = $Is_MacOS
+- ? File::Spec->catdir( $_, $incver )
+- : "$_/$incver";
++ ? File::Spec->catdir( $path, $incver )
++ : "$path/$incver";
+ unshift(@INC, $dir) if -d $dir;
+ }
+- # Put a corresponding archlib directory in front of $_ if it
+- # looks like $_ has an archlib directory below it.
++ # Put a corresponding archlib directory in front of $path if it
++ # looks like $path has an archlib directory below it.
+ my($arch_auto_dir, $arch_dir, $version_dir, $version_arch_dir)
+- = _get_dirs($_);
++ = _get_dirs($path);
+ unshift(@INC, $arch_dir) if -d $arch_auto_dir;
+ unshift(@INC, $version_dir) if -d $version_dir;
+ unshift(@INC, $version_arch_dir) if -d $version_arch_dir;