aboutsummaryrefslogtreecommitdiff
path: root/lang/php-mode.el
diff options
context:
space:
mode:
authorKoichiro Iwao <meta@FreeBSD.org>2019-11-12 04:32:03 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2019-11-12 04:32:03 +0000
commitf4ebd07ebefe1c5ec7bb00038450c92ce891f8d4 (patch)
treeb25ff9d74e4129de5dd12fad2251962d64f01bd9 /lang/php-mode.el
parentcfab4519aa49b15047f629b7a6919318bfa04d75 (diff)
downloadports-f4ebd07ebefe1c5ec7bb00038450c92ce891f8d4.tar.gz
ports-f4ebd07ebefe1c5ec7bb00038450c92ce891f8d4.zip
Notes
Diffstat (limited to 'lang/php-mode.el')
-rw-r--r--lang/php-mode.el/Makefile3
-rw-r--r--lang/php-mode.el/distinfo6
-rw-r--r--lang/php-mode.el/files/patch-75d3ee1ead7557175e6aeb2ad8efdd73ee3c933261
3 files changed, 4 insertions, 66 deletions
diff --git a/lang/php-mode.el/Makefile b/lang/php-mode.el/Makefile
index 67a7dccaf9e0..f69444779c97 100644
--- a/lang/php-mode.el/Makefile
+++ b/lang/php-mode.el/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= php-mode.el
-PORTVERSION= 1.22.0
+PORTVERSION= 1.22.1
DISTVERSIONPREFIX= v
-PORTREVISION= 1
CATEGORIES= lang elisp
PKGNAMESUFFIX= ${EMACS_PKGNAMESUFFIX}
diff --git a/lang/php-mode.el/distinfo b/lang/php-mode.el/distinfo
index 932b636c66e9..d5d3bca4da35 100644
--- a/lang/php-mode.el/distinfo
+++ b/lang/php-mode.el/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1570063790
-SHA256 (emacs-php-php-mode-v1.22.0_GH0.tar.gz) = 8127f4ac6d7425a584bf50f2e3611aae4661c026a2f59aa06e1251ba690d57e8
-SIZE (emacs-php-php-mode-v1.22.0_GH0.tar.gz) = 90211
+TIMESTAMP = 1573417507
+SHA256 (emacs-php-php-mode-v1.22.1_GH0.tar.gz) = 6c4e366be6004e52ca6afe41e2fd90ab747ef8cd564dfd18ac5dc3364060b3de
+SIZE (emacs-php-php-mode-v1.22.1_GH0.tar.gz) = 90539
diff --git a/lang/php-mode.el/files/patch-75d3ee1ead7557175e6aeb2ad8efdd73ee3c9332 b/lang/php-mode.el/files/patch-75d3ee1ead7557175e6aeb2ad8efdd73ee3c9332
deleted file mode 100644
index d79f7697d143..000000000000
--- a/lang/php-mode.el/files/patch-75d3ee1ead7557175e6aeb2ad8efdd73ee3c9332
+++ /dev/null
@@ -1,61 +0,0 @@
-From 75d3ee1ead7557175e6aeb2ad8efdd73ee3c9332 Mon Sep 17 00:00:00 2001
-From: Charlie McMackin <charliemac@gmail.com>
-Date: Sun, 29 Sep 2019 11:52:54 -0500
-Subject: [PATCH] Replace rx-form with rx-to-string
-
-`rx-form` is being removed in an upcoming version of Emacs and its rewrite of
-`rx`. Replacing it with `rx-to-string` is backwards and future compatible.
----
- php.el | 36 ++++++++++++++++++------------------
- 1 file changed, 18 insertions(+), 18 deletions(-)
-
-diff --git php.el php.el
-index 64286da..ea36fc3 100644
---- php.el
-+++ php.el
-@@ -177,24 +177,24 @@ keywords that can appear in method signatures, e.g. 'final' and
- which will be the name of the method."
- (when (stringp visibility)
- (setq visibility (list visibility)))
-- (rx-form `(: line-start
-- (* (syntax whitespace))
-- ,@(if visibility
-- `((* (or "abstract" "final" "static")
-- (+ (syntax whitespace)))
-- (or ,@visibility)
-- (+ (syntax whitespace))
-- (* (or "abstract" "final" "static")
-- (+ (syntax whitespace))))
-- '((* (* (or "abstract" "final" "static"
-- "private" "protected" "public")
-- (+ (syntax whitespace))))))
-- "function"
-- (+ (syntax whitespace))
-- (? "&" (* (syntax whitespace)))
-- (group (+ (or (syntax word) (syntax symbol))))
-- (* (syntax whitespace))
-- "(")))
-+ (rx-to-string `(: line-start
-+ (* (syntax whitespace))
-+ ,@(if visibility
-+ `((* (or "abstract" "final" "static")
-+ (+ (syntax whitespace)))
-+ (or ,@visibility)
-+ (+ (syntax whitespace))
-+ (* (or "abstract" "final" "static")
-+ (+ (syntax whitespace))))
-+ '((* (* (or "abstract" "final" "static"
-+ "private" "protected" "public")
-+ (+ (syntax whitespace))))))
-+ "function"
-+ (+ (syntax whitespace))
-+ (? "&" (* (syntax whitespace)))
-+ (group (+ (or (syntax word) (syntax symbol))))
-+ (* (syntax whitespace))
-+ "(")))
-
- (defun php-create-regexp-for-classlike (type)
- "Accepts a `TYPE' of a 'classlike' object as a string, such as
---
-2.23.0
-