aboutsummaryrefslogtreecommitdiff
path: root/lang/php53/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-08-25 12:42:20 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-08-25 12:42:20 +0000
commit14ac5bc0664b041c07f217b5cdb66a77a3ccc81f (patch)
tree3bd88acc4b830e8b7e54bf9127a389d8bc5a322b /lang/php53/Makefile
parent529dbcac575e57e5087bf38be540fe70d5f8cdb1 (diff)
downloadports-14ac5bc0664b041c07f217b5cdb66a77a3ccc81f.tar.gz
ports-14ac5bc0664b041c07f217b5cdb66a77a3ccc81f.zip
Notes
Diffstat (limited to 'lang/php53/Makefile')
-rw-r--r--lang/php53/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index 84a9d96511ca..03aa163deecd 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -7,7 +7,7 @@
PORTNAME= php5
PORTVERSION= 5.3.3
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
@@ -33,6 +33,7 @@ CONFIGURE_ARGS= \
--enable-libxml \
--with-libxml-dir=${LOCALBASE} \
--with-pcre-regex=${LOCALBASE} \
+ --with-zlib-dir=/usr \
--program-prefix=""
USE_GNOME= libxml2
@@ -66,8 +67,7 @@ PLIST_SUB+= SUHOSIN="@comment "
.endif
.if defined(WITH_MAILHEAD)
-#PATCHFILES+= php-${PORTVERSION}-mail-header.patch:mail
-PATCHFILES+= php-5.3.2-mail-header.patch:mail
+PATCHFILES+= php-${PORTVERSION}-mail-header.patch:mail
PATCH_SITES+= http://choon.net/opensource/php/:mail
.endif
@@ -140,7 +140,8 @@ CONFIGURE_ARGS+=--with-zend-vm=GOTO
CONFIGURE_ENV+= ac_cv_pthreads_lib="" \
ac_cv_pthreads_cflags="" \
pthreads_working="yes" \
- lt_cv_path_SED="sed"
+ lt_cv_path_SED="sed" \
+ PHP_MYSQLND_ENABLED="yes"
.if defined(WITH_LINKTHR)
CONFIGURE_ENV+= LIBS="${LIBS} ${PTHREAD_LIBS}"