aboutsummaryrefslogtreecommitdiff
path: root/lang/php72
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2018-01-12 12:57:18 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2018-01-12 12:57:18 +0000
commit8c60cffc902f73b2bc9b35a2c90cccb663bb1260 (patch)
tree5420aab46a862d597ca5ddbe96b764b55b898c81 /lang/php72
parentf262887ab1f3e5a7e8557bc0c7f9ecf1978bab14 (diff)
Notes
Diffstat (limited to 'lang/php72')
-rw-r--r--lang/php72/Makefile15
-rw-r--r--lang/php72/files/patch-configure.in20
-rw-r--r--lang/php72/files/patch-main__php_config.h.in12
3 files changed, 17 insertions, 30 deletions
diff --git a/lang/php72/Makefile b/lang/php72/Makefile
index 90767a314d48..6ea8c27148b8 100644
--- a/lang/php72/Makefile
+++ b/lang/php72/Makefile
@@ -17,16 +17,11 @@ CPE_PRODUCT= php
NO_OPTIONS_SORT=yes
.if !defined(PKGNAMESUFFIX)
-USE_AUTOTOOLS= autoconf
-#NOTE: libtools ends with Version mismatch error
-#USES+= autoreconf gmake
-#GNU_CONFIGURE= yes
-
LIB_DEPENDS= libpcre.so:devel/pcre \
libargon2.so:security/libargon2
+GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-layout=GNU \
- --localstatedir=/var \
--with-config-file-scan-dir=${PREFIX}/etc/php \
--disable-all \
--enable-libxml \
@@ -35,7 +30,7 @@ CONFIGURE_ARGS+=--with-layout=GNU \
--with-pcre-regex=${LOCALBASE} \
--with-password-argon2=${LOCALBASE} \
--program-prefix=""
-
+USES+= autoreconf:build
USE_GNOME= libxml2
OPTIONS_DEFINE+=CLI CGI FPM EMBED PHPDBG DEBUG DTRACE IPV6 LINKTHR ZTS
@@ -154,12 +149,8 @@ post-patch:
${WRKSRC}/sapi/fpm/php-fpm.conf.in
.endif
-# Work around issues with newer (>=2.64) autoconf
pre-configure:
- @${REINPLACE_CMD} -E 's:^((m4_)?divert)[(]([0-9]*)[)]:\1(600\3):' \
- ${WRKSRC}/configure.ac `${FIND} ${WRKSRC} -name '*.m4'`
- @${RM} ${WRKSRC}/configure
- @${CAT} ${WRKSRC}/acinclude.m4 ${WRKSRC}/build/libtool.m4 > ${WRKSRC}/aclocal.m4
+ @(cd ${WRKSRC} && ${SETENV} MAKE=${MAKE_CMD} ./buildconf --force)
.if !defined(PKGNAMEPREFIX)
post-build:
diff --git a/lang/php72/files/patch-configure.in b/lang/php72/files/patch-configure.in
index 0f4ba6df833f..539cfd1d4997 100644
--- a/lang/php72/files/patch-configure.in
+++ b/lang/php72/files/patch-configure.in
@@ -1,6 +1,14 @@
---- configure.ac.orig 2016-07-20 13:11:23 UTC
+--- configure.ac.orig 2018-01-02 22:35:55 UTC
+++ configure.ac
-@@ -370,7 +370,6 @@ sinclude(TSRM/tsrm.m4)
+@@ -102,6 +102,7 @@ int zend_sprintf(char *buffer, const char *format, ...
+
+ #undef PTHREADS
+
++#include <ext/php_config.h>
+ #endif /* PHP_CONFIG_H */
+ ])
+
+@@ -339,7 +340,6 @@ sinclude(TSRM/tsrm.m4)
dnl .
dnl -------------------------------------------------------------------------
@@ -8,7 +16,7 @@
PHP_HELP_SEPARATOR([SAPI modules:])
PHP_SHLIB_SUFFIX_NAMES
PHP_BUILD_PROGRAM
-@@ -401,15 +400,9 @@ else
+@@ -370,15 +370,9 @@ else
AC_MSG_RESULT([none])
fi
@@ -24,7 +32,7 @@
fi
dnl Starting system checks.
-@@ -700,7 +693,7 @@ nanosleep \
+@@ -682,7 +676,7 @@ nanosleep \
)
dnl Some systems (like OpenSolaris) do not have nanosleep in libc
@@ -33,7 +41,7 @@
dnl Check for getaddrinfo, should be a better way, but...
dnl Also check for working getaddrinfo
-@@ -1251,7 +1244,7 @@ EXPANDED_SYSCONFDIR=`eval echo $sysconfd
+@@ -1235,7 +1229,7 @@ EXPANDED_SYSCONFDIR=`eval echo $sysconfdir`
EXPANDED_DATADIR=$datadir
EXPANDED_PHP_CONFIG_FILE_PATH=`eval echo "$PHP_CONFIG_FILE_PATH"`
EXPANDED_PHP_CONFIG_FILE_SCAN_DIR=`eval echo "$PHP_CONFIG_FILE_SCAN_DIR"`
@@ -42,7 +50,7 @@
exec_prefix=$old_exec_prefix
libdir=$old_libdir
-@@ -1460,7 +1453,7 @@ PHP_SUBST(all_targets)
+@@ -1434,7 +1428,7 @@ PHP_SUBST(all_targets)
PHP_SUBST(install_targets)
PHP_SUBST(install_binary_targets)
diff --git a/lang/php72/files/patch-main__php_config.h.in b/lang/php72/files/patch-main__php_config.h.in
deleted file mode 100644
index 7a1d7db40d78..000000000000
--- a/lang/php72/files/patch-main__php_config.h.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- main/php_config.h.in.orig 2016-07-20 13:12:32 UTC
-+++ main/php_config.h.in
-@@ -2426,6 +2426,9 @@
- /* Define if processor uses big-endian word */
- #undef WORDS_BIGENDIAN
-
-+/* Include external shared modules configurations */
-+#include "ext/php_config.h"
-+
- /* Whether sprintf is broken */
- #undef ZEND_BROKEN_SPRINTF
-