aboutsummaryrefslogtreecommitdiff
path: root/lang/php74
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-09-30 14:16:26 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-09-30 14:16:26 +0000
commite37ca720b9c11bb56dbf90e195b7ba92f3b7fb80 (patch)
treeda5169a4bbfceceeba6e3ff39707838cfaf76fd7 /lang/php74
parent0529726683513320f6d247c0d99cc279322e7d4c (diff)
downloadports-e37ca720b9c11bb56dbf90e195b7ba92f3b7fb80.tar.gz
ports-e37ca720b9c11bb56dbf90e195b7ba92f3b7fb80.zip
lang/php74: fix build on GCC architectures
Use C11 compiler because of: /wrkdirs/usr/ports/lang/php74/work/php-7.4.0RC1/Zend/zend_compile.h:363: error: redefinition of typedef 'zend_property_info' /wrkdirs/usr/ports/lang/php74/work/php-7.4.0RC1/Zend/zend_types.h:385: error: previous declaration of 'zend_property_info' was here Disable DTRACE on powerpc64 due to: dtrace: failed to link script /usr/local/poudriere/ports/default/lang/php74/work/php-7.4.0RC1/Zend/zend_dtrace.d: an error was encountered while processing main/.libs/main.o PR: 240733 Approved by: tz (maintainer), linimon (mentor)
Notes
Notes: svn path=/head/; revision=513384
Diffstat (limited to 'lang/php74')
-rw-r--r--lang/php74/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/php74/Makefile b/lang/php74/Makefile
index 6817b128a2dc..9d7e06fba5e2 100644
--- a/lang/php74/Makefile
+++ b/lang/php74/Makefile
@@ -12,7 +12,7 @@ COMMENT= PHP Scripting Language
LICENSE= PHP301
-USES+= tar:xz cpe gnome pkgconfig
+USES+= compiler:c11 tar:xz cpe gnome pkgconfig
CPE_PRODUCT= php
NO_OPTIONS_SORT=yes
@@ -40,6 +40,7 @@ OPTIONS_EXCLUDE_DragonFly= DTRACE
# ld(1) fails to link probes: Relocations in generic ELF (EM: 0)
OPTIONS_EXCLUDE_aarch64= DTRACE
OPTIONS_EXCLUDE_powerpc= DTRACE
+OPTIONS_EXCLUDE_powerpc64= DTRACE
# dt_modtext:opensolaris/ib/libdtrace/common/dt_link.c: arm not impemented
OPTIONS_EXCLUDE_armv6= DTRACE
OPTIONS_EXCLUDE_armv7= DTRACE