aboutsummaryrefslogtreecommitdiff
path: root/lang/picoc
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2010-09-03 12:40:47 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2010-09-03 12:40:47 +0000
commit6ff38a9949fb587310398207e62031813c98e4d4 (patch)
tree6b80d96f0644edae8d50b62c79c1382d6f22627f /lang/picoc
parentab6d458fe2e3f4b59b17c3bb0350be395b3cde19 (diff)
downloadports-6ff38a9949fb587310398207e62031813c98e4d4.tar.gz
ports-6ff38a9949fb587310398207e62031813c98e4d4.zip
PicoC is a very small C interpreter for scripting. It was originally written for
scripting a UAV's on-board flight system and it's also very suitable for other robotic, embedded and non-embedded applications too. WWW: http://code.google.com/p/picoc/
Notes
Notes: svn path=/head/; revision=260484
Diffstat (limited to 'lang/picoc')
-rw-r--r--lang/picoc/Makefile30
-rw-r--r--lang/picoc/distinfo3
-rw-r--r--lang/picoc/pkg-descr5
3 files changed, 38 insertions, 0 deletions
diff --git a/lang/picoc/Makefile b/lang/picoc/Makefile
new file mode 100644
index 000000000000..840d92150d3c
--- /dev/null
+++ b/lang/picoc/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: picoc
+# Date created: 2010-09-03
+# Whom: Bapt <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= picoc
+PORTVERSION= 1.0
+CATEGORIES= lang devel
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Very small C interpreter for scripting
+
+LICENSE= BSD
+
+USE_BZIP2= yes
+
+PLIST= bin/picoc
+
+post-patch:
+ @${REINPLACE_CMD} -e "/-include/d" \
+ -e "s/^CFLAGS=.*/CFLAGS=${CFLAGS} -DUNIX_HOST/" \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/picoc ${PREFIX}/bin/picoc
+
+.include <bsd.port.mk>
diff --git a/lang/picoc/distinfo b/lang/picoc/distinfo
new file mode 100644
index 000000000000..a1adc9b03624
--- /dev/null
+++ b/lang/picoc/distinfo
@@ -0,0 +1,3 @@
+MD5 (picoc-1.0.tar.bz2) = 7af179f5f9351228df8a34ed7add436a
+SHA256 (picoc-1.0.tar.bz2) = ba20d866f1c1645fb507183c9a653631d9ba8bdc67523236d9f5f7a4c9922edc
+SIZE (picoc-1.0.tar.bz2) = 72095
diff --git a/lang/picoc/pkg-descr b/lang/picoc/pkg-descr
new file mode 100644
index 000000000000..82e32488d9ee
--- /dev/null
+++ b/lang/picoc/pkg-descr
@@ -0,0 +1,5 @@
+PicoC is a very small C interpreter for scripting. It was originally written for
+scripting a UAV's on-board flight system and it's also very suitable for other
+robotic, embedded and non-embedded applications too.
+
+WWW: http://code.google.com/p/picoc/