aboutsummaryrefslogtreecommitdiff
path: root/lang/polyml
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2021-02-12 11:42:54 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2021-02-12 11:42:54 +0000
commitb45426fc85067c8efbe3d4d4f5fe673bfa43cc79 (patch)
treeac26bc03a6e23b7a6fa61cfa47457df20b1b9ce0 /lang/polyml
parent737c92804638aa7a2f4345f58b661190523ab004 (diff)
downloadports-b45426fc85067c8efbe3d4d4f5fe673bfa43cc79.tar.gz
ports-b45426fc85067c8efbe3d4d4f5fe673bfa43cc79.zip
lang/polyml: Update to 5.8.1
- Bug fix release for version 5.8 - Visual Studio projects have been updated to VS2017 and SDK 10 Changelog: https://github.com/polyml/polyml/releases/tag/v5.8.1 PR: 253282 Submitted by: Wen Heping <wen@FreeBSD.org> Reviewed by: tcberner (mentor) Approved by: arrowd (mentor) Differential Revision: https://reviews.freebsd.org/D28529
Notes
Notes: svn path=/head/; revision=565011
Diffstat (limited to 'lang/polyml')
-rw-r--r--lang/polyml/Makefile16
-rw-r--r--lang/polyml/distinfo6
-rw-r--r--lang/polyml/files/patch-libpolyml_polyffi.cpp14
-rw-r--r--lang/polyml/files/patch-libpolyml_sighandler.cpp14
-rw-r--r--lang/polyml/files/patch-libpolyml_xwindows.cpp11
-rw-r--r--lang/polyml/pkg-descr2
-rw-r--r--lang/polyml/pkg-plist4
7 files changed, 24 insertions, 43 deletions
diff --git a/lang/polyml/Makefile b/lang/polyml/Makefile
index f4a0ba10ee24..d7dc08970ce0 100644
--- a/lang/polyml/Makefile
+++ b/lang/polyml/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= polyml
-PORTVERSION= 5.8
+PORTVERSION= 5.8.1
DISTVERSIONPREFIX= v
-PORTREVISION= 1
CATEGORIES= lang
DIST_SUBDIR= ${PORTNAME}
@@ -18,26 +17,25 @@ ONLY_FOR_ARCHS= aarch64 amd64 i386
LIB_DEPENDS= libffi.so:devel/libffi
USES= libtool localbase pathfix pkgconfig
-
USE_GITHUB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-system-libffi --enable-shared
-USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= MOTIF GMP INTINF_AS_INT
OPTIONS_DEFAULT=GMP INTINF_AS_INT
-MOTIF_CONFIGURE_WITH= x
-MOTIF_USE= motif
+INTINF_AS_INT_DESC= Use IntInf.int as int type
-GMP_CONFIGURE_WITH= gmp
GMP_LIB_DEPENDS= libgmp.so:math/gmp
-
-INTINF_AS_INT_DESC= Use IntInf.int as int type
+GMP_CONFIGURE_WITH= gmp
INTINF_AS_INT_CONFIGURE_ENABLE= intinf-as-int
+MOTIF_USES= motif xorg
+MOTIF_USE= xorg=x11,xext,xt
+MOTIF_CONFIGURE_WITH= x
post-patch:
@${REINPLACE_CMD} -e 's|-lstdc++ ||' ${WRKSRC}/configure
diff --git a/lang/polyml/distinfo b/lang/polyml/distinfo
index 5e3b1d647792..19c343dc7206 100644
--- a/lang/polyml/distinfo
+++ b/lang/polyml/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1590409982
-SHA256 (polyml/polyml-polyml-v5.8_GH0.tar.gz) = 6bcc2c5af91f361ef9e0bb28f39ce20171b0beae73b4db3674df6fc793cec8bf
-SIZE (polyml/polyml-polyml-v5.8_GH0.tar.gz) = 9817105
+TIMESTAMP = 1612530407
+SHA256 (polyml/polyml-polyml-v5.8.1_GH0.tar.gz) = fa0507b44470b4e07a061ef6a8896efe42710d8436e15721d743572ad2f7753b
+SIZE (polyml/polyml-polyml-v5.8.1_GH0.tar.gz) = 9845209
diff --git a/lang/polyml/files/patch-libpolyml_polyffi.cpp b/lang/polyml/files/patch-libpolyml_polyffi.cpp
deleted file mode 100644
index a0a23bacc8b3..000000000000
--- a/lang/polyml/files/patch-libpolyml_polyffi.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- libpolyml/polyffi.cpp.orig 2017-11-18 13:45:15 UTC
-+++ libpolyml/polyffi.cpp
-@@ -108,9 +108,10 @@ static struct _abiTable { const char *abiName; ffi_abi
- {"ms_cdecl", FFI_MS_CDECL},
- #elif defined(X86_WIN64)
- {"win64", FFI_WIN64},
-+#elif defined(X86_64) || (defined (__x86_64__) && defined (X86_DARWIN))
-+ {"unix64", FFI_UNIX64},
- #elif defined(X86_ANY)
- {"sysv", FFI_SYSV},
-- {"unix64", FFI_UNIX64},
- #endif
- { "default", FFI_DEFAULT_ABI}
- };
diff --git a/lang/polyml/files/patch-libpolyml_sighandler.cpp b/lang/polyml/files/patch-libpolyml_sighandler.cpp
deleted file mode 100644
index 29681a304e2b..000000000000
--- a/lang/polyml/files/patch-libpolyml_sighandler.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
-polyexport fails to unwind the stack on aarch64 with pthread signals enabled
-ref: https://github.com/polyml/polyml/issues/110
-
---- libpolyml/sighandler.cpp.orig 2020-06-07 19:41:16 UTC
-+++ libpolyml/sighandler.cpp
-@@ -70,7 +70,7 @@
- #include <semaphore.h>
- #endif
-
--#if ((!defined(_WIN32) || defined(__CYGWIN__)) && defined(HAVE_LIBPTHREAD) && defined(HAVE_PTHREAD_H) && defined(HAVE_SEMAPHORE_H))
-+#if ((!defined(_WIN32) || defined(__CYGWIN__)) && defined(HAVE_LIBPTHREAD) && defined(HAVE_PTHREAD_H) && defined(HAVE_SEMAPHORE_H)) && !defined(__aarch64__)
- // If we have the pthread library and header and we have semaphores we can use the pthread
- // signalling mechanism. But if this is a native Windows build we don't use semaphores or
- // pthread even if they're provided.
diff --git a/lang/polyml/files/patch-libpolyml_xwindows.cpp b/lang/polyml/files/patch-libpolyml_xwindows.cpp
new file mode 100644
index 000000000000..da35f2ccb983
--- /dev/null
+++ b/lang/polyml/files/patch-libpolyml_xwindows.cpp
@@ -0,0 +1,11 @@
+--- libpolyml/xwindows.cpp.orig 2020-07-17 08:44:22 UTC
++++ libpolyml/xwindows.cpp
+@@ -7302,7 +7302,7 @@ static void DebugPrintWord(PolyWord P /* was X_Object
+ : printf("Old Display <%p>",P.AsAddress()));
+ return;
+
+- default: printf("Pointer "ZERO_X"%p",P.AsAddress());
++ default: printf("Pointer 'ZERO_X' %p", P.AsAddress());
+ return;
+ }
+ }
diff --git a/lang/polyml/pkg-descr b/lang/polyml/pkg-descr
index 5e653ac3fb1b..2e6ffe5341d7 100644
--- a/lang/polyml/pkg-descr
+++ b/lang/polyml/pkg-descr
@@ -2,4 +2,4 @@ Poly/ML is a full implementation of Standard ML available as
open-source. It includes a symbolic debugger which allows breakpoints
to be set and local variables to be viewed as ML values.
-WWW: http://www.polyml.org
+WWW: https://www.polyml.org
diff --git a/lang/polyml/pkg-plist b/lang/polyml/pkg-plist
index 12546f70286e..74f4335bdad4 100644
--- a/lang/polyml/pkg-plist
+++ b/lang/polyml/pkg-plist
@@ -4,8 +4,8 @@ bin/polyimport
lib/libpolymain.a
lib/libpolyml.a
lib/libpolyml.so
-lib/libpolyml.so.10
-lib/libpolyml.so.10.0.0
+lib/libpolyml.so.11
+lib/libpolyml.so.11.0.0
libdata/pkgconfig/polyml.pc
man/man1/poly.1.gz
man/man1/polyc.1.gz