aboutsummaryrefslogtreecommitdiff
path: root/lang/ptoc/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-02-22 04:02:48 +0000
committerSteve Price <steve@FreeBSD.org>1999-02-22 04:02:48 +0000
commit1b94d66d82f6ffdcdce540a6cb45c06785b2d274 (patch)
treeda939d08e203ecb3635012ababb4abc5fdb26c82 /lang/ptoc/Makefile
parente05363d82dc739db20aa6a6829967867c0de92a5 (diff)
downloadports-1b94d66d82f6ffdcdce540a6cb45c06785b2d274.tar.gz
ports-1b94d66d82f6ffdcdce540a6cb45c06785b2d274.zip
Notes
Diffstat (limited to 'lang/ptoc/Makefile')
-rw-r--r--lang/ptoc/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/lang/ptoc/Makefile b/lang/ptoc/Makefile
index 1412747c36f7..a9c18a893c58 100644
--- a/lang/ptoc/Makefile
+++ b/lang/ptoc/Makefile
@@ -1,15 +1,15 @@
# New ports collection makefile for: ptoc
-# Version required: 3.34
+# Version required: 3.41
# Date created: 10 December 1997
# Whom: Andrey Zakhvatov
#
-# $Id: Makefile,v 1.5 1998/10/14 23:56:40 jseger Exp $
+# $Id: Makefile,v 1.6 1998/11/09 01:21:38 steve Exp $
#
-DISTNAME= ptoc_3.34
-PKGNAME= ptoc-3.34
+DISTNAME= ptoc-3.41
CATEGORIES= lang
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITES= ${MASTER_SITE_SUNSITE} \
+ http://www.ispras.ru/~knizhnik/
MASTER_SITE_SUBDIR= devel/lang/pascal
MAINTAINER= andy@icc.surw.chel.su
@@ -19,6 +19,11 @@ MAKEFILE= makefile
USE_XLIB= yes
WRKSRC= ${WRKDIR}/ptoc
+pre-build:
+ @ ${MV} ${WRKSRC}/makefile.bsd ${WRKSRC}/makefile
+ @ ${MV} ${WRKSRC}/Xbgi/makefile.bsd ${WRKSRC}/Xbgi/makefile
+ @ ${MV} ${WRKSRC}/examples/makefile.bsd ${WRKSRC}/examples/makefile
+
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/cganal ${PREFIX}/bin
@ ${INSTALL_PROGRAM} ${WRKSRC}/ptoc ${PREFIX}/bin
@@ -38,6 +43,8 @@ do-install:
.for file in bgidemo.pas coord.txt hello.pas impact.pas lister.pas polut2.pas printer.pas q2.txt random.txt rename.pas set.pas test.pas tpascal.pas trinor.pas vibrkinp.pas vibrkinp.txt vibrtabl.pas war2.pas war2.txt xy2orig.txt
@ ${INSTALL_DATA} ${WRKSRC}/examples/${file} ${PREFIX}/share/examples/ptoc
.endfor
+
+post-install:
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${PREFIX}/share/doc/ptoc
@ ${INSTALL_DATA} ${WRKSRC}/Readme.htm ${PREFIX}/share/doc/ptoc