aboutsummaryrefslogtreecommitdiff
path: root/lang/pypy
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2017-06-18 16:55:38 +0000
committerDavid Naylor <dbn@FreeBSD.org>2017-06-18 16:55:38 +0000
commitbe9819f737564d904fb9983cbc54aa0407dd9a35 (patch)
tree93d34148942316232d82eb782ffbe503aae7c787 /lang/pypy
parent795c8e51a0fc77ed98c41bcd0f34f5ce54ad67cb (diff)
downloadports-be9819f737564d904fb9983cbc54aa0407dd9a35.tar.gz
ports-be9819f737564d904fb9983cbc54aa0407dd9a35.zip
lang/pypy(3): update to 5.8
Change Log: - supports upstream library 2.7.13 and 3.5.3 - critical bugs fixed in shadowstack - native support for profiling frames in vmprof - performance improvements for pack* and unpack* structs - cffi updates to 1.10.1 - numpy 1.13.0 requires at least this version
Notes
Notes: svn path=/head/; revision=443834
Diffstat (limited to 'lang/pypy')
-rw-r--r--lang/pypy/Makefile3
-rw-r--r--lang/pypy/bsd.pypy.cffi.mk2
-rw-r--r--lang/pypy/distinfo6
-rw-r--r--lang/pypy/files/patch-lib-python_2.7_distutils_sysconfig__pypy.py18
-rw-r--r--lang/pypy/files/patch-rpython_rlib_rvmprof_src_shared_machine.c20
-rw-r--r--lang/pypy/files/patch-rpython_translator_platform_posix.py13
6 files changed, 25 insertions, 37 deletions
diff --git a/lang/pypy/Makefile b/lang/pypy/Makefile
index ffe163247739..2f5ecbb293b6 100644
--- a/lang/pypy/Makefile
+++ b/lang/pypy/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME?= pypy
-DISTVERSION?= 5.7.1 # Also update bsd.pypy.cffi.mk
-PORTREVISION?= 1
+DISTVERSION?= 5.8.0 # Also update bsd.pypy.cffi.mk
CATEGORIES= lang python
MASTER_SITES= https://bitbucket.org/pypy/pypy/downloads/ http://buildbot.pypy.org/mirror/
DISTNAME?= ${PORTNAME}2-v${PORTVERSION}-src
diff --git a/lang/pypy/bsd.pypy.cffi.mk b/lang/pypy/bsd.pypy.cffi.mk
index f4363e5df00d..571f986342d7 100644
--- a/lang/pypy/bsd.pypy.cffi.mk
+++ b/lang/pypy/bsd.pypy.cffi.mk
@@ -11,7 +11,7 @@ PLIST_FILES= %%PYPY_DIR%%/lib_pypy/${CFFI_MODULE}_cffi.%%PYPY_CFFI_VER%%.so
CFFI_MODULE?= _${PORTNAME}
PYTHON_IMPL= pypy
-PYTHON_PORTVERSION?= 5.7.1
+PYTHON_PORTVERSION?= 5.8.0
PYTHON_PKGNAMEPREFIX= pypy-
PYTHON_CMD= ${LOCALBASE}/bin/${PYTHON_IMPL}
diff --git a/lang/pypy/distinfo b/lang/pypy/distinfo
index aa2853e55a50..cf07ca8d3148 100644
--- a/lang/pypy/distinfo
+++ b/lang/pypy/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1491510301
-SHA256 (pypy2-v5.7.1-src.tar.bz2) = d01bee43c6df79f7bbc1149bb3e85f489491fb2358a6a1f9a7f0d6e07715832f
-SIZE (pypy2-v5.7.1-src.tar.bz2) = 18940413
+TIMESTAMP = 1497478804
+SHA256 (pypy2-v5.8.0-src.tar.bz2) = 504c2d522595baf8775ae1045a217a2b120732537861d31b889d47c340b58bd5
+SIZE (pypy2-v5.8.0-src.tar.bz2) = 19163498
diff --git a/lang/pypy/files/patch-lib-python_2.7_distutils_sysconfig__pypy.py b/lang/pypy/files/patch-lib-python_2.7_distutils_sysconfig__pypy.py
deleted file mode 100644
index 2f228be3a635..000000000000
--- a/lang/pypy/files/patch-lib-python_2.7_distutils_sysconfig__pypy.py
+++ /dev/null
@@ -1,18 +0,0 @@
---- lib-python/2.7/distutils/sysconfig_pypy.py.orig 2017-04-06 19:44:56 UTC
-+++ lib-python/2.7/distutils/sysconfig_pypy.py
-@@ -61,12 +61,12 @@ _config_vars = None
- def _init_posix():
- """Initialize the module as appropriate for POSIX systems."""
- g = {}
-- g['CC'] = "gcc -pthread"
-- g['CXX'] = "g++ -pthread"
-+ g['CC'] = "cc -pthread"
-+ g['CXX'] = "c++ -pthread"
- g['OPT'] = "-DNDEBUG -O2"
- g['CFLAGS'] = "-DNDEBUG -O2"
- g['CCSHARED'] = "-fPIC"
-- g['LDSHARED'] = "gcc -pthread -shared"
-+ g['LDSHARED'] = "cc -pthread -shared"
- g['SO'] = [s[0] for s in imp.get_suffixes() if s[2] == imp.C_EXTENSION][0]
- g['AR'] = "ar"
- g['ARFLAGS'] = "rc"
diff --git a/lang/pypy/files/patch-rpython_rlib_rvmprof_src_shared_machine.c b/lang/pypy/files/patch-rpython_rlib_rvmprof_src_shared_machine.c
new file mode 100644
index 000000000000..b4e9cbbbeeea
--- /dev/null
+++ b/lang/pypy/files/patch-rpython_rlib_rvmprof_src_shared_machine.c
@@ -0,0 +1,20 @@
+--- rpython/rlib/rvmprof/src/shared/machine.c.orig 2017-06-05 20:40:44 UTC
++++ rpython/rlib/rvmprof/src/shared/machine.c
+@@ -28,6 +28,8 @@ const char * vmp_machine_os_name(void)
+ #endif
+ #elif __linux__
+ return "linux";
++#elif __FreeBSD__
++ return "freebsd";
+ #else
+ #error "Unknown compiler"
+ #endif
+@@ -39,7 +41,7 @@ long vmp_fd_to_path(int fd, char * buffe
+ char proffs[24];
+ (void)snprintf(proffs, 24, "/proc/self/fd/%d", fd);
+ return readlink(proffs, buffer, buffer_len);
+-#elif defined(VMPROF_UNIX)
++#elif defined(VMPROF_UNIX) && !defined(__FreeBSD__)
+ fcntl(fd, F_GETPATH, buffer);
+ return strlen(buffer);
+ #endif
diff --git a/lang/pypy/files/patch-rpython_translator_platform_posix.py b/lang/pypy/files/patch-rpython_translator_platform_posix.py
deleted file mode 100644
index 61c82e22d954..000000000000
--- a/lang/pypy/files/patch-rpython_translator_platform_posix.py
+++ /dev/null
@@ -1,13 +0,0 @@
-FreeBSD's base ld(1) does not currently support plugins and is not compatible
-with clang's link-time optimisation.
---- rpython/translator/platform/posix.py.orig 2017-03-19 19:55:48 UTC
-+++ rpython/translator/platform/posix.py
-@@ -132,7 +132,7 @@ class BasePosix(Platform):
-
- # xxx check which compilers accept this option or not
- if not config or config.translation.gcrootfinder != 'asmgcc':
-- cflags = ('-flto',) + cflags
-+ pass
-
- m = GnuMakefile(path)
- m.exe_name = path.join(exe_name.basename)