aboutsummaryrefslogtreecommitdiff
path: root/lang/python23
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2004-04-14 06:49:21 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2004-04-14 06:49:21 +0000
commit9e1cf1197820ca234a3d09f6997703a58f0755a2 (patch)
treefe2b4e05b6207af8fb9eaa70fcc6853ac8c4d1b7 /lang/python23
parentf04d1caa47275fa4fa52733b3bb321621b583fa8 (diff)
downloadports-9e1cf1197820ca234a3d09f6997703a58f0755a2.tar.gz
ports-9e1cf1197820ca234a3d09f6997703a58f0755a2.zip
Notes
Diffstat (limited to 'lang/python23')
-rw-r--r--lang/python23/Makefile2
-rw-r--r--lang/python23/files/patch-configure10
2 files changed, 10 insertions, 2 deletions
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index 3fd4cb0ff30a..3495e7ec11c2 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python
PORTVERSION= 2.3.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python23/files/patch-configure b/lang/python23/files/patch-configure
index ef9326985205..40e715f8aa0e 100644
--- a/lang/python23/files/patch-configure
+++ b/lang/python23/files/patch-configure
@@ -1,5 +1,5 @@
--- configure.orig Wed Nov 19 04:59:36 2003
-+++ configure Mon Feb 9 17:39:34 2004
++++ configure Wed Apr 14 15:37:53 2004
@@ -1321,7 +1321,7 @@
VERSION=2.3
@@ -31,3 +31,11 @@
else
echo "$as_me: program exited with status $ac_status" >&5
echo "$as_me: failed program was:" >&5
+@@ -15001,6 +15007,7 @@
+ hints.ai_family = AF_UNSPEC;
+ hints.ai_flags = passive ? AI_PASSIVE : 0;
+ hints.ai_socktype = SOCK_STREAM;
++ hints.ai_protocol = IPPROTO_TCP;
+ if ((gaierr = getaddrinfo(NULL, "54321", &hints, &aitop)) != 0) {
+ (void)gai_strerror(gaierr);
+ goto bad;