aboutsummaryrefslogtreecommitdiff
path: root/lang/python27/Makefile
diff options
context:
space:
mode:
authorSean Bruno <sbruno@FreeBSD.org>2017-08-02 17:58:03 +0000
committerSean Bruno <sbruno@FreeBSD.org>2017-08-02 17:58:03 +0000
commite6f4295f5c5a982139001ec20e31b9fc66632c79 (patch)
tree3b1e90ac749d4222fcaf237b32ff353b8d8e9fab /lang/python27/Makefile
parentc0595e7ea0a82ca78509b644cb550dc8f4097052 (diff)
downloadports-e6f4295f5c5a982139001ec20e31b9fc66632c79.tar.gz
ports-e6f4295f5c5a982139001ec20e31b9fc66632c79.zip
Notes
Diffstat (limited to 'lang/python27/Makefile')
-rw-r--r--lang/python27/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 0280eea82ddc..85377eefd2be 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -2,7 +2,7 @@
PORTNAME= python27
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
@@ -136,6 +136,17 @@ post-patch:
post-install:
for i in ${STAGEDIR}${PREFIX}/lib/python2.7/lib-dynload/*.so; do \
${STRIP_CMD} $$i; done # Strip shared extensions
+# This code block exists for the qemu-user enabled cross build environment.
+# When using this environment in poudriere, CC is not set to the default
+# of /usr/bin/cc and a cross-compile toolchain is used. We need to hand
+# edit this so that the run time configuration for python matches what the
+# FreeBSD base system provides. sbruno 02Aug2017
+.if ${CC} == /nxb-bin/usr/bin/cc
+ @${REINPLACE_CMD} -e 's=/nxb-bin==' \
+ ${STAGEDIR}${PREFIX}/lib/python2.7/_sysconfigdata.py
+ @${REINPLACE_CMD} -e 's=/nxb-bin==' \
+ ${STAGEDIR}${PREFIX}/lib/python2.7/config/Makefile
+.endif
${INSTALL_DATA} ${WRKSRC}/Tools/gdb/libpython.py \
${STAGEDIR}${PREFIX}/lib/libpython2.7.so.1-gdb.py