aboutsummaryrefslogtreecommitdiff
path: root/lang/python27
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2015-12-24 11:39:53 +0000
committerMartin Wilke <miwi@FreeBSD.org>2015-12-24 11:39:53 +0000
commitb05bb8a6fb064d305258f13a518990f60f767d71 (patch)
tree0ac80159c469f2c35ead6bea7447eec3afbbbf2f /lang/python27
parenta4308117ecb084225d4857fe5c23a5ca8fdc944d (diff)
downloadports-b05bb8a6fb064d305258f13a518990f60f767d71.tar.gz
ports-b05bb8a6fb064d305258f13a518990f60f767d71.zip
- Switch regression-test to TEST_TARGED
Discussed in: D4695 Reviewed by: koobs
Notes
Notes: svn path=/head/; revision=404343
Diffstat (limited to 'lang/python27')
-rw-r--r--lang/python27/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 95a3e1443707..d8b9a506c915 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -25,6 +25,10 @@ CONFIGURE_ARGS+= --enable-shared
CONFIGURE_ENV+= ac_cv_opt_olimit_ok=no OPT="" # Null out OPT to respect user CFLAGS and remove optimizations
INSTALL_TARGET= altinstall # Don't want cloberring of unprefixed files
+
+TEST_TARGET= buildbottest
+TEST_ARGS= TESTOPTS=-j${MAKE_JOBS_NUMBER}
+
MAKE_ARGS+= INSTALL_SHARED="${INSTALL_LIB}" # Strip shared library
MAKE_ARGS+= LIBPC="${PREFIX}/libdata/pkgconfig" # Until pathfix gets support for files other than Makefile.in
MAKE_JOBS_UNSAFE= yes # Parser/pgen build bug. See Issue: 200622, 201974
@@ -122,7 +126,4 @@ post-install:
for i in ${STAGEDIR}${PREFIX}/lib/python2.7/lib-dynload/*.so; do \
${STRIP_CMD} $$i; done # Strip shared extensions
-regression-test: build
- @cd ${WRKSRC} && ${MAKE} TESTOPTS=-j${MAKE_JOBS_NUMBER} buildbottest
-
.include <bsd.port.mk>