aboutsummaryrefslogtreecommitdiff
path: root/lang/python27
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2014-07-11 18:09:01 +0000
committerSofian Brabez <sbz@FreeBSD.org>2014-07-11 18:09:01 +0000
commitb5d9bfb7a4aa74448310eb6f732369f376d05423 (patch)
tree54f8e56289136b2586222145558ebbda6542a04c /lang/python27
parented9d1b9bafa228d0d8a34c679a2143d047826177 (diff)
downloadports-b5d9bfb7a4aa74448310eb6f732369f376d05423.tar.gz
ports-b5d9bfb7a4aa74448310eb6f732369f376d05423.zip
Notes
Diffstat (limited to 'lang/python27')
-rw-r--r--lang/python27/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index f057d2e55acc..a0d0d3ccfff2 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -22,10 +22,14 @@ MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
INSTALL_TARGET= altinstall
-USES= readline tar:xz
+USES= readline tar:xz cpe
USE_LDCONFIG= yes
USE_PYTHON= yes
+CPE_VENDOR= python
+CPE_PRODUCT= ${CPE_VENDOR}
+CPE_VERSION= ${PORTVERSION}
+
PYTHON_VERSION= python2.7
PYTHON_NO_DEPENDS= yes
@@ -272,10 +276,9 @@ post-install:
${INSTALL_MAN} ${PYTHON_WRKSRC}/Misc/python.man \
${STAGEDIR}${MAN1PREFIX}/man/man1/${PYTHON_VERSION}.1
-.if !defined(NOPORTDATA)
@${MKDIR} ${STAGEDIR}${DATADIR}
@(cd ${PYTHON_WRKSRC}; ${TAR} -cf - Tools | (cd ${STAGEDIR}${DATADIR}; ${TAR} --no-same-owner -xf -))
-.endif
+
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@(cd ${PYTHON_WRKSRC}/Demo; ${TAR} -cf - * | \
(cd ${STAGEDIR}${EXAMPLESDIR}; ${TAR} --no-same-owner -xf -))