aboutsummaryrefslogtreecommitdiff
path: root/lang/python27
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-11-29 10:55:00 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-11-29 10:55:00 +0000
commite4c2b30ce8e600e2bf5f6d3e6b95c4dd27abcac4 (patch)
tree2413914bfbe3fbc373cf0d76ed6622109f25b995 /lang/python27
parent324ac215698252611470237971d13ac472815eb0 (diff)
downloadports-e4c2b30ce8e600e2bf5f6d3e6b95c4dd27abcac4.tar.gz
ports-e4c2b30ce8e600e2bf5f6d3e6b95c4dd27abcac4.zip
lang/python{27,35,36,37,38}: Add closefrom(2) support
A single close(fd) syscall is cheap, but when MAXFDS (maximum file descriptor number) is high, the loop calling close(fd) on each file descriptor can take several milliseconds. The default value of subprocess.Popen "close_fds" parameter changed to True in Python 3. Compared to Python 2, close_fds=True can make Popen 10x slower: see bpo-37790 [1] The present workaround on FreeBSD to improve performance is to load and mount the fdescfs kernel module, but this is not enabled by default. This change adds minimum viable (and upstreamable) closefrom(2) syscall support to Python's subprocess and posix modules, improving performance significantly for loads that involve working with many processes, such as diffoscope, ansible, and many others. For additional optimizations, upstream recently (3.8) landed posix_spawn(2) support [3] and has stated that they will adopt close_range(2) after Linux merges it [4]. Linux/FreeBSD developers are already collaborating on ensuring compatible implementations, with FreeBSD's implementation pending in D21627. [5] Thank you emaste, cem, kevans for providing analysis, input, clarifications, comms/upstream support and patches. [1] https://bugs.python.org/issue37790 [2] https://bugs.python.org/issue38061 [3] https://bugs.python.org/issue35537 [4] https://lwn.net/Articles/789023/ [5] https://reviews.freebsd.org/D21627 Additional References: https://bugs.python.org/issue8052 https://bugs.python.org/issue11284 https://bugs.python.org/issue13788 https://bugs.python.org/issue1663329 https://www.python.org/dev/peps/pep-0446/ PR: 242274, 221700 Submitted by: kevans (emaste, cem) Approved by: koobs (python (maintainer), santa)
Notes
Notes: svn path=/head/; revision=518640
Diffstat (limited to 'lang/python27')
-rw-r--r--lang/python27/Makefile1
-rw-r--r--lang/python27/files/patch-Modules_posixmodule.c27
2 files changed, 28 insertions, 0 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 717f0296b46e..6ecb0882b96c 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -2,6 +2,7 @@
PORTNAME= python
PORTVERSION= ${PYTHON_PORTVERSION}
+PORTREVISION= 1
CATEGORIES= lang python
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
PKGNAMESUFFIX= 27
diff --git a/lang/python27/files/patch-Modules_posixmodule.c b/lang/python27/files/patch-Modules_posixmodule.c
new file mode 100644
index 000000000000..acc841e5c199
--- /dev/null
+++ b/lang/python27/files/patch-Modules_posixmodule.c
@@ -0,0 +1,27 @@
+# Add closefrom(2) support
+# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=242274
+# https://bugs.python.org/issue38061
+# TODO: Upstream
+
+--- Modules/posixmodule.c.orig 2019-10-19 18:38:44 UTC
++++ Modules/posixmodule.c
+@@ -6676,9 +6676,16 @@ posix_closerange(PyObject *self, PyObject *args)
+ if (!PyArg_ParseTuple(args, "ii:closerange", &fd_from, &fd_to))
+ return NULL;
+ Py_BEGIN_ALLOW_THREADS
+- for (i = fd_from; i < fd_to; i++)
+- if (_PyVerify_fd(i))
+- close(i);
++#ifdef __FreeBSD__
++ if (fd_to >= sysconf(_SC_OPEN_MAX)) {
++ closefrom(fd_from);
++ } else
++#endif
++ {
++ for (i = fd_from; i < fd_to; i++)
++ if (_PyVerify_fd(i))
++ close(i);
++ }
+ Py_END_ALLOW_THREADS
+ Py_RETURN_NONE;
+ }