aboutsummaryrefslogtreecommitdiff
path: root/lang/python2
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-01-09 13:33:04 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-01-09 13:33:04 +0000
commitc990abadc1a9aa1ece49c466799def40831e34d7 (patch)
tree194f50e502b8a756351eb9612bc04a160a05e207 /lang/python2
parent35cc54ec3795fbe49255212b57d766e27f14703d (diff)
downloadports-c990abadc1a9aa1ece49c466799def40831e34d7.tar.gz
ports-c990abadc1a9aa1ece49c466799def40831e34d7.zip
Simplify the lang/python{2,3} metaports.
Reviewed by: antoine
Notes
Notes: svn path=/head/; revision=522488
Diffstat (limited to 'lang/python2')
-rw-r--r--lang/python2/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/lang/python2/Makefile b/lang/python2/Makefile
index 414aee14dfec..c446a1038dc2 100644
--- a/lang/python2/Makefile
+++ b/lang/python2/Makefile
@@ -14,11 +14,10 @@ COMMENT= The "meta-port" for version 2 of the Python interpreter
DEPRECATED= EOLed upstream
EXPIRATION_DATE= 2020-12-31
-USES= python:run
+USES= python:2.7,run
NO_ARCH= yes
NO_BUILD= yes
-PYTHON_VERSION= python${PYTHON2_DEFAULT}
PLIST_FILES= bin/2to3-${PYTHON_MAJOR_VER} \
bin/idle${PYTHON_MAJOR_VER} \
@@ -29,8 +28,6 @@ PLIST_FILES= bin/2to3-${PYTHON_MAJOR_VER} \
.include <bsd.port.pre.mk>
-RUN_DEPENDS+= ${PYTHON_CMD}:${PYTHON_PORTSDIR}
-
do-install:
.for file in idle pydoc python
${LN} -sf ${file}${PYTHON_VER} \