aboutsummaryrefslogtreecommitdiff
path: root/lang/python32
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-12-14 06:31:19 +0000
committerWen Heping <wen@FreeBSD.org>2010-12-14 06:31:19 +0000
commit39858860eabd63d59f38ed508f6510be890ed8bb (patch)
treeca5fb07ffe5f492a8883bb540a1737269d6f3da9 /lang/python32
parent39faccbe393b2c31feb9510072b6407c40952953 (diff)
downloadports-39858860eabd63d59f38ed508f6510be890ed8bb.tar.gz
ports-39858860eabd63d59f38ed508f6510be890ed8bb.zip
Notes
Diffstat (limited to 'lang/python32')
-rw-r--r--lang/python32/Makefile3
-rw-r--r--lang/python32/distinfo5
-rw-r--r--lang/python32/files/patch-Lib-test-test_socket.py11
-rw-r--r--lang/python32/files/patch-Modules-fcntlmodule.c88
-rw-r--r--lang/python32/files/patch-setup.py71
-rw-r--r--lang/python32/pkg-plist35
6 files changed, 102 insertions, 111 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 5c0f76ae8343..87d1ad6491f1 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= python31
-PORTVERSION= 3.1.2
-PORTREVISION= 1
+PORTVERSION= 3.1.3
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python32/distinfo b/lang/python32/distinfo
index aec70c21ed7c..60a1380f078b 100644
--- a/lang/python32/distinfo
+++ b/lang/python32/distinfo
@@ -1,3 +1,2 @@
-MD5 (python/Python-3.1.2.tgz) = 08d01c468989d1f2cc560c23f8e6a7ea
-SHA256 (python/Python-3.1.2.tgz) = dffbc0561a161a4a576c6059e6990a9859a0be16ba9b5736eabe4abbb2700d1c
-SIZE (python/Python-3.1.2.tgz) = 11661773
+SHA256 (python/Python-3.1.3.tgz) = 6311823aeda8be6a7a2b67caaeff48abce6626c9940ba7ed81f9c978666a36bd
+SIZE (python/Python-3.1.3.tgz) = 11769584
diff --git a/lang/python32/files/patch-Lib-test-test_socket.py b/lang/python32/files/patch-Lib-test-test_socket.py
deleted file mode 100644
index 4895d7bc5fc8..000000000000
--- a/lang/python32/files/patch-Lib-test-test_socket.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- Lib/test/test_socket.py.orig 2009-10-04 10:54:52.000000000 -0400
-+++ Lib/test/test_socket.py 2010-06-24 13:57:37.000000000 -0400
-@@ -337,7 +337,7 @@
- # I've ordered this by protocols that have both a tcp and udp
- # protocol, at least for modern Linuxes.
- if sys.platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6',
-- 'freebsd7', 'freebsd8', 'darwin'):
-+ 'freebsd7', 'freebsd8', 'freebsd9', 'darwin'):
- # avoid the 'echo' service on this platform, as there is an
- # assumption breaking non-standard port/protocol entry
- services = ('daytime', 'qotd', 'domain')
diff --git a/lang/python32/files/patch-Modules-fcntlmodule.c b/lang/python32/files/patch-Modules-fcntlmodule.c
index 3803ad427fbe..6f9f3ab01d0a 100644
--- a/lang/python32/files/patch-Modules-fcntlmodule.c
+++ b/lang/python32/files/patch-Modules-fcntlmodule.c
@@ -1,53 +1,53 @@
---- Modules/fcntlmodule.c.orig 2009-05-24 11:46:13.000000000 -0400
-+++ Modules/fcntlmodule.c 2010-06-24 22:30:32.000000000 -0400
+--- Modules/fcntlmodule.c.orig 2010-12-14 09:44:03.000000000 +0800
++++ Modules/fcntlmodule.c 2010-12-14 09:47:17.000000000 +0800
@@ -97,20 +97,15 @@
{
#define IOCTL_BUFSZ 1024
- int fd;
-- /* In PyArg_ParseTuple below, we use the unsigned non-checked 'I'
-+ /* In PyArg_ParseTuple below, we use the unsigned non-checked 'k'
- format for the 'code' parameter because Python turns 0x8000000
- into either a large positive number (PyLong or PyInt on 64-bit
- platforms) or a negative number on others (32-bit PyInt)
- whereas the system expects it to be a 32bit bit field value
- regardless of it being passed as an int or unsigned long on
-- various platforms. See the termios.TIOCSWINSZ constant across
-- platforms for an example of thise.
+ int fd;
+- /* In PyArg_ParseTuple below, we use the unsigned non-checked 'I'
++ /* In PyArg_ParseTuple below, we use the unsigned non-checked 'k'
+ format for the 'code' parameter because Python turns 0x8000000
+ into either a large positive number (PyLong or PyInt on 64-bit
+ platforms) or a negative number on others (32-bit PyInt)
+ whereas the system expects it to be a 32bit bit field value
+ regardless of it being passed as an int or unsigned long on
+- various platforms. See the termios.TIOCSWINSZ constant across
+- platforms for an example of thise.
-
-- If any of the 64bit platforms ever decide to use more than 32bits
-- in their unsigned long ioctl codes this will break and need
-- special casing based on the platform being built on.
-+ various platforms.
- */
-- unsigned int code;
-+ unsigned long code;
- int arg;
- int ret;
- Py_buffer pstr;
+- If any of the 64bit platforms ever decide to use more than 32bits
+- in their unsigned long ioctl codes this will break and need
+- special casing based on the platform being built on.
++ various platforms.
+ */
+- unsigned int code;
++ unsigned long code;
+ int arg;
+ int ret;
+ Py_buffer pstr;
@@ -119,7 +114,7 @@
- int mutate_arg = 1;
- char buf[IOCTL_BUFSZ+1]; /* argument plus NUL byte */
+ int mutate_arg = 1;
+ char buf[IOCTL_BUFSZ+1]; /* argument plus NUL byte */
-- if (PyArg_ParseTuple(args, "O&Iw*|i:ioctl",
-+ if (PyArg_ParseTuple(args, "O&kw*|i:ioctl",
- conv_descriptor, &fd, &code,
- &pstr, &mutate_arg)) {
- char *arg;
+- if (PyArg_ParseTuple(args, "O&Iw*|i:ioctl",
++ if (PyArg_ParseTuple(args, "O&kw*|i:ioctl",
+ conv_descriptor, &fd, &code,
+ &pstr, &mutate_arg)) {
+ char *arg;
@@ -174,7 +169,7 @@
- }
+ }
- PyErr_Clear();
-- if (PyArg_ParseTuple(args, "O&Is*:ioctl",
-+ if (PyArg_ParseTuple(args, "O&ks*:ioctl",
- conv_descriptor, &fd, &code, &pstr)) {
- str = pstr.buf;
- len = pstr.len;
+ PyErr_Clear();
+- if (PyArg_ParseTuple(args, "O&Is*:ioctl",
++ if (PyArg_ParseTuple(args, "O&ks*:ioctl",
+ conv_descriptor, &fd, &code, &pstr)) {
+ str = pstr.buf;
+ len = pstr.len;
@@ -201,7 +196,7 @@
- PyErr_Clear();
- arg = 0;
- if (!PyArg_ParseTuple(args,
-- "O&I|i;ioctl requires a file or file descriptor,"
-+ "O&k|i;ioctl requires a file or file descriptor,"
- " an integer and optionally an integer or buffer argument",
- conv_descriptor, &fd, &code, &arg)) {
- return NULL;
+ PyErr_Clear();
+ arg = 0;
+ if (!PyArg_ParseTuple(args,
+- "O&I|i;ioctl requires a file or file descriptor,"
++ "O&k|i;ioctl requires a file or file descriptor,"
+ " an integer and optionally an integer or buffer argument",
+ conv_descriptor, &fd, &code, &arg)) {
+ return NULL;
diff --git a/lang/python32/files/patch-setup.py b/lang/python32/files/patch-setup.py
index 5f78c13849a4..ee5430f79091 100644
--- a/lang/python32/files/patch-setup.py
+++ b/lang/python32/files/patch-setup.py
@@ -1,7 +1,7 @@
---- setup.py.orig 2009-08-12 20:39:44.000000000 +0200
-+++ setup.py 2009-11-26 12:58:45.000000000 +0100
-@@ -16,7 +16,7 @@
- from distutils.command.install_lib import install_lib
+--- setup.py.orig 2010-11-26 19:56:26.000000000 +0800
++++ setup.py 2010-12-14 10:53:36.000000000 +0800
+@@ -17,7 +17,7 @@
+ from distutils.spawn import find_executable
# This global variable is used to hold the list of modules to be disabled.
-disabled_module_list = []
@@ -9,16 +9,16 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
-@@ -514,7 +514,7 @@
-
- readline_libs = ['readline']
- if self.compiler.find_library_file(lib_dirs,
-- 'ncursesw'):
-+ 'XXXncursesw'):
- readline_libs.append('ncursesw')
- elif self.compiler.find_library_file(lib_dirs,
- 'ncurses'):
-@@ -526,7 +526,7 @@
+@@ -578,7 +578,7 @@
+ # curses_library = readline_termcap_library
+ # elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
+ # (...)
+- if self.compiler.find_library_file(lib_dirs, 'ncursesw'):
++ if self.compiler.find_library_file(lib_dirs, 'XXXncursesw'):
+ curses_library = 'ncursesw'
+ elif self.compiler.find_library_file(lib_dirs, 'ncurses'):
+ curses_library = 'ncurses'
+@@ -614,7 +614,7 @@
'termcap'):
readline_libs.append('termcap')
exts.append( Extension('readline', ['readline.c'],
@@ -27,7 +27,7 @@
extra_link_args=readline_extra_link_args,
libraries=readline_libs) )
else:
-@@ -619,6 +619,8 @@
+@@ -708,6 +708,8 @@
# OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
exts.append( Extension('_sha256', ['sha256module.c']) )
exts.append( Extension('_sha512', ['sha512module.c']) )
@@ -36,50 +36,49 @@
if openssl_ver < 0x00907000:
# no openssl at all, use our own md5 and sha1
-@@ -994,7 +996,7 @@
- # Curses support, requiring the System V version of curses, often
+@@ -1116,12 +1118,13 @@
# provided by the ncurses library.
panel_library = 'panel'
-- if (self.compiler.find_library_file(lib_dirs, 'ncursesw')):
-+ if (self.compiler.find_library_file(lib_dirs, 'XXXncursesw')):
- curses_libs = ['ncursesw']
- # Bug 1464056: If _curses.so links with ncursesw,
- # _curses_panel.so must link with panelw.
-@@ -1004,6 +1006,7 @@
- elif (self.compiler.find_library_file(lib_dirs, 'ncurses')):
- curses_libs = ['ncurses']
+ if curses_library.startswith('ncurses'):
+- if curses_library == 'ncursesw':
++ if curses_library == 'XXXncursesw':
+ # Bug 1464056: If _curses.so links with ncursesw,
+ # _curses_panel.so must link with panelw.
+ panel_library = 'panelw'
+ curses_libs = [curses_library]
exts.append( Extension('_curses', ['_cursesmodule.c'],
-+ library_dirs = ['/usr/lib'],
++ library_dirs = ['/usr/lib'],
libraries = curses_libs) )
- elif (self.compiler.find_library_file(lib_dirs, 'curses')
- and platform != 'darwin'):
-@@ -1025,6 +1028,7 @@
+ elif curses_library == 'curses' and platform != 'darwin':
+ # OSX has an old Berkeley curses, not good enough for
+@@ -1142,6 +1145,7 @@
if (module_enabled(exts, '_curses') and
self.compiler.find_library_file(lib_dirs, panel_library)):
exts.append( Extension('_curses_panel', ['_curses_panel.c'],
-+ library_dirs = ['/usr/lib'],
++ library_dirs = ['/usr/lib'],
libraries = [panel_library] + curses_libs) )
else:
missing.append('_curses_panel')
-@@ -1161,7 +1165,7 @@
+@@ -1278,7 +1282,7 @@
macros = dict()
libraries = []
- elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8'):
-+ elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9'):
++ elif platform in ('freebsd6', 'freebsd7', 'freebsd8', 'freebsd9'):
# FreeBSD's P1003.1b semaphore support is very experimental
# and has many known problems. (as of June 2008)
macros = dict()
-@@ -1204,7 +1208,7 @@
+@@ -1321,8 +1325,7 @@
+ # End multiprocessing
# Platform-specific libraries
- if platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6',
+- if platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6',
- 'freebsd7', 'freebsd8'):
-+ 'freebsd7', 'freebsd8', 'freebsd9'):
++ if platform in ('linux2', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9'):
exts.append( Extension('ossaudiodev', ['ossaudiodev.c']) )
else:
missing.append('ossaudiodev')
-@@ -1665,8 +1669,7 @@
+@@ -1808,8 +1811,7 @@
# called unless there's at least one extension module defined.
ext_modules=[Extension('_struct', ['_struct.c'])],
diff --git a/lang/python32/pkg-plist b/lang/python32/pkg-plist
index 325f9e99cad5..caaf24620821 100644
--- a/lang/python32/pkg-plist
+++ b/lang/python32/pkg-plist
@@ -125,7 +125,6 @@ libdata/pkgconfig/python-3.1.pc
%%PYTHON_LIBDIR%%/bdb.py
%%PYTHON_LIBDIR%%/binhex.py
%%PYTHON_LIBDIR%%/bisect.py
-%%PYTHON_LIBDIR%%/build_class.py
%%PYTHON_LIBDIR%%/cProfile.py
%%PYTHON_LIBDIR%%/calendar.py
%%PYTHON_LIBDIR%%/cgi.py
@@ -314,6 +313,7 @@ libdata/pkgconfig/python-3.1.pc
%%PYTHON_LIBDIR%%/distutils/tests/test_install_headers.py
%%PYTHON_LIBDIR%%/distutils/tests/test_install_lib.py
%%PYTHON_LIBDIR%%/distutils/tests/test_install_scripts.py
+%%PYTHON_LIBDIR%%/distutils/tests/test_log.py
%%PYTHON_LIBDIR%%/distutils/tests/test_msvc9compiler.py
%%PYTHON_LIBDIR%%/distutils/tests/test_register.py
%%PYTHON_LIBDIR%%/distutils/tests/test_sdist.py
@@ -747,10 +747,12 @@ libdata/pkgconfig/python-3.1.pc
%%PYTHON_LIBDIR%%/lib-dynload/unicodedata.so
%%PYTHON_LIBDIR%%/lib-dynload/zlib.so
%%PYTHON_LIBDIR%%/lib2to3/Grammar.txt
-%%PYTHON_LIBDIR%%/lib2to3/Grammar3.1.2.final.0.pickle
+%%PYTHON_LIBDIR%%/lib2to3/Grammar3.1.3.final.0.pickle
%%PYTHON_LIBDIR%%/lib2to3/PatternGrammar.txt
-%%PYTHON_LIBDIR%%/lib2to3/PatternGrammar3.1.2.final.0.pickle
+%%PYTHON_LIBDIR%%/lib2to3/PatternGrammar3.1.3.final.0.pickle
%%PYTHON_LIBDIR%%/lib2to3/__init__.py
+%%PYTHON_LIBDIR%%/lib2to3/btm_matcher.py
+%%PYTHON_LIBDIR%%/lib2to3/btm_utils.py
%%PYTHON_LIBDIR%%/lib2to3/fixer_base.py
%%PYTHON_LIBDIR%%/lib2to3/fixer_util.py
%%PYTHON_LIBDIR%%/lib2to3/fixes/__init__.py
@@ -762,6 +764,7 @@ libdata/pkgconfig/python-3.1.pc
%%PYTHON_LIBDIR%%/lib2to3/fixes/fix_except.py
%%PYTHON_LIBDIR%%/lib2to3/fixes/fix_exec.py
%%PYTHON_LIBDIR%%/lib2to3/fixes/fix_execfile.py
+%%PYTHON_LIBDIR%%/lib2to3/fixes/fix_exitfunc.py
%%PYTHON_LIBDIR%%/lib2to3/fixes/fix_filter.py
%%PYTHON_LIBDIR%%/lib2to3/fixes/fix_funcattrs.py
%%PYTHON_LIBDIR%%/lib2to3/fixes/fix_future.py
@@ -1156,7 +1159,9 @@ libdata/pkgconfig/python-3.1.pc
%%PYTHON_LIBDIR%%/test/relimport.py
%%PYTHON_LIBDIR%%/test/reperf.py
%%PYTHON_LIBDIR%%/test/sample_doctest.py
+%%PYTHON_LIBDIR%%/test/script_helper.py
%%PYTHON_LIBDIR%%/test/seq_tests.py
+%%PYTHON_LIBDIR%%/test/sha256.pem
%%PYTHON_LIBDIR%%/test/sgml_input.html
%%PYTHON_LIBDIR%%/test/sortperf.py
%%PYTHON_LIBDIR%%/test/ssl_cert.pem
@@ -1392,7 +1397,6 @@ libdata/pkgconfig/python-3.1.pc
%%PYTHON_LIBDIR%%/test/test_pprint.py
%%PYTHON_LIBDIR%%/test/test_print.py
%%PYTHON_LIBDIR%%/test/test_profile.py
-%%PYTHON_LIBDIR%%/test/test_profilehooks.py
%%PYTHON_LIBDIR%%/test/test_property.py
%%PYTHON_LIBDIR%%/test/test_pstats.py
%%PYTHON_LIBDIR%%/test/test_pty.py
@@ -1409,6 +1413,7 @@ libdata/pkgconfig/python-3.1.pc
%%PYTHON_LIBDIR%%/test/test_reprlib.py
%%PYTHON_LIBDIR%%/test/test_resource.py
%%PYTHON_LIBDIR%%/test/test_richcmp.py
+%%PYTHON_LIBDIR%%/test/test_rlcompleter.py
%%PYTHON_LIBDIR%%/test/test_robotparser.py
%%PYTHON_LIBDIR%%/test/test_runpy.py
%%PYTHON_LIBDIR%%/test/test_sax.py
@@ -1424,6 +1429,7 @@ libdata/pkgconfig/python-3.1.pc
%%PYTHON_LIBDIR%%/test/test_slice.py
%%PYTHON_LIBDIR%%/test/test_smtplib.py
%%PYTHON_LIBDIR%%/test/test_smtpnet.py
+%%PYTHON_LIBDIR%%/test/test_sndhdr.py
%%PYTHON_LIBDIR%%/test/test_socket.py
%%PYTHON_LIBDIR%%/test/test_socketserver.py
%%PYTHON_LIBDIR%%/test/test_sort.py
@@ -1440,11 +1446,14 @@ libdata/pkgconfig/python-3.1.pc
%%PYTHON_LIBDIR%%/test/test_structmembers.py
%%PYTHON_LIBDIR%%/test/test_structseq.py
%%PYTHON_LIBDIR%%/test/test_subprocess.py
+%%PYTHON_LIBDIR%%/test/test_sunau.py
%%PYTHON_LIBDIR%%/test/test_sundry.py
%%PYTHON_LIBDIR%%/test/test_super.py
%%PYTHON_LIBDIR%%/test/test_symtable.py
%%PYTHON_LIBDIR%%/test/test_syntax.py
%%PYTHON_LIBDIR%%/test/test_sys.py
+%%PYTHON_LIBDIR%%/test/test_sys_setprofile.py
+%%PYTHON_LIBDIR%%/test/test_sys_settrace.py
%%PYTHON_LIBDIR%%/test/test_syslog.py
%%PYTHON_LIBDIR%%/test/test_tarfile.py
%%PYTHON_LIBDIR%%/test/test_tcl.py
@@ -1519,6 +1528,8 @@ libdata/pkgconfig/python-3.1.pc
%%PYTHON_LIBDIR%%/test/tokenize_tests-utf8-coding-cookie-and-no-utf8-bom-sig.txt
%%PYTHON_LIBDIR%%/test/tokenize_tests-utf8-coding-cookie-and-utf8-bom-sig.txt
%%PYTHON_LIBDIR%%/test/tokenize_tests.txt
+%%PYTHON_LIBDIR%%/test/tracedmodules/__init__.py
+%%PYTHON_LIBDIR%%/test/tracedmodules/testmod.py
%%PYTHON_LIBDIR%%/test/warning_tests.py
%%PYTHON_LIBDIR%%/test/xmltests.py
%%PYTHON_LIBDIR%%/test/zipdir.zip
@@ -1645,7 +1656,6 @@ libdata/pkgconfig/python-3.1.pc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/embed/demo.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/embed/importexc.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/embed/loop.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/imputil/knee.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/md5test/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/md5test/foo
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/md5test/md5driver.py
@@ -1780,10 +1790,7 @@ libdata/pkgconfig/python-3.1.pc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tix/samples/Tree.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tix/tixwidgets.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/README
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/AttrDialog.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/ManPage.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/MimeViewer.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/ShellWindow.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/attr_dialog.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/brownian.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/brownian2.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/canvasevents.py
@@ -1795,11 +1802,14 @@ libdata/pkgconfig/python-3.1.pc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/imageview.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/kill.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/listtree.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/manpage.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/mbox.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/mimeviewer.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/newmenubardemo.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/optionmenu.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/paint.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/rmt.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/shell_window.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/solitaire.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/sortvisu.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tkinter/guido/ss1.py
@@ -2096,10 +2106,6 @@ libdata/pkgconfig/python-3.1.pc
%%PORTDATA%%%%DATADIR%%/Tools/unicode/python-mappings/CP1140.TXT
%%PORTDATA%%%%DATADIR%%/Tools/unicode/python-mappings/KOI8-U.TXT
%%PORTDATA%%%%DATADIR%%/Tools/unicode/python-mappings/TIS-620.TXT
-%%PORTDATA%%%%DATADIR%%/Tools/versioncheck/README
-%%PORTDATA%%%%DATADIR%%/Tools/versioncheck/_checkversion.py
-%%PORTDATA%%%%DATADIR%%/Tools/versioncheck/checkversions.py
-%%PORTDATA%%%%DATADIR%%/Tools/versioncheck/pyversioncheck.py
%%PORTDATA%%%%DATADIR%%/Tools/webchecker/README
%%PORTDATA%%%%DATADIR%%/Tools/webchecker/tktools.py
%%PORTDATA%%%%DATADIR%%/Tools/webchecker/wcgui.py
@@ -2111,7 +2117,6 @@ libdata/pkgconfig/python-3.1.pc
%%PORTDATA%%%%DATADIR%%/Tools/world/world
%%PORTDATA%%@dirrm %%DATADIR%%/Tools/world
%%PORTDATA%%@dirrm %%DATADIR%%/Tools/webchecker
-%%PORTDATA%%@dirrm %%DATADIR%%/Tools/versioncheck
%%PORTDATA%%@dirrm %%DATADIR%%/Tools/unicode/python-mappings
%%PORTDATA%%@dirrm %%DATADIR%%/Tools/unicode
%%PORTDATA%%@dirrm %%DATADIR%%/Tools/ssl
@@ -2151,7 +2156,6 @@ libdata/pkgconfig/python-3.1.pc
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/parser
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/newmetaclasses
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/md5test
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/imputil
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/embed
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/distutils/test2to3/test2to3
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/distutils/test2to3/test
@@ -2175,6 +2179,7 @@ libdata/pkgconfig/python-3.1.pc
@dirrm %%PYTHON_LIBDIR%%/tkinter/test
@dirrm %%PYTHON_LIBDIR%%/tkinter
@dirrm %%PYTHON_LIBDIR%%/test/decimaltestdata
+@dirrm %%PYTHON_LIBDIR%%/test/tracedmodules
@dirrm %%PYTHON_LIBDIR%%/test
@dirrm %%PYTHON_LIBDIR%%/sqlite3/test
@dirrm %%PYTHON_LIBDIR%%/sqlite3