aboutsummaryrefslogtreecommitdiff
path: root/lang/python34
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2017-06-06 12:56:47 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2017-06-06 12:56:47 +0000
commit2f6fe8dcec7d5bc9ac62ebe4ba2510257cb470de (patch)
treedc349266ef50b39f1af7ccb996591cf377357316 /lang/python34
parent5a46ce779090dc0e6e32a02e0615d69310fee507 (diff)
downloadports-2f6fe8dcec7d5bc9ac62ebe4ba2510257cb470de.tar.gz
ports-2f6fe8dcec7d5bc9ac62ebe4ba2510257cb470de.zip
Notes
Diffstat (limited to 'lang/python34')
-rw-r--r--lang/python34/Makefile4
-rw-r--r--lang/python34/pkg-plist1
2 files changed, 4 insertions, 1 deletions
diff --git a/lang/python34/Makefile b/lang/python34/Makefile
index 1c237230bd91..0a5ec790ece9 100644
--- a/lang/python34/Makefile
+++ b/lang/python34/Makefile
@@ -3,7 +3,7 @@
PORTNAME= python34
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
@@ -126,5 +126,7 @@ post-install:
.endif
for i in ${STAGEDIR}${PREFIX}/lib/python3.4/lib-dynload/*.so; do \
${STRIP_CMD} $$i; done # Strip shared extensions
+ ${INSTALL_DATA} ${WRKSRC}/Tools/gdb/libpython.py \
+ ${STAGEDIR}${PREFIX}/lib/libpython3.4${ABIFLAGS}.so.1-gdb.py
.include <bsd.port.mk>
diff --git a/lang/python34/pkg-plist b/lang/python34/pkg-plist
index 17a52edcf0bf..ec468844cade 100644
--- a/lang/python34/pkg-plist
+++ b/lang/python34/pkg-plist
@@ -101,6 +101,7 @@ include/python3.4%%ABI%%/warnings.h
include/python3.4%%ABI%%/weakrefobject.h
lib/libpython3.4%%ABI%%.so
lib/libpython3.4%%ABI%%.so.1
+lib/libpython3.4%%ABI%%.so.1-gdb.py
lib/python3.4/LICENSE.txt
lib/python3.4/__future__.py
lib/python3.4/__phello__.foo.py