aboutsummaryrefslogtreecommitdiff
path: root/lang/python35
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2016-06-17 17:09:04 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2016-06-17 17:09:04 +0000
commit5643ed620ad357da5eeacb8833b77c6f2d7747ac (patch)
tree0adb184f75003084e164df487438ff3c51107f45 /lang/python35
parentb7700753f9278cb149b133ca845a9609bb3408ef (diff)
downloadports-5643ed620ad357da5eeacb8833b77c6f2d7747ac.tar.gz
ports-5643ed620ad357da5eeacb8833b77c6f2d7747ac.zip
Notes
Diffstat (limited to 'lang/python35')
-rw-r--r--lang/python35/Makefile4
-rw-r--r--lang/python35/files/patch-Modules_zipimport.c17
2 files changed, 19 insertions, 2 deletions
diff --git a/lang/python35/Makefile b/lang/python35/Makefile
index 521887ebd4ff..63f16bb34dcb 100644
--- a/lang/python35/Makefile
+++ b/lang/python35/Makefile
@@ -3,7 +3,7 @@
PORTNAME= python
DISTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PYTHON_PORTVERSION}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
@@ -126,7 +126,7 @@ PLIST_SUB+= NO_NIS=""
post-install:
.if ! ${PORT_OPTIONS:MDEBUG}
- ${RM} -f ${STAGEDIR}${PREFIX}/lib/libpython3.so # Upstream Issue: http://bugs.python.org/issue17975
+ ${RM} ${STAGEDIR}${PREFIX}/lib/libpython3.so # Upstream Issue: http://bugs.python.org/issue17975
.endif
for i in ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/lib-dynload/*.so; do \
${STRIP_CMD} $$i; done # Strip shared extensions
diff --git a/lang/python35/files/patch-Modules_zipimport.c b/lang/python35/files/patch-Modules_zipimport.c
new file mode 100644
index 000000000000..14fab69a406c
--- /dev/null
+++ b/lang/python35/files/patch-Modules_zipimport.c
@@ -0,0 +1,17 @@
+
+Bug: http://bugs.python.org/issue26171
+
+--- Modules/zipimport.c.orig 2015-12-07 01:39:10 UTC
++++ Modules/zipimport.c
+@@ -1112,6 +1112,11 @@ get_data(PyObject *archive, PyObject *to
+ }
+ file_offset += l; /* Start of file data */
+
++ if (data_size > LONG_MAX - 1) {
++ fclose(fp);
++ PyErr_NoMemory();
++ return NULL;
++ }
+ bytes_size = compress == 0 ? data_size : data_size + 1;
+ if (bytes_size == 0)
+ bytes_size++;