aboutsummaryrefslogtreecommitdiff
path: root/lang/python35
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-12-29 12:03:09 +0000
committerJohn Marino <marino@FreeBSD.org>2015-12-29 12:03:09 +0000
commit6256117d69833c86052b33bbc7252a244d3413a7 (patch)
tree442cd87d41f98356b818e916797bd629171b005c /lang/python35
parent5181935100e044b96a86b4671e62ec0692fa2c27 (diff)
downloadports-6256117d69833c86052b33bbc7252a244d3413a7.tar.gz
ports-6256117d69833c86052b33bbc7252a244d3413a7.zip
Notes
Diffstat (limited to 'lang/python35')
-rw-r--r--lang/python35/Makefile6
-rw-r--r--lang/python35/Makefile.version4
2 files changed, 7 insertions, 3 deletions
diff --git a/lang/python35/Makefile b/lang/python35/Makefile
index 097fa497756f..1aa52fa5ae8a 100644
--- a/lang/python35/Makefile
+++ b/lang/python35/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= python
-DISTVERSION= 3.5.1
+DISTVERSION= ${PYTHON_PORTVERSION}
CATEGORIES= lang python ipv6
-MASTER_SITES= PYTHON/ftp/python/${DISTVERSION:C/^([0-9]+\.[0-9]+\.[0-9]+).*/\1/}
+MASTER_SITES= PYTHON/ftp/python/${PYTHON_PORTVERSION}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
DISTNAME= Python-${DISTVERSION}
DIST_SUBDIR= python
@@ -24,7 +24,6 @@ CPE_PRODUCT= ${CPE_VENDOR}
CPE_VERSION= ${DISTVERSION}
# Duplicate python.mk variables. TODO: Let lang/python?? ports use python.mk bits.
-PYTHON_PORTVERSION= ${DISTVERSION:C/^([0-9]+\.[0-9]+\.[0-9]+).*/\1/}
PYTHON_VER= ${PYTHON_PORTVERSION:R}
PYTHON_VERSION= python${PYTHON_VER}
PYTHON_SUFFIX= ${PYTHON_VER:S/.//g}
@@ -89,6 +88,7 @@ THREADS_LDFLAGS= -lpthread
TSC_CONFIGURE_WITH= tsc
+.include "${.CURDIR}/Makefile.version"
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPYMALLOC}
diff --git a/lang/python35/Makefile.version b/lang/python35/Makefile.version
new file mode 100644
index 000000000000..bc8460896a75
--- /dev/null
+++ b/lang/python35/Makefile.version
@@ -0,0 +1,4 @@
+# Mk/Uses/python.mk includes this file, don't remove it!
+# $FreeBSD$
+
+PYTHON_PORTVERSION= 3.5.1