aboutsummaryrefslogtreecommitdiff
path: root/lang/python36
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-02-11 14:36:16 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-02-11 14:36:16 +0000
commit5327348fea06480aa7e80a4f11141bb5c914329d (patch)
tree5601001b2676f8eecc4bec01386c5a0c4ced6b9f /lang/python36
parent20153c04cc287106e47b95fb421b2ca8935080e1 (diff)
downloadports-5327348fea06480aa7e80a4f11141bb5c914329d.tar.gz
ports-5327348fea06480aa7e80a4f11141bb5c914329d.zip
Clean up Makefile
- Move BROKEN_SSL upward - Sort USES - Remove CPE_*: all of them are default values - Update PLIST_FILES: do not use %% - Update http:// links in Makefile comments and patch files
Notes
Notes: svn path=/head/; revision=461500
Diffstat (limited to 'lang/python36')
-rw-r--r--lang/python36/Makefile37
-rw-r--r--lang/python36/files/patch-issue202102
2 files changed, 19 insertions, 20 deletions
diff --git a/lang/python36/Makefile b/lang/python36/Makefile
index 95075ad1382c..7b44ccc21732 100644
--- a/lang/python36/Makefile
+++ b/lang/python36/Makefile
@@ -4,9 +4,9 @@
PORTNAME= python
PORTVERSION= ${PYTHON_PORTVERSION}
CATEGORIES= lang python ipv6
-MASTER_SITES= PYTHON/ftp/python/${PYTHON_PORTVERSION}
+MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
-DISTNAME= Python-${DISTVERSION}
+DISTNAME= Python-${PORTVERSION}
DIST_SUBDIR= python
MAINTAINER= python@FreeBSD.org
@@ -14,18 +14,15 @@ COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
-USES= cpe ncurses pathfix pkgconfig readline:port ssl tar:xz shebangfix
+BROKEN_SSL= openssl-devel
+
+USES= cpe ncurses pathfix pkgconfig readline:port shebangfix ssl tar:xz
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
python_CMD= ${PREFIX}/bin/python${PYTHON_PORTVERSION:R}
SHEBANG_FILES= Lib/*.py Lib/*/*.py Lib/*/*/*.py Lib/*/*/*/*.py
-BROKEN_SSL= openssl-devel
-
-CPE_VENDOR= python
-CPE_PRODUCT= ${CPE_VENDOR}
-
# Duplicate python.mk variables. TODO: Let lang/python?? ports use python.mk bits.
PYTHON_VER= ${PYTHON_PORTVERSION:R}
PYTHON_VERSION= python${PYTHON_VER}
@@ -46,9 +43,11 @@ MAKE_JOBS_UNSAFE= yes # Parser/pgen build bug. See Issue: 200622, 201974
SUB_FILES= pkg-message
SUB_LIST= PYTHON_SUFFIX=${PYTHON_SUFFIX}
-PLIST_SUB= XYDOT=${PYTHON_VER} XY=${PYTHON_SUFFIX} \
- XYZDOT=${PYTHON_PORTVERSION} ABI=${ABIFLAGS} \
- OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. http://bugs.python.org/issue19554
+PLIST_SUB= ABI=${ABIFLAGS} \
+ XY=${PYTHON_SUFFIX} \
+ XYDOT=${PYTHON_VER} \
+ XYZDOT=${PORTVERSION} \
+ OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. https://bugs.python.org/issue19554
OPTIONS_DEFINE= DEBUG IPV6 LIBFFI NLS PYMALLOC THREADS
OPTIONS_DEFAULT= LIBFFI PYMALLOC THREADS
@@ -75,7 +74,7 @@ LIBFFI_LIB_DEPENDS= libffi.so:devel/libffi
# Use CPPFLAGS over CFLAGS due to -I ordering, causing elementtree and pyexpat
# to break in Python 2.7, or preprocessor complaints in Python >= 3.3
-# Upstream Issue: http://bugs.python.org/issue6299
+# Upstream Issue: https://bugs.python.org/issue6299
NLS_USES= gettext
NLS_CPPFLAGS= -I${LOCALBASE}/include
NLS_LIBS= -L${LOCALBASE}/lib -lintl
@@ -98,13 +97,13 @@ ABIFLAGS:= d${ABIFLAGS}
.endif
.if !empty(ABIFLAGS)
-PLIST_FILES+= bin/python%%XYDOT%%%%ABI%%
-PLIST_FILES+= bin/python%%XYDOT%%%%ABI%%-config
-PLIST_FILES+= libdata/pkgconfig/python-%%XYDOT%%%%ABI%%.pc
+PLIST_FILES+= bin/python${PYTHON_VER}${ABIFLAGS} \
+ bin/python${PYTHON_VER}${ABIFLAGS}-config \
+ libdata/pkgconfig/python-${PYTHON_VER}${ABIFLAGS}.pc
.endif
-# http://bugs.python.org/issue22521
-# http://bugs.python.org/issue23042
+# https://bugs.python.org/issue22521
+# https://bugs.python.org/issue23042
.if ${ARCH} == i386 && !${PORT_OPTIONS:MLIBFFI}
BROKEN= You must use libffi from ports on i386. Enable the LIBFFI option
.endif
@@ -113,7 +112,7 @@ BROKEN= You must use libffi from ports on i386. Enable the LIBFFI option
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif
-# See http://bugs.freebsd.org/115940 and http://bugs.freebsd.org/193650
+# See https://bugs.freebsd.org/115940 and https://bugs.freebsd.org/193650
.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS)
PLIST_SUB+= NO_NIS="@comment "
DISABLED_EXTENSIONS+= nis
@@ -134,7 +133,7 @@ post-patch:
post-install:
.if ! ${PORT_OPTIONS:MDEBUG}
- ${RM} ${STAGEDIR}${PREFIX}/lib/libpython3.so # Upstream Issue: http://bugs.python.org/issue17975
+ ${RM} ${STAGEDIR}${PREFIX}/lib/libpython3.so # Upstream Issue: https://bugs.python.org/issue17975
.endif
# This code block exists for the qemu-user enabled cross build environment.
# When using this environment in poudriere, CC is not set to the default
diff --git a/lang/python36/files/patch-issue20210 b/lang/python36/files/patch-issue20210
index 38ad041e322c..90330d8f90a5 100644
--- a/lang/python36/files/patch-issue20210
+++ b/lang/python36/files/patch-issue20210
@@ -1,5 +1,5 @@
# Backport patch 0001 from Issue #20210
-# Issue: http://bugs.python.org/issue20210
+# Issue: https://bugs.python.org/issue20210
# By: Thomas Petazzoni
--- ./Makefile.pre.in.orig 2014-03-24 22:45:17.908886504 +1100