aboutsummaryrefslogtreecommitdiff
path: root/lang/python37
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-12-31 16:03:41 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-12-31 16:03:41 +0000
commit3e5bb2b9681fef6dff510ba76156530bb4d62027 (patch)
treed39af9b4d8ab66e7568c5982ff1b8d6dd63c43b5 /lang/python37
parent355e44ee6399318da9e3a19e6f0c677c5a642e2e (diff)
downloadports-3e5bb2b9681fef6dff510ba76156530bb4d62027.tar.gz
ports-3e5bb2b9681fef6dff510ba76156530bb4d62027.zip
- Fix build in presence of e2fsprogs-libuuid
PR: 229562 Reported by: many
Notes
Notes: svn path=/head/; revision=488798
Diffstat (limited to 'lang/python37')
-rw-r--r--lang/python37/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/lang/python37/Makefile b/lang/python37/Makefile
index fe87ffb87a4c..a3f04f2ebf91 100644
--- a/lang/python37/Makefile
+++ b/lang/python37/Makefile
@@ -114,6 +114,12 @@ DISABLED_EXTENSIONS+= nis
PLIST_SUB+= NO_NIS=""
.endif
+post-patch:
+# disable the detection of includes and library from e2fsprogs-libuuid,
+# which introduces hidden dependency and breaks build
+ @${REINPLACE_CMD} -e 's|uuid/uuid.h|ignore_&|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/find_library_file/ s|uuid|ignore_&|' ${WRKSRC}/setup.py
+
post-install:
.if ! ${PORT_OPTIONS:MDEBUG}
${RM} ${STAGEDIR}${PREFIX}/lib/libpython3.so # Upstream Issue: https://bugs.python.org/issue17975