aboutsummaryrefslogtreecommitdiff
path: root/lang/python38
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-05-28 13:52:33 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-05-28 13:52:33 +0000
commite7d17eb8674b0b6fab8a3ef5684cd92c8c306bab (patch)
treed94abc3a8df325a515ab6f1dbffc53c85efb6a47 /lang/python38
parentf2191cb27cebc4d310b3126119bb3112be91da0c (diff)
downloadports-e7d17eb8674b0b6fab8a3ef5684cd92c8c306bab.tar.gz
ports-e7d17eb8674b0b6fab8a3ef5684cd92c8c306bab.zip
Recompile _sysconfigdata.py after reinplacing it
PR: 246618 With hat: portmgr
Notes
Notes: svn path=/head/; revision=536770
Diffstat (limited to 'lang/python38')
-rw-r--r--lang/python38/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/lang/python38/Makefile b/lang/python38/Makefile
index bf3a72f27576..be8d1548aa24 100644
--- a/lang/python38/Makefile
+++ b/lang/python38/Makefile
@@ -132,6 +132,12 @@ post-install:
.if ${CC} == /nxb-bin/usr/bin/cc
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_m_freebsd${OSREL:R}_.py
+ @cd ${WRKSRC} && ${SETENV} LD_LIBRARY_PATH=${WRKSRC} \
+ ./python -E -m compileall -d ${PREFIX}/lib/python${PYTHON_VER} \
+ ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_m_freebsd${OSREL:R}_.py
+ @cd ${WRKSRC} && ${SETENV} LD_LIBRARY_PATH=${WRKSRC} \
+ ./python -E -O -m compileall -d ${PREFIX}/lib/python${PYTHON_VER} \
+ ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_m_freebsd${OSREL:R}_.py
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/config-${PYTHON_VER}m/Makefile
.endif