aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-20 19:38:18 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-20 19:38:18 +0000
commit337594ad285702299901a50bf686ca547a2f44df (patch)
tree5d646fb6dd5d2f42289ae42466380f3b10870f15 /lang/python
parentae5b3afec891c5c2092ca456f6b31d309f999db4 (diff)
downloadports-337594ad285702299901a50bf686ca547a2f44df.tar.gz
ports-337594ad285702299901a50bf686ca547a2f44df.zip
Fix symbolic links of idle and pydoc
- Bump PORTREVISION for package change - While I'm here: - Remove leading definite article from COMMENT - Fix indent - Add NO_ARCH PR: 216310 Submitted by: Jose M. Alcaide <josemaria.alcaide@ehu.eus> MFH: 2017Q1
Notes
Notes: svn path=/head/; revision=431987
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/Makefile22
1 files changed, 7 insertions, 15 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 8be4596a1ad9..a5790e158259 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -3,7 +3,7 @@
PORTNAME= python
PORTVERSION= ${PYTHON_DEFAULT}
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 2
CATEGORIES= lang python ipv6
MASTER_SITES= # empty
@@ -11,10 +11,11 @@ DISTFILES= # empty
EXTRACT_ONLY= # empty
MAINTAINER= python@FreeBSD.org
-COMMENT= The "meta-port" for the default version of Python interpreter
+COMMENT= "meta-port" for the default version of Python interpreter
-USES= python:run
-NO_BUILD= yes
+USES= python:run
+NO_ARCH= yes
+NO_BUILD= yes
PLIST_FILES= bin/2to3 \
bin/idle \
@@ -31,20 +32,11 @@ RUN_DEPENDS+= python3:lang/python3
.endif
do-install:
- ${LN} -sf python${PYTHON_MAJOR_VER} ${STAGEDIR}${PREFIX}/bin/python
${LN} -sf 2to3-${PYTHON_MAJOR_VER} ${STAGEDIR}${PREFIX}/bin/2to3
-.if ${PYTHON_MAJOR_VER} == 2
-.for file in idle pydoc
+.for file in idle pydoc python
${LN} -sf ${file}${PYTHON_MAJOR_VER} ${STAGEDIR}${PREFIX}/bin/${file}
.endfor
-.elif ${PYTHON_MAJOR_VER} == 3
-.for file in idle pydoc
- ${LN} -sf ${file}${PYTHON_MAJOR_VER}-${PYTHON_VER} \
- ${STAGEDIR}${PREFIX}/bin/${file}
-.endfor
-.endif
- ${LN} -sf python${PYTHON_MAJOR_VER}-config \
- ${STAGEDIR}${PREFIX}/bin/python-config
+ ${LN} -sf python${PYTHON_MAJOR_VER}-config ${STAGEDIR}${PREFIX}/bin/python-config
# Major upgrade support
PORTUPGRADE_CMD= ${LOCALBASE}/sbin/portupgrade