aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorAlexander Botero-Lowry <alexbl@FreeBSD.org>2007-07-30 09:42:28 +0000
committerAlexander Botero-Lowry <alexbl@FreeBSD.org>2007-07-30 09:42:28 +0000
commit4942ce5a7d8a3d0cbebaf4d202011850d1f7569f (patch)
treedb1f21912f461000d609ddcd5d130946bcfe9e09 /lang/python
parentb4be9b354e86bd790925c5a9a2e67df8ba20bc00 (diff)
downloadports-4942ce5a7d8a3d0cbebaf4d202011850d1f7569f.tar.gz
ports-4942ce5a7d8a3d0cbebaf4d202011850d1f7569f.zip
- Make Python 2.5.1 the default Python version
- Add significantly better support in bsd.python.mk for working with Python Eggs and the easy_install system Tested by: pointyhat runs Approved by: pav (portmgr) Most work by: perky Thanks to: pav
Notes
Notes: svn path=/head/; revision=196700
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/Makefile41
-rw-r--r--lang/python/distinfo3
2 files changed, 24 insertions, 20 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index fc1b1a72cc79..3b3a59fc5dd3 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -6,43 +6,44 @@
#
PORTNAME= python
-PORTVERSION= 2.4.4
-PORTEPOCH= 1
+PORTVERSION= ${PYTHON_VER}
+PORTEPOCH= 2
CATEGORIES= lang python ipv6
MASTER_SITES= # empty
DISTFILES= # empty
EXTRACT_ONLY= # empty
MAINTAINER= python@FreeBSD.org
-COMMENT= The "meta-port" for the stable version of Python interpreter
+COMMENT= The "meta-port" for the default version of Python interpreter
USE_PYTHON_RUN= yes
-PYTHON_VERSION= python2.4
+PYTHON_VERSION= ${PYTHON_DEFAULT_VERSION}
NO_BUILD= yes
-do-install: # empty
+do-install:
+ @${DO_NADA}
# Major upgrade support
PORTUPGRADE?= ${LOCALBASE}/sbin/portupgrade
PKG_WHICH?= ${LOCALBASE}/sbin/pkg_which
upgrade-site-packages:
- @if [ -x ${PORTUPGRADE} ]; then \
- for ver in 2.1 2.2 2.3 2.5; do \
- if [ -d ${PREFIX}/lib/python$$ver ]; then \
- UPD=`${FIND} ${PREFIX}/lib/python$$ver \
- -type f -print0 | \
- ${XARGS} -0 ${PKG_WHICH} | \
- ${GREP} -Fv '?' | \
- ${EGREP} -v '^python2?[0-5]?-2' | \
- ${SORT} -u`; \
- if [ "$$UPD" ]; then \
- ${PORTUPGRADE} -f $$UPD; \
- fi; \
- fi; \
- done; \
- else \
+ @if [ ! -x ${PORTUPGRADE} ]; then \
${ECHO_MSG} "Please install ports-mgmt/portupgrade."; \
${FALSE}; \
fi
+ @for ver in `echo ${_PYTHON_ALLBRANCHES}|${SED} 's/${PYTHON_VER}//'`; do \
+ if [ -d ${PREFIX}/lib/python$$ver ]; then \
+ UPD=`${FIND} ${PREFIX}/lib/python$$ver \
+ -type f -print0 | \
+ ${XARGS} -0 ${PKG_WHICH} | \
+ ${GREP} -Fv '?' | \
+ ${EGREP} -v '^python2?[0-5]?-2' | \
+ ${SORT} -u`; \
+ if [ "$$UPD" ]; then \
+ ${PORTUPGRADE} -f $$UPD; \
+ fi; \
+ fi; \
+ done \
+
.include <bsd.port.mk>
diff --git a/lang/python/distinfo b/lang/python/distinfo
index 054d4ecd5c4c..2f175c4a9f78 100644
--- a/lang/python/distinfo
+++ b/lang/python/distinfo
@@ -17,6 +17,7 @@ MD5 (python/Python-2.4.2.tgz) = 07cfc759546f6723bb367be5b1ce9875
MD5 (python/Python-2.4.3.tgz) = edf994473a8c1a963aaa71e442b285b7
MD5 (python/Python-2.4.4.tgz) = 82d000617baaef269ad5795c595fdc58
MD5 (python/Python-2.4.tgz) = 149ad508f936eccf669d52682cf8e606
+MD5 (python/Python-2.5.1.tgz) = cca695828df8adc3e69b637af07522e1
MD5 (python/Python-2.5.tgz) = bc1b74f90a472a6c0a85481aaeb43f95
SHA256 (python/Python-2.1.1.tgz) = 6a5455b2ab72642feffc060a04e8ea543de2d0671a3f9c335b52f2e1e41edc5f
SHA256 (python/Python-2.1.2.tgz) = 389c7badc61f9bdc50788b54dd3ffeaa4b559baf6a4de1425bf90b9c6b4ac66e
@@ -37,6 +38,7 @@ SHA256 (python/Python-2.4.2.tgz) = 2653e1846e87fd9b3ee287fefc965c80c54646548b491
SHA256 (python/Python-2.4.3.tgz) = 985a413932f5e31e6280b37da6b285a3a0b2748c6786643989ed9b23de97e2d5
SHA256 (python/Python-2.4.4.tgz) = 92be6e20cbc3111d9dd0c016d72ef7914c23b879dc52df7ba28df97afbf12e2e
SHA256 (python/Python-2.4.tgz) = ff746de0fae8691c082414b42a2bb172da8797e6e8ff66c9a39d2e452f7034e9
+SHA256 (python/Python-2.5.1.tgz) = 1f5caee846049ca30d996f9403eefdb996295c4af664867e35dcc5eb36e4e7e8
SHA256 (python/Python-2.5.tgz) = d7bbf42e36003c6065cd19f3e67d283521858515ee923220f654131cebe1d8f2
SIZE (python/Python-2.1.1.tgz) = 6187808
SIZE (python/Python-2.1.2.tgz) = 6189889
@@ -57,4 +59,5 @@ SIZE (python/Python-2.4.2.tgz) = 9239975
SIZE (python/Python-2.4.3.tgz) = 9348239
SIZE (python/Python-2.4.4.tgz) = 9531474
SIZE (python/Python-2.4.tgz) = 9198035
+SIZE (python/Python-2.5.1.tgz) = 11060830
SIZE (python/Python-2.5.tgz) = 11019675