aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1996-01-18 10:18:54 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1996-01-18 10:18:54 +0000
commit6534821fdbcdc970244fffab1d3be8547ac58439 (patch)
treeb19121bbb864df5c4c32a54e9e098c1ce51bbab2 /lang/python
parentdc15e8883b9615c15fc6c0401c1f84d296908ada (diff)
downloadports-6534821fdbcdc970244fffab1d3be8547ac58439.tar.gz
ports-6534821fdbcdc970244fffab1d3be8547ac58439.zip
Notes
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/Makefile29
-rw-r--r--lang/python/distinfo2
-rw-r--r--lang/python/files/Setup63
-rw-r--r--lang/python/pkg-plist907
4 files changed, 548 insertions, 453 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 502235016a44..2fe0727106d7 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -3,26 +3,33 @@
# Date created: 08 August 1995
# Whom: jkh
#
-# $Id: Makefile,v 1.2 1995/08/09 01:30:00 asami Exp $
+# $Id: Makefile,v 1.3 1995/11/22 13:13:06 asami Exp $
#
-DISTNAME= python1.2
-PKGNAME= python-1.2
+DISTNAME= python1.3
+PKGNAME= python-1.3
CATEGORIES+= lang
-MASTER_SITES= ftp://www.python.org/pub/python/src/
+MASTER_SITES= ftp://www.python.org/pub/python/src/ \
+ ftp://ftp.cwi.nl/pub/python/src/
MAINTAINER= jkh@FreeBSD.org
-LIB_DEPENDS= tcl\\.7\\.:${PORTSDIR}/lang/tcl \
- tk\\.3\\.:${PORTSDIR}/x11/tk
+LIB_DEPENDS= tcl74\\.1\\.:${PORTSDIR}/lang/tcl74 \
+ tk40\\.1\\.:${PORTSDIR}/x11/tk4
+
+WRKSRC= ${WRKDIR}/Python-1.3
+HAS_CONFIGURE= yes
+
+MAKE_FLAGS+= 'OPT=${CFLAGS}'
+INSTALL_TARGET= install libinstall maninstall
post-configure:
cp ${FILESDIR}/Setup ${WRKSRC}/Modules
-pre-install:
- cd ${WRKSRC}; ${MAKE} libinstall
-
-WRKSRC= ${WRKDIR}/Python-1.2
-HAS_CONFIGURE= yes
+post-install:
+ strip ${PREFIX}/bin/python
+.if !defined(NOMANCOMPRESS)
+ gzip -9nf ${PREFIX}/man/man1/python.1
+.endif
.include <bsd.port.mk>
diff --git a/lang/python/distinfo b/lang/python/distinfo
index c2ecc13bd8c1..6a340d74c113 100644
--- a/lang/python/distinfo
+++ b/lang/python/distinfo
@@ -1 +1 @@
-MD5 (python1.2.tar.gz) = f4a9c715b24c680ddfed9c5378ec09a0
+MD5 (python1.3.tar.gz) = 23f9d7cba017e0df1752377b514b0bbe
diff --git a/lang/python/files/Setup b/lang/python/files/Setup
index b840d2860e0d..d7ebe4ebbfbb 100644
--- a/lang/python/files/Setup
+++ b/lang/python/files/Setup
@@ -51,7 +51,13 @@
# Don't add any whitespace or comments!
# Don't edit this (usually)
-DESTLIB=$(prefix)/lib/python
+DESTLIB=$(prefix)/share/python
+
+# Site specific path insertions -- should begin with : if non-empty
+SITEPATH=
+
+# Standard path -- don't edit
+DESTPATH=:$(DESTLIB)
# Standard enabled (tests are always available)
TESTPATH=:$(DESTLIB)/test
@@ -59,7 +65,7 @@ TESTPATH=:$(DESTLIB)/test
# Path for machine- or system-dependent modules (and shared libraries)
MACHDEPPATH=:$(DESTLIB)/$(MACHDEP)
-COREPYTHONPATH=.:$(DESTLIB)$(TESTPATH)$(MACHDEPPATH)$(STDWINPATH)$(TKPATH)
+COREPYTHONPATH=.$(SITEPATH)$(DESTPATH)$(TESTPATH)$(MACHDEPPATH)$(STDWINPATH)$(TKPATH)
PYTHONPATH=$(COREPYTHONPATH)
@@ -94,7 +100,6 @@ signal signalmodule.c # signal(2)
array arraymodule.c # array objects
math mathmodule.c -lm # math library functions, e.g. sin()
-parser parsermodule.c # raw interface to the Python parser
regex regexmodule.c regexpr.c # Regular expressions, GNU Emacs style
strop stropmodule.c # fast string operations implemented in C
struct structmodule.c # binary structure packing/unpacking
@@ -136,7 +141,7 @@ rgbimg rgbimgmodule.c # Read SGI RGB image files (but coded portably)
# STDWIN toplevel directory.
# Uncomment and edit as needed:
-#STDWIN=/usr/ports/devel/stdwin/work/stdwin1.0
+#STDWIN=/ufs/guido/src/stdwin
# Uncomment these lines:
#STDWINPATH=:$(DESTLIB)/stdwin
@@ -227,12 +232,10 @@ md5 md5module.c md5c.c
#
# In all cases also enable the last line (TKPATH).
#
-# This was designed to build with Tk 3.6 and Tcl 7.3, but also seems
-# to work Tk 4.0 beta. (Tkinter.py hasn't been fixed though, so for
-# the time being Tk 3.6 is the version of choice!)
+# See the section "The Tk interface" in ../README for more info.
# *** Use ONE of the following two lines, see previous comments ***
-tkinter tkintermodule.c -I/usr/local/include -I/usr/X11R6/include -L/usr/local/lib -L/usr/X11R6/lib -ltk -ltcl -lX11
+tkinter tkintermodule.c -I/usr/local/include -I/usr/X11R6/include -L/usr/local/lib -L/usr/X11R6/lib -ltk40 -ltcl74 -lX11
#tkinter tkintermodule.c tkappinit.c -DWITH_APPINIT -I/usr/local/include -L/usr/local/lib -ltk -ltcl -lX11
# *** ALWAYS use this line as well ***
@@ -243,8 +246,14 @@ TKPATH=:$(DESTLIB)/tkinter
rotor rotormodule.c # enigma-inspired encryption
syslog syslogmodule.c # syslog daemon interface
-curses cursesmodule.c -lncurses -ltermcap # guess what?
- # (On Linux, try -lncurses)
+
+
+# Lance's curses module. This requires the System V version of
+# curses, sometimes known as ncurses (e.g. on Linux, link with
+# -lncurses instead of -lcurses; on SunOS 4.1.3, insert -I/usr/5include
+# -L/usr/5lib before -lcurses).
+
+curses cursesmodule.c -lncurses -ltermcap
@@ -254,6 +263,7 @@ curses cursesmodule.c -lncurses -ltermcap # guess what?
# John Redford's sybase module (requires sybase):
+# (Unfortunately this code is orphaned. Read the source for documentation.)
#sybase sybasemodule.c
@@ -272,5 +282,38 @@ curses cursesmodule.c -lncurses -ltermcap # guess what?
#gdbm gdbmmodule.c -I/usr/local/include -L/usr/local/lib -lgdbm
+# Berkeley DB interface.
+#
+# This requires the Berkeley DB code, see
+# ftp://ftp.cs.berkeley.edu/pub/4bsd/db.1.85.tar.gz
+#
+# Edit the variables DB and DBPORT to point to the db top directory
+# and the subdirectory of PORT where you built it.
+
+#DB=/depot/sundry/src/db.1.85/
+#DBPORT=$(DB)/PORT/sunos.5.2
+#bsddb bsddbmodule.o -I$(DB)/include -I$(DBPORT) $(DBPORT)/libdb.a
+bsddb bsddbmodule.o
+
+
+
+# Andy Bensky's "environment" module (contains putenv())
+environment environment.c
+
+# David Wayne Williams' soundex module
+#soundex soundex.c
+
+# Objective-C (incomplete!!!)
+#objc.c
+
+# Helper module for various ascii-encoders
+binascii binascii.c
+
+# Fred Drake's interface to the Python parser.
+# (Not enabled by default because it is big and doesn't compile with
+# cc on SunOS 4.1.3)
+#parser parsermodule.c
+
+
# Example -- included for reference only:
# xx xxmodule.c
diff --git a/lang/python/pkg-plist b/lang/python/pkg-plist
index 834deb507808..c6d3df3e09e0 100644
--- a/lang/python/pkg-plist
+++ b/lang/python/pkg-plist
@@ -1,432 +1,477 @@
bin/python
-@exec mkdir -p %D/lib/python/freebsd2
-@unexec rmdir %D/lib/python/freebsd2
-lib/python/tkinter/Canvas.py
-lib/python/tkinter/Dialog.py
-lib/python/tkinter/ScrolledText.py
-lib/python/tkinter/Tkinter.py
-lib/python/tkinter/Canvas.pyc
-lib/python/tkinter/Dialog.pyc
-lib/python/tkinter/ScrolledText.pyc
-lib/python/tkinter/Tkinter.pyc
-lib/python/mac/socket.py
-lib/python/mac/EasyDialogs.py
-lib/python/mac/FrameWork.py
-lib/python/mac/MACTCP.py
-lib/python/mac/MacTCPerrors.py
-lib/python/mac/SoundMgr.py
-lib/python/mac/dbmac.py
-lib/python/mac/maccache.py
-lib/python/mac/macpath.py
-lib/python/mac/Audio_mac.py
-lib/python/mac/Audio_mac.pyc
-lib/python/mac/EasyDialogs.pyc
-lib/python/mac/FrameWork.pyc
-lib/python/mac/MACTCP.pyc
-lib/python/mac/MacTCPerrors.pyc
-lib/python/mac/SoundMgr.pyc
-lib/python/mac/dbmac.pyc
-lib/python/mac/maccache.pyc
-lib/python/mac/macpath.pyc
-lib/python/mac/socket.pyc
-lib/python/test/testall.py
-lib/python/test/test.rawimg
-lib/python/test/test.rawimg.rev
-lib/python/test/test.rgb
-lib/python/test/test_audioop.py
-lib/python/test/test_b1.py
-lib/python/test/test_b2.py
-lib/python/test/test_builtin.py
-lib/python/test/test_exceptions.py
-lib/python/test/test_grammar.py
-lib/python/test/test_md5.py
-lib/python/test/test_opcodes.py
-lib/python/test/test_operations.py
-lib/python/test/test_pow.py
-lib/python/test/test_rgbimg.py
-lib/python/test/test_select.py
-lib/python/test/test_signal.py
-lib/python/test/test_support.py
-lib/python/test/test_thread.py
-lib/python/test/test_types.py
-lib/python/test/testall.out
-lib/python/test/autotest.py
-lib/python/test/autotest.pyc
-lib/python/test/test_audioop.pyc
-lib/python/test/test_b1.pyc
-lib/python/test/test_b2.pyc
-lib/python/test/test_builtin.pyc
-lib/python/test/test_exceptions.pyc
-lib/python/test/test_grammar.pyc
-lib/python/test/test_md5.pyc
-lib/python/test/test_opcodes.pyc
-lib/python/test/test_operations.pyc
-lib/python/test/test_pow.pyc
-lib/python/test/test_rgbimg.pyc
-lib/python/test/test_select.pyc
-lib/python/test/test_signal.pyc
-lib/python/test/test_support.pyc
-lib/python/test/test_thread.pyc
-lib/python/test/test_types.pyc
-lib/python/test/testall.pyc
-lib/python/linux/FCNTL.py
-lib/python/linux/IN.py
-lib/python/linux/SOCKET.py
-lib/python/linux/TERMIOS.py
-lib/python/linux/regen
-lib/python/linux/FCNTL.pyc
-lib/python/linux/IN.pyc
-lib/python/linux/SOCKET.pyc
-lib/python/linux/TERMIOS.pyc
-lib/python/sunos4/FCNTL.py
-lib/python/sunos4/IN.py
-lib/python/sunos4/SOCKET.py
-lib/python/sunos4/SUNAUDIODEV.py
-lib/python/sunos4/WAIT.py
-lib/python/sunos4/regen
-lib/python/sunos4/FCNTL.pyc
-lib/python/sunos4/IN.pyc
-lib/python/sunos4/SOCKET.pyc
-lib/python/sunos4/SUNAUDIODEV.pyc
-lib/python/sunos4/WAIT.pyc
-lib/python/irix5/torgb.py
-lib/python/irix5/AWARE.py
-lib/python/irix5/CD.py
-lib/python/irix5/CL.py
-lib/python/irix5/DEVICE.py
-lib/python/irix5/FCNTL.py
-lib/python/irix5/FL.py
-lib/python/irix5/GET.py
-lib/python/irix5/GL.py
-lib/python/irix5/GLWS.py
-lib/python/irix5/IN.py
-lib/python/irix5/IOCTL.py
-lib/python/irix5/SOCKET.py
-lib/python/irix5/SV.py
-lib/python/irix5/TERMIOS.py
-lib/python/irix5/WAIT.py
-lib/python/irix5/auds.py
-lib/python/irix5/cddb.py
-lib/python/irix5/cdplayer.py
-lib/python/irix5/flp.doc
-lib/python/irix5/flp.py
-lib/python/irix5/jpeg.py
-lib/python/irix5/panel.py
-lib/python/irix5/panelparser.py
-lib/python/irix5/readcd.doc
-lib/python/irix5/readcd.py
-lib/python/irix5/regen
-lib/python/irix5/AL.py
-lib/python/irix5/AL.pyc
-lib/python/irix5/AWARE.pyc
-lib/python/irix5/CD.pyc
-lib/python/irix5/CL.pyc
-lib/python/irix5/DEVICE.pyc
-lib/python/irix5/FCNTL.pyc
-lib/python/irix5/FL.pyc
-lib/python/irix5/GET.pyc
-lib/python/irix5/GL.pyc
-lib/python/irix5/GLWS.pyc
-lib/python/irix5/IN.pyc
-lib/python/irix5/IOCTL.pyc
-lib/python/irix5/SOCKET.pyc
-lib/python/irix5/SV.pyc
-lib/python/irix5/TERMIOS.pyc
-lib/python/irix5/WAIT.pyc
-lib/python/irix5/auds.pyc
-lib/python/irix5/cddb.pyc
-lib/python/irix5/cdplayer.pyc
-lib/python/irix5/flp.pyc
-lib/python/irix5/jpeg.pyc
-lib/python/irix5/panel.pyc
-lib/python/irix5/panelparser.pyc
-lib/python/irix5/readcd.pyc
-lib/python/irix5/torgb.pyc
-lib/python/sunos5/FCNTL.py
-lib/python/sunos5/IN.py
-lib/python/sunos5/SOCKET.py
-lib/python/sunos5/SUNAUDIODEV.py
-lib/python/sunos5/TERMIOS.py
-lib/python/sunos5/regen
-lib/python/sunos5/FCNTL.pyc
-lib/python/sunos5/IN.pyc
-lib/python/sunos5/SOCKET.pyc
-lib/python/sunos5/SUNAUDIODEV.pyc
-lib/python/sunos5/TERMIOS.pyc
-lib/python/stdwin/wdbsrcwin.py
-lib/python/stdwin/BoxParent.py
-lib/python/stdwin/Buttons.py
-lib/python/stdwin/CSplit.py
-lib/python/stdwin/DirList.py
-lib/python/stdwin/FormSplit.py
-lib/python/stdwin/HVSplit.py
-lib/python/stdwin/Histogram.py
-lib/python/stdwin/Sliders.py
-lib/python/stdwin/Soundogram.py
-lib/python/stdwin/Split.py
-lib/python/stdwin/StripChart.py
-lib/python/stdwin/TextEdit.py
-lib/python/stdwin/TransParent.py
-lib/python/stdwin/VUMeter.py
-lib/python/stdwin/WindowParent.py
-lib/python/stdwin/WindowSched.py
-lib/python/stdwin/anywin.py
-lib/python/stdwin/basewin.py
-lib/python/stdwin/dirwin.py
-lib/python/stdwin/filewin.py
-lib/python/stdwin/formatter.py
-lib/python/stdwin/gwin.py
-lib/python/stdwin/listwin.py
-lib/python/stdwin/mainloop.py
-lib/python/stdwin/rect.py
-lib/python/stdwin/srcwin.py
-lib/python/stdwin/stdwinevents.py
-lib/python/stdwin/stdwinq.py
-lib/python/stdwin/tablewin.py
-lib/python/stdwin/textwin.py
-lib/python/stdwin/wdb.py
-lib/python/stdwin/wdbframewin.py
-lib/python/stdwin/Abstract.py
-lib/python/stdwin/Abstract.pyc
-lib/python/stdwin/BoxParent.pyc
-lib/python/stdwin/Buttons.pyc
-lib/python/stdwin/CSplit.pyc
-lib/python/stdwin/DirList.pyc
-lib/python/stdwin/FormSplit.pyc
-lib/python/stdwin/HVSplit.pyc
-lib/python/stdwin/Histogram.pyc
-lib/python/stdwin/Sliders.pyc
-lib/python/stdwin/Soundogram.pyc
-lib/python/stdwin/Split.pyc
-lib/python/stdwin/StripChart.pyc
-lib/python/stdwin/TextEdit.pyc
-lib/python/stdwin/TransParent.pyc
-lib/python/stdwin/VUMeter.pyc
-lib/python/stdwin/WindowParent.pyc
-lib/python/stdwin/WindowSched.pyc
-lib/python/stdwin/anywin.pyc
-lib/python/stdwin/basewin.pyc
-lib/python/stdwin/dirwin.pyc
-lib/python/stdwin/filewin.pyc
-lib/python/stdwin/formatter.pyc
-lib/python/stdwin/gwin.pyc
-lib/python/stdwin/listwin.pyc
-lib/python/stdwin/mainloop.pyc
-lib/python/stdwin/rect.pyc
-lib/python/stdwin/srcwin.pyc
-lib/python/stdwin/stdwinevents.pyc
-lib/python/stdwin/stdwinq.pyc
-lib/python/stdwin/tablewin.pyc
-lib/python/stdwin/textwin.pyc
-lib/python/stdwin/wdb.pyc
-lib/python/stdwin/wdbframewin.pyc
-lib/python/stdwin/wdbsrcwin.pyc
-lib/python/tzparse.py
-lib/python/types.py
-lib/python/tty.py
-lib/python/traceback.py
-lib/python/tokenize.py
-lib/python/token.py
-lib/python/toaiff.py
-lib/python/tempfile.py
-lib/python/tb.py
-lib/python/symbol.py
-lib/python/sunaudio.py
-lib/python/sunau.py
-lib/python/string.py
-lib/python/statcache.py
-lib/python/stat.py
-lib/python/sndhdr.py
-lib/python/shutil.py
-lib/python/shelve.py
-lib/python/sgmllib.py
-lib/python/sched.py
-lib/python/rfc822.py
-lib/python/rexec.py
-lib/python/repr.py
-lib/python/regsub.py
-lib/python/regexp.py
-lib/python/regex_syntax.py
-lib/python/random.py
-lib/python/rand.py
-lib/python/py_compile.py
-lib/python/pty.py
-lib/python/pstats.py
-lib/python/profile.py
-lib/python/profile.doc
-lib/python/posixpath.py
-lib/python/posixfile.py
-lib/python/popen2.py
-lib/python/poly.py
-lib/python/pipes.py
-lib/python/pickle.py
-lib/python/persist.py
-lib/python/pdb.py
-lib/python/pdb.doc
-lib/python/packmail.py
-lib/python/ospath.py
-lib/python/os.py
-lib/python/ntpath.py
-lib/python/nntplib.py
-lib/python/newimp.py
-lib/python/newdir.py
-lib/python/mutex.py
-lib/python/multifile.py
-lib/python/mimetools.py
-lib/python/mhlib.py
-lib/python/mailbox.py
-lib/python/lockfile.py
-lib/python/linecache.py
-lib/python/importall.py
-lib/python/imghdr.py
-lib/python/httplib.py
-lib/python/htmllib.py
-lib/python/grep.py
-lib/python/gopherlib.py
-lib/python/glob.py
-lib/python/getopt.py
-lib/python/ftplib.py
-lib/python/fpformat.py
-lib/python/fnmatch.py
-lib/python/fmt.py
-lib/python/find.py
-lib/python/emacs.py
-lib/python/dump.py
-lib/python/dospath.py
-lib/python/dis.py
-lib/python/dircmp.py
-lib/python/dircache.py
-lib/python/copy.py
-lib/python/compileall.py
-lib/python/commands.py
-lib/python/colorsys.py
-lib/python/codehack.py
-lib/python/cmpcache.py
-lib/python/cmp.py
-lib/python/cmd.py
-lib/python/cgi.py
-lib/python/calendar.py
-lib/python/bisect.py
-lib/python/bdb.py
-lib/python/audiodev.py
-lib/python/anydbm.py
-lib/python/aifc.py
-lib/python/addpack.py
-lib/python/UserList.py
-lib/python/UserDict.py
-lib/python/StringIO.py
-lib/python/Queue.py
-lib/python/Para.py
-lib/python/Makefile
-lib/python/zmod.py
-lib/python/Complex.py
-lib/python/whrandom.py
-lib/python/whatsound.py
-lib/python/wave.py
-lib/python/uu.py
-lib/python/util.py
-lib/python/urlparse.py
-lib/python/urllib.py
-lib/python/os.pyc
-lib/python/posixpath.pyc
-lib/python/stat.pyc
-lib/python/py_compile.pyc
-lib/python/getopt.pyc
-lib/python/Complex.pyc
-lib/python/Para.pyc
-lib/python/Queue.pyc
-lib/python/StringIO.pyc
-lib/python/UserDict.pyc
-lib/python/UserList.pyc
-lib/python/addpack.pyc
-lib/python/aifc.pyc
-lib/python/anydbm.pyc
-lib/python/audiodev.pyc
-lib/python/bdb.pyc
-lib/python/bisect.pyc
-lib/python/calendar.pyc
-lib/python/cgi.pyc
-lib/python/cmd.pyc
-lib/python/cmp.pyc
-lib/python/cmpcache.pyc
-lib/python/codehack.pyc
-lib/python/colorsys.pyc
-lib/python/commands.pyc
-lib/python/compileall.pyc
-lib/python/copy.pyc
-lib/python/dircache.pyc
-lib/python/dircmp.pyc
-lib/python/dis.pyc
-lib/python/dospath.pyc
-lib/python/dump.pyc
-lib/python/emacs.pyc
-lib/python/find.pyc
-lib/python/fmt.pyc
-lib/python/fnmatch.pyc
-lib/python/fpformat.pyc
-lib/python/ftplib.pyc
-lib/python/glob.pyc
-lib/python/gopherlib.pyc
-lib/python/grep.pyc
-lib/python/htmllib.pyc
-lib/python/httplib.pyc
-lib/python/imghdr.pyc
-lib/python/importall.pyc
-lib/python/linecache.pyc
-lib/python/lockfile.pyc
-lib/python/mailbox.pyc
-lib/python/mhlib.pyc
-lib/python/mimetools.pyc
-lib/python/multifile.pyc
-lib/python/mutex.pyc
-lib/python/newdir.pyc
-lib/python/newimp.pyc
-lib/python/nntplib.pyc
-lib/python/ntpath.pyc
-lib/python/ospath.pyc
-lib/python/packmail.pyc
-lib/python/pdb.pyc
-lib/python/persist.pyc
-lib/python/pickle.pyc
-lib/python/pipes.pyc
-lib/python/poly.pyc
-lib/python/popen2.pyc
-lib/python/posixfile.pyc
-lib/python/profile.pyc
-lib/python/pstats.pyc
-lib/python/pty.pyc
-lib/python/rand.pyc
-lib/python/random.pyc
-lib/python/regex_syntax.pyc
-lib/python/regexp.pyc
-lib/python/regsub.pyc
-lib/python/repr.pyc
-lib/python/rexec.pyc
-lib/python/rfc822.pyc
-lib/python/sched.pyc
-lib/python/sgmllib.pyc
-lib/python/shelve.pyc
-lib/python/shutil.pyc
-lib/python/sndhdr.pyc
-lib/python/statcache.pyc
-lib/python/string.pyc
-lib/python/sunau.pyc
-lib/python/sunaudio.pyc
-lib/python/symbol.pyc
-lib/python/tb.pyc
-lib/python/tempfile.pyc
-lib/python/tty.pyc
-lib/python/toaiff.pyc
-lib/python/token.pyc
-lib/python/tokenize.pyc
-lib/python/traceback.pyc
-lib/python/types.pyc
-lib/python/tzparse.pyc
-lib/python/urllib.pyc
-lib/python/urlparse.pyc
-lib/python/util.pyc
-lib/python/uu.pyc
-lib/python/wave.pyc
-lib/python/whatsound.pyc
-lib/python/whrandom.pyc
-lib/python/zmod.pyc
+@exec mkdir -p %D/share/python/freebsd2
+@unexec rmdir %D/share/python/freebsd2
+share/python/stdwin/wdbsrcwin.py
+share/python/stdwin/BoxParent.py
+share/python/stdwin/Buttons.py
+share/python/stdwin/CSplit.py
+share/python/stdwin/DirList.py
+share/python/stdwin/FormSplit.py
+share/python/stdwin/HVSplit.py
+share/python/stdwin/Histogram.py
+share/python/stdwin/Sliders.py
+share/python/stdwin/Soundogram.py
+share/python/stdwin/Split.py
+share/python/stdwin/StripChart.py
+share/python/stdwin/TextEdit.py
+share/python/stdwin/TransParent.py
+share/python/stdwin/VUMeter.py
+share/python/stdwin/WindowParent.py
+share/python/stdwin/WindowSched.py
+share/python/stdwin/anywin.py
+share/python/stdwin/basewin.py
+share/python/stdwin/dirwin.py
+share/python/stdwin/filewin.py
+share/python/stdwin/formatter.py
+share/python/stdwin/gwin.py
+share/python/stdwin/listwin.py
+share/python/stdwin/mainloop.py
+share/python/stdwin/rect.py
+share/python/stdwin/srcwin.py
+share/python/stdwin/stdwinevents.py
+share/python/stdwin/stdwinq.py
+share/python/stdwin/tablewin.py
+share/python/stdwin/textwin.py
+share/python/stdwin/wdb.py
+share/python/stdwin/wdbframewin.py
+share/python/stdwin/Abstract.py
+share/python/stdwin/Abstract.pyc
+share/python/stdwin/BoxParent.pyc
+share/python/stdwin/Buttons.pyc
+share/python/stdwin/CSplit.pyc
+share/python/stdwin/DirList.pyc
+share/python/stdwin/FormSplit.pyc
+share/python/stdwin/HVSplit.pyc
+share/python/stdwin/Histogram.pyc
+share/python/stdwin/Sliders.pyc
+share/python/stdwin/Soundogram.pyc
+share/python/stdwin/Split.pyc
+share/python/stdwin/StripChart.pyc
+share/python/stdwin/TextEdit.pyc
+share/python/stdwin/TransParent.pyc
+share/python/stdwin/VUMeter.pyc
+share/python/stdwin/WindowParent.pyc
+share/python/stdwin/WindowSched.pyc
+share/python/stdwin/anywin.pyc
+share/python/stdwin/basewin.pyc
+share/python/stdwin/dirwin.pyc
+share/python/stdwin/filewin.pyc
+share/python/stdwin/formatter.pyc
+share/python/stdwin/gwin.pyc
+share/python/stdwin/listwin.pyc
+share/python/stdwin/mainloop.pyc
+share/python/stdwin/rect.pyc
+share/python/stdwin/srcwin.pyc
+share/python/stdwin/stdwinevents.pyc
+share/python/stdwin/stdwinq.pyc
+share/python/stdwin/tablewin.pyc
+share/python/stdwin/textwin.pyc
+share/python/stdwin/wdb.pyc
+share/python/stdwin/wdbframewin.pyc
+share/python/stdwin/wdbsrcwin.pyc
+share/python/linux1
+share/python/linux1/FCNTL.py
+share/python/linux1/IN.py
+share/python/linux1/SOCKET.py
+share/python/linux1/TERMIOS.py
+share/python/linux1/regen
+share/python/linux1/FCNTL.pyc
+share/python/linux1/IN.pyc
+share/python/linux1/SOCKET.pyc
+share/python/linux1/TERMIOS.pyc
+share/python/sunos4
+share/python/sunos4/FCNTL.py
+share/python/sunos4/IN.py
+share/python/sunos4/SOCKET.py
+share/python/sunos4/SUNAUDIODEV.py
+share/python/sunos4/WAIT.py
+share/python/sunos4/regen
+share/python/sunos4/FCNTL.pyc
+share/python/sunos4/IN.pyc
+share/python/sunos4/SOCKET.pyc
+share/python/sunos4/SUNAUDIODEV.pyc
+share/python/sunos4/WAIT.pyc
+share/python/irix5
+share/python/irix5/torgb.py
+share/python/irix5/AWARE.py
+share/python/irix5/CD.py
+share/python/irix5/CL.py
+share/python/irix5/CL_old.py
+share/python/irix5/DEVICE.py
+share/python/irix5/ERRNO.py
+share/python/irix5/FCNTL.py
+share/python/irix5/FL.py
+share/python/irix5/GET.py
+share/python/irix5/GL.py
+share/python/irix5/GLWS.py
+share/python/irix5/IN.py
+share/python/irix5/IOCTL.py
+share/python/irix5/SOCKET.py
+share/python/irix5/SV.py
+share/python/irix5/TERMIOS.py
+share/python/irix5/WAIT.py
+share/python/irix5/auds.py
+share/python/irix5/cddb.py
+share/python/irix5/cdplayer.py
+share/python/irix5/flp.doc
+share/python/irix5/flp.py
+share/python/irix5/jpeg.py
+share/python/irix5/panel.py
+share/python/irix5/panelparser.py
+share/python/irix5/readcd.doc
+share/python/irix5/readcd.py
+share/python/irix5/regen
+share/python/irix5/AL.py
+share/python/irix5/AL.pyc
+share/python/irix5/AWARE.pyc
+share/python/irix5/CD.pyc
+share/python/irix5/CL.pyc
+share/python/irix5/CL_old.pyc
+share/python/irix5/DEVICE.pyc
+share/python/irix5/ERRNO.pyc
+share/python/irix5/FCNTL.pyc
+share/python/irix5/FL.pyc
+share/python/irix5/GET.pyc
+share/python/irix5/GL.pyc
+share/python/irix5/GLWS.pyc
+share/python/irix5/IN.pyc
+share/python/irix5/IOCTL.pyc
+share/python/irix5/SOCKET.pyc
+share/python/irix5/SV.pyc
+share/python/irix5/TERMIOS.pyc
+share/python/irix5/WAIT.pyc
+share/python/irix5/auds.pyc
+share/python/irix5/cddb.pyc
+share/python/irix5/cdplayer.pyc
+share/python/irix5/flp.pyc
+share/python/irix5/jpeg.pyc
+share/python/irix5/panel.pyc
+share/python/irix5/panelparser.pyc
+share/python/irix5/readcd.pyc
+share/python/irix5/torgb.pyc
+share/python/sunos5
+share/python/sunos5/FCNTL.py
+share/python/sunos5/IN.py
+share/python/sunos5/SOCKET.py
+share/python/sunos5/SUNAUDIODEV.py
+share/python/sunos5/TERMIOS.py
+share/python/sunos5/regen
+share/python/sunos5/FCNTL.pyc
+share/python/sunos5/IN.pyc
+share/python/sunos5/SOCKET.pyc
+share/python/sunos5/SUNAUDIODEV.pyc
+share/python/sunos5/TERMIOS.pyc
+share/python/test
+share/python/test/test_types.pyc
+share/python/test/test.rawimg
+share/python/test/test.rawimg.rev
+share/python/test/test.rgb
+share/python/test/test_audioop.py
+share/python/test/test_b1.py
+share/python/test/test_b2.py
+share/python/test/test_builtin.py
+share/python/test/test_exceptions.py
+share/python/test/test_grammar.py
+share/python/test/test_md5.py
+share/python/test/test_opcodes.py
+share/python/test/test_operations.py
+share/python/test/test_pow.py
+share/python/test/test_rgbimg.py
+share/python/test/test_select.py
+share/python/test/test_signal.py
+share/python/test/test_support.py
+share/python/test/test_thread.py
+share/python/test/test_types.py
+share/python/test/testall.out
+share/python/test/testall.py
+share/python/test/autotest.pyc
+share/python/test/testall.pyc
+share/python/test/test_support.pyc
+share/python/test/test_grammar.pyc
+share/python/test/test_opcodes.pyc
+share/python/test/test_operations.pyc
+share/python/test/test_builtin.pyc
+share/python/test/test_b1.pyc
+share/python/test/test_b2.pyc
+share/python/test/test_exceptions.pyc
+share/python/test/autotest.py
+share/python/test/test_audioop.pyc
+share/python/test/test_md5.pyc
+share/python/test/test_pow.pyc
+share/python/test/test_rgbimg.pyc
+share/python/test/test_select.pyc
+share/python/test/test_signal.pyc
+share/python/test/test_thread.pyc
+share/python/tkinter
+share/python/tkinter/README
+share/python/tkinter/Dialog.py
+share/python/tkinter/FileDialog.py
+share/python/tkinter/Canvas.py
+share/python/tkinter/ScrolledText.py
+share/python/tkinter/Tkconstants.py
+share/python/tkinter/Tkinter.py
+share/python/tkinter/Canvas.pyc
+share/python/tkinter/Dialog.pyc
+share/python/tkinter/FileDialog.pyc
+share/python/tkinter/ScrolledText.pyc
+share/python/tkinter/Tkconstants.pyc
+share/python/tkinter/Tkinter.pyc
+share/python/mac
+share/python/mac/socket.py
+share/python/mac/EasyDialogs.py
+share/python/mac/FrameWork.py
+share/python/mac/MACFS.py
+share/python/mac/MACTCP.py
+share/python/mac/MacTCPerrors.py
+share/python/mac/SoundMgr.py
+share/python/mac/dbmac.py
+share/python/mac/maccache.py
+share/python/mac/macostools.py
+share/python/mac/Audio_mac.py
+share/python/mac/Audio_mac.pyc
+share/python/mac/EasyDialogs.pyc
+share/python/mac/FrameWork.pyc
+share/python/mac/MACFS.pyc
+share/python/mac/MACTCP.pyc
+share/python/mac/MacTCPerrors.pyc
+share/python/mac/SoundMgr.pyc
+share/python/mac/dbmac.pyc
+share/python/mac/maccache.pyc
+share/python/mac/macostools.pyc
+share/python/mac/socket.pyc
+share/python/tzparse.py
+share/python/types.py
+share/python/tty.py
+share/python/traceback.py
+share/python/tokenize.py
+share/python/token.py
+share/python/toaiff.py
+share/python/tempfile.py
+share/python/tb.py
+share/python/symbol.py
+share/python/sunaudio.py
+share/python/sunau.py
+share/python/string.pyc
+share/python/string.py
+share/python/statcache.py
+share/python/stat.pyc
+share/python/stat.py
+share/python/sndhdr.py
+share/python/shutil.py
+share/python/shelve.py
+share/python/sgmllib.py
+share/python/sched.py
+share/python/rfc822.py
+share/python/rexec.py
+share/python/repr.py
+share/python/regsub.py
+share/python/regexp.py
+share/python/regex_syntax.py
+share/python/random.py
+share/python/rand.py
+share/python/quopri.py
+share/python/pyclbr.py
+share/python/py_compile.py
+share/python/pty.py
+share/python/pstats.py
+share/python/profile.py
+share/python/profile.doc
+share/python/posixpath.pyc
+share/python/posixpath.py
+share/python/posixfile.py
+share/python/popen2.py
+share/python/poly.py
+share/python/pipes.py
+share/python/pickle.py
+share/python/pdb.py
+share/python/pdb.doc
+share/python/packmail.py
+share/python/ospath.py
+share/python/os.pyc
+share/python/os.py
+share/python/ntpath.py
+share/python/nntplib.py
+share/python/ni.py
+share/python/newdir.py
+share/python/mutex.py
+share/python/multifile.py
+share/python/mimetools.py
+share/python/mhlib.py
+share/python/mailcap.py
+share/python/mailbox.py
+share/python/macpath.py
+share/python/lockfile.py
+share/python/linecache.py
+share/python/importall.py
+share/python/imghdr.py
+share/python/ihooks.py
+share/python/httplib.py
+share/python/htmllib.py
+share/python/grep.py
+share/python/htmlentitydefs.py
+share/python/gopherlib.py
+share/python/glob.py
+share/python/getopt.py
+share/python/ftplib.py
+share/python/fpformat.py
+share/python/formatter.py
+share/python/fnmatch.py
+share/python/fmt.py
+share/python/find.py
+share/python/emacs.py
+share/python/dump.py
+share/python/dumbdbm.py
+share/python/dospath.py
+share/python/dis.py
+share/python/dircmp.py
+share/python/dircache.py
+share/python/copy.py
+share/python/compileall.py
+share/python/commands.py
+share/python/colorsys.py
+share/python/codehack.py
+share/python/cmpcache.py
+share/python/cmp.py
+share/python/cmd.py
+share/python/cgi.py
+share/python/calendar.py
+share/python/bisect.py
+share/python/binhex.py
+share/python/bdb.py
+share/python/base64.py
+share/python/audiodev.py
+share/python/anydbm.py
+share/python/aifc.py
+share/python/addpack.py
+share/python/UserList.py
+share/python/UserDict.py
+share/python/StringIO.py
+share/python/SocketServer.py
+share/python/SimpleHTTPServer.py
+share/python/Queue.py
+share/python/Para.py
+share/python/Makefile
+share/python/Complex.py
+share/python/CGIHTTPServer.py
+share/python/zmod.py
+share/python/BaseHTTPServer.py
+share/python/whrandom.py
+share/python/whatsound.py
+share/python/wave.py
+share/python/uu.py
+share/python/util.py
+share/python/urlparse.py
+share/python/urllib.py
+share/python/py_compile.pyc
+share/python/getopt.pyc
+share/python/BaseHTTPServer.pyc
+share/python/CGIHTTPServer.pyc
+share/python/Complex.pyc
+share/python/Para.pyc
+share/python/Queue.pyc
+share/python/SimpleHTTPServer.pyc
+share/python/SocketServer.pyc
+share/python/StringIO.pyc
+share/python/UserDict.pyc
+share/python/UserList.pyc
+share/python/addpack.pyc
+share/python/aifc.pyc
+share/python/anydbm.pyc
+share/python/audiodev.pyc
+share/python/base64.pyc
+share/python/bdb.pyc
+share/python/binhex.pyc
+share/python/bisect.pyc
+share/python/calendar.pyc
+share/python/cgi.pyc
+share/python/cmd.pyc
+share/python/cmp.pyc
+share/python/cmpcache.pyc
+share/python/codehack.pyc
+share/python/colorsys.pyc
+share/python/commands.pyc
+share/python/compileall.pyc
+share/python/copy.pyc
+share/python/dircache.pyc
+share/python/dircmp.pyc
+share/python/dis.pyc
+share/python/dospath.pyc
+share/python/dumbdbm.pyc
+share/python/dump.pyc
+share/python/emacs.pyc
+share/python/find.pyc
+share/python/fmt.pyc
+share/python/fnmatch.pyc
+share/python/formatter.pyc
+share/python/fpformat.pyc
+share/python/ftplib.pyc
+share/python/glob.pyc
+share/python/ni.pyc
+share/python/gopherlib.pyc
+share/python/grep.pyc
+share/python/htmlentitydefs.pyc
+share/python/htmllib.pyc
+share/python/httplib.pyc
+share/python/ihooks.pyc
+share/python/imghdr.pyc
+share/python/importall.pyc
+share/python/linecache.pyc
+share/python/lockfile.pyc
+share/python/macpath.pyc
+share/python/mailbox.pyc
+share/python/mailcap.pyc
+share/python/mhlib.pyc
+share/python/mimetools.pyc
+share/python/multifile.pyc
+share/python/mutex.pyc
+share/python/newdir.pyc
+share/python/nntplib.pyc
+share/python/ntpath.pyc
+share/python/ospath.pyc
+share/python/packmail.pyc
+share/python/pdb.pyc
+share/python/pickle.pyc
+share/python/pipes.pyc
+share/python/poly.pyc
+share/python/popen2.pyc
+share/python/posixfile.pyc
+share/python/profile.pyc
+share/python/pstats.pyc
+share/python/pty.pyc
+share/python/pyclbr.pyc
+share/python/quopri.pyc
+share/python/rand.pyc
+share/python/random.pyc
+share/python/regex_syntax.pyc
+share/python/regexp.pyc
+share/python/regsub.pyc
+share/python/repr.pyc
+share/python/rexec.pyc
+share/python/rfc822.pyc
+share/python/sched.pyc
+share/python/sgmllib.pyc
+share/python/shelve.pyc
+share/python/shutil.pyc
+share/python/sndhdr.pyc
+share/python/statcache.pyc
+share/python/sunau.pyc
+share/python/symbol.pyc
+share/python/sunaudio.pyc
+share/python/tb.pyc
+share/python/tempfile.pyc
+share/python/toaiff.pyc
+share/python/token.pyc
+share/python/tokenize.pyc
+share/python/traceback.pyc
+share/python/tty.pyc
+share/python/types.pyc
+share/python/tzparse.pyc
+share/python/urllib.pyc
+share/python/urlparse.pyc
+share/python/util.pyc
+share/python/uu.pyc
+share/python/wave.pyc
+share/python/whatsound.pyc
+share/python/whrandom.pyc
+share/python/zmod.pyc
+man/man1/python.1.gz