aboutsummaryrefslogtreecommitdiff
path: root/lang/q
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-10-09 18:51:19 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-10-09 18:51:19 +0000
commitc3dd807ed86d7900e165b0a7b4a820574f5d9943 (patch)
treef47fdabe17c9afbf1fcffff85339c01509a1963e /lang/q
parent65cc3f80d037fd2c2c7e3ed5390c098a0c95cbed (diff)
downloadports-c3dd807ed86d7900e165b0a7b4a820574f5d9943.tar.gz
ports-c3dd807ed86d7900e165b0a7b4a820574f5d9943.zip
Notes
Diffstat (limited to 'lang/q')
-rw-r--r--lang/q/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/lang/q/Makefile b/lang/q/Makefile
index 4299c6eb0780..eec9dc5d373c 100644
--- a/lang/q/Makefile
+++ b/lang/q/Makefile
@@ -57,15 +57,20 @@ CONFIGURE_ARGS+= --with-pthread="${PTHREAD_LIBS}"
.endif
# The odbc module needs an ODBC driver manager to be installed, and it
-# supports both iODBC and unixODBC. The following variable may be set at
-# build-time to either "iodbc" or "unixodbc", with the former being the
-# default:
-ODBC?= iodbc
+# supports both iODBC and unixODBC.
-.if ${ODBC} == "unixodbc"
+.if defined(WITH_IODBC) && defined(WITH_UNIXODBC)
+IGNORE= selected mutually exclusive options: WITH_IODBC and WITH_UNIXODBC
+.endif
+
+.if !defined(WITH_IODBC) && !defined(WITH_UNIXODBC)
+WITH_IODBC?= yes
+.endif
+
+.if defined(WITH_UNIXODBC)
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+= --with-odbc=-lodbc
-.else # assume we're using iodbc
+.elif defined(WITH_IODBC)
LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
CONFIGURE_ARGS+= --with-odbc=-liodbc
.endif