aboutsummaryrefslogtreecommitdiff
path: root/lang/qmasm
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-06-11 01:45:18 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-06-11 01:45:18 +0000
commit7cd6efc0e68506e587b110eb8cc7ed9bad8c1136 (patch)
tree3556c51bfd6e11c57978b610fc1e0aca54f95923 /lang/qmasm
parentb32e777b21534ff7723dea77921b143a8aad9be5 (diff)
downloadports-7cd6efc0e68506e587b110eb8cc7ed9bad8c1136.tar.gz
ports-7cd6efc0e68506e587b110eb8cc7ed9bad8c1136.zip
New port: lang/qmasm: Quantum macro assembler for D-Wave systems
Notes
Notes: svn path=/head/; revision=503935
Diffstat (limited to 'lang/qmasm')
-rw-r--r--lang/qmasm/Makefile27
-rw-r--r--lang/qmasm/distinfo3
-rw-r--r--lang/qmasm/pkg-descr9
3 files changed, 39 insertions, 0 deletions
diff --git a/lang/qmasm/Makefile b/lang/qmasm/Makefile
new file mode 100644
index 000000000000..7f551ae3ebdf
--- /dev/null
+++ b/lang/qmasm/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= qmasm
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.0-34
+DISTVERSIONSUFFIX= -gb02225f
+CATEGORIES= lang
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Quantum macro assembler for D-Wave systems
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}PuLP>0:math/py-PuLP@${PY_FLAVOR}
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= lanl
+USE_PYTHON= distutils noflavors autoplist
+
+POST_PLIST= fix-plist
+
+fix-plist: # https://github.com/lanl/qmasm/issues/9
+ @${REINPLACE_CMD} -E "s|^bin/([a-z0-9-]*).py$$|bin/\1|" ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/lang/qmasm/distinfo b/lang/qmasm/distinfo
new file mode 100644
index 000000000000..cc6db52c93e7
--- /dev/null
+++ b/lang/qmasm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1560215686
+SHA256 (lanl-qmasm-v3.0-34-gb02225f_GH0.tar.gz) = dc8e20a0e3e31401386c61d285229dcf7f450dbc2739686281f5921d3be3e642
+SIZE (lanl-qmasm-v3.0-34-gb02225f_GH0.tar.gz) = 65888
diff --git a/lang/qmasm/pkg-descr b/lang/qmasm/pkg-descr
new file mode 100644
index 000000000000..f81b2ee55df2
--- /dev/null
+++ b/lang/qmasm/pkg-descr
@@ -0,0 +1,9 @@
+QMASM fills a gap in the software ecosystem for D-Wave's adiabatic quantum
+computers by shielding the programmer from having to know system-specific
+hardware details while still enabling programs to be expressed at a fairly low
+level of abstraction. It is therefore analogous to a conventional macro
+assembler and can be used in much the same way: as a target either for
+programmers who want a great deal of control over the hardware or for compilers
+that implement higher-level languages.
+
+WWW: https://github.com/lanl/qmasm