aboutsummaryrefslogtreecommitdiff
path: root/lang/rexx-imc
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-03-06 23:01:23 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-03-06 23:01:23 +0000
commita2198409d857834bf6cb73df6cd220fc0916a1ad (patch)
treed11b935ceb70736fca0b7f2ad42030827acaf386 /lang/rexx-imc
parente3d5aa89c4e91305891e64037cdb89b538dd1638 (diff)
downloadports-a2198409d857834bf6cb73df6cd220fc0916a1ad.tar.gz
ports-a2198409d857834bf6cb73df6cd220fc0916a1ad.zip
- Fix MASTER_SITES
- Fix compilation on FreeBSD 6.* - Pass Maintainership to submitter PR: 77898 Submitted by: Gerhard Gonter <g.gonter@ieee.org>
Notes
Notes: svn path=/head/; revision=130492
Diffstat (limited to 'lang/rexx-imc')
-rw-r--r--lang/rexx-imc/Makefile9
-rw-r--r--lang/rexx-imc/files/patch-Make-P0230
2 files changed, 32 insertions, 7 deletions
diff --git a/lang/rexx-imc/Makefile b/lang/rexx-imc/Makefile
index e2c181a7c114..5f6bde5587cf 100644
--- a/lang/rexx-imc/Makefile
+++ b/lang/rexx-imc/Makefile
@@ -10,10 +10,9 @@ PORTVERSION= 1.76
PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://users.comlab.ox.ac.uk/ian.collier/distribution/ \
- ftp://ftp.sai.msu.su/pub/unix/rexx/ \
- ftp://crydee.sai.msu.ru/zeus/unix/rexx/
+ ftp://ftp.sai.msu.su/pub/unix/rexx/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= g.gonter@ieee.org
COMMENT= A procedural programming language designed by IBM's UK Laboratories
CONFLICTS= rexx-regina-*
@@ -38,10 +37,6 @@ RMEFILES= README README.Y2K README.bugreport README.docs \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 600000
-BROKEN= "Does not compile on FreeBSD >= 6.x"
-.endif
-
post-patch:
# CFLAGS safeness for ARCHs other than i386
@${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/Make
diff --git a/lang/rexx-imc/files/patch-Make-P02 b/lang/rexx-imc/files/patch-Make-P02
new file mode 100644
index 000000000000..1ae941e60517
--- /dev/null
+++ b/lang/rexx-imc/files/patch-Make-P02
@@ -0,0 +1,30 @@
+--- work/rexx-imc-1.76/Make Tue Feb 22 01:35:58 2005
++++ Make Tue Feb 22 01:27:08 2005
+@@ -452,6 +452,27 @@
+ ;;
+ esac
+ ;;
++ FreeBSD:6.*)
++ REXXLIB="librexx.so"
++ SOLINK="librexx.so"
++ RANLIB=ranlib
++ MATH=rxmathfn.rxfn
++ LIBRARIES=""
++ SOFLAG="-shared --export-dynamic"
++ : ${RUNLIBS='-L$(LIBDIR) -Wl,-rpath,$(PREFIX)/lib'}
++ DLLFLAG="-shared --export-dynamic"
++ case $CC in
++ gcc)
++ CCFLAG="${CFLAGS} -DHAS_TTYCOM -DRENAME_UNDELETE -DHAS_GMTOFF"
++ PIC="-fPIC"
++ ;;
++ *) echo "Warning: I don't know the options for $CC"\
++ "- trying the gcc ones" >&2
++ CCFLAG="${CFLAGS} -DHAS_TTYCOM -DRENAME_UNDELETE -DHAS_GMTOFF"
++ PIC="-fPIC"
++ ;;
++ esac
++ ;;
+ unknown:*|*:*)
+ echo "I am not configured for this platform - guessing some options" >&2
+ echo "(You will not be able to use shared libraries)" >&2