aboutsummaryrefslogtreecommitdiff
path: root/lang/rizin
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2024-01-28 15:13:52 +0000
committerGleb Popov <arrowd@FreeBSD.org>2024-01-28 16:07:40 +0000
commit0e95b0cdcb956d1aab5e34cc22a9eaf57053fe9a (patch)
tree40b8579a0aa876affd5322636f610ea222cf8f95 /lang/rizin
parentd30f14fae69072bdce08c4af1583d461c2330a49 (diff)
downloadports-0e95b0cdcb956d1aab5e34cc22a9eaf57053fe9a.tar.gz
ports-0e95b0cdcb956d1aab5e34cc22a9eaf57053fe9a.zip
lang/rizin: Fix breakage after tree-sitter update.
Reported by: pkg-fallout
Diffstat (limited to 'lang/rizin')
-rw-r--r--lang/rizin/Makefile2
-rw-r--r--lang/rizin/files/patch-subprojects_rizin-shell-parser_src_parser.c8
-rw-r--r--lang/rizin/files/patch-subprojects_rizin-shell-parser_src_scanner.c11
3 files changed, 20 insertions, 1 deletions
diff --git a/lang/rizin/Makefile b/lang/rizin/Makefile
index 42e5aa793064..46053595cc6a 100644
--- a/lang/rizin/Makefile
+++ b/lang/rizin/Makefile
@@ -1,7 +1,7 @@
PORTNAME= rizin
DISTVERSIONPREFIX= v
DISTVERSION= 0.6.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang security shells
MAINTAINER= arrowd@FreeBSD.org
diff --git a/lang/rizin/files/patch-subprojects_rizin-shell-parser_src_parser.c b/lang/rizin/files/patch-subprojects_rizin-shell-parser_src_parser.c
new file mode 100644
index 000000000000..487cbf26a0d6
--- /dev/null
+++ b/lang/rizin/files/patch-subprojects_rizin-shell-parser_src_parser.c
@@ -0,0 +1,8 @@
+--- subprojects/rizin-shell-parser/src/parser.c.orig 2023-10-17 10:11:38 UTC
++++ subprojects/rizin-shell-parser/src/parser.c
+@@ -1,4 +1,4 @@
+-#include <tree_sitter/parser.h>
++#include "tree_sitter/parser.h"
+
+ #if defined(__GNUC__) || defined(__clang__)
+ #pragma GCC diagnostic push
diff --git a/lang/rizin/files/patch-subprojects_rizin-shell-parser_src_scanner.c b/lang/rizin/files/patch-subprojects_rizin-shell-parser_src_scanner.c
new file mode 100644
index 000000000000..27c0caed234d
--- /dev/null
+++ b/lang/rizin/files/patch-subprojects_rizin-shell-parser_src_scanner.c
@@ -0,0 +1,11 @@
+--- subprojects/rizin-shell-parser/src/scanner.c.orig 2023-10-17 10:11:38 UTC
++++ subprojects/rizin-shell-parser/src/scanner.c
+@@ -1,7 +1,7 @@
+ // SPDX-FileCopyrightText: 2020 ret2libc <sirmy15@gmail.com>
+ // SPDX-License-Identifier: LGPL-3.0-only
+
+-#include <tree_sitter/parser.h>
++#include "tree_sitter/parser.h"
+ #include <ctype.h>
+ #include <wctype.h>
+ #include <stdio.h>