aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby25/files
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-10-20 14:57:33 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-10-20 14:57:33 +0000
commit97a290bd3fd377601390863e445242d527055025 (patch)
tree1fa41d4dfa205eaa7944b461d025e0825294492a /lang/ruby25/files
parent4adccb13516ed024b9efdf711fc09441e65e46e2 (diff)
Update to 2.5.3
- Move USES upward - Remove no-op MLINKS and create symlinks for manpages - Sort INSTALLED_SCRIPTS - Regenerate patch files with makepatch: Changes: https://www.ruby-lang.org/en/news/2018/10/18/ruby-2-5-3-released/ https://www.ruby-lang.org/en/news/2018/10/17/ruby-2-5-2-released/ PR: 232431 Submitted by: Yasuhiro KIMURA <yasu@utahime.org> Security: afc60484-0652-440e-b01a-5ef814747f06 MFH: 2018Q4
Notes
Notes: svn path=/head/; revision=482554
Diffstat (limited to 'lang/ruby25/files')
-rw-r--r--lang/ruby25/files/patch-configure.ac12
-rw-r--r--lang/ruby25/files/patch-ext-openssl-extconf.rb28
-rw-r--r--lang/ruby25/files/patch-lib_mkmf.rb4
-rw-r--r--lang/ruby25/files/patch-lib_rdoc_generator_json__index.rb (renamed from lang/ruby25/files/patch-lib_rdoc_generator_json_index.rb)8
-rw-r--r--lang/ruby25/files/patch-tool_mkconfig.rb6
5 files changed, 15 insertions, 43 deletions
diff --git a/lang/ruby25/files/patch-configure.ac b/lang/ruby25/files/patch-configure.ac
index 08924ed4396a..863230942a2c 100644
--- a/lang/ruby25/files/patch-configure.ac
+++ b/lang/ruby25/files/patch-configure.ac
@@ -1,6 +1,6 @@
---- configure.ac.orig 2018-01-04 02:12:16.000000000 +0800
-+++ configure.ac 2018-07-19 14:45:11.636321000 +0800
-@@ -2482,7 +2482,7 @@
+--- configure.ac.orig 2018-01-03 18:12:16 UTC
++++ configure.ac
+@@ -2482,7 +2482,7 @@ AS_IF([test "$ac_cv_func_qsort_r" != no]
AC_CACHE_CHECK(whether qsort_r is GNU version, rb_cv_gnu_qsort_r,
[AC_TRY_COMPILE([
@%:@include <stdlib.h>
@@ -9,7 +9,7 @@
int (*compar)(const void *, const void *, void *),
void *arg);
],[ ],
-@@ -2492,7 +2492,7 @@
+@@ -2492,7 +2492,7 @@ void qsort_r(void *base, size_t nmemb, s
AC_CACHE_CHECK(whether qsort_r is BSD version, rb_cv_bsd_qsort_r,
[AC_TRY_COMPILE([
@%:@include <stdlib.h>
@@ -18,7 +18,7 @@
void *arg, int (*compar)(void *, const void *, const void *));
],[ ],
[rb_cv_bsd_qsort_r=yes],
-@@ -3245,7 +3245,7 @@
+@@ -3245,7 +3245,7 @@ AS_IF([test "$with_dln_a_out" != yes], [
: ${LDSHARED='$(CC) -shared'}
AS_IF([test "$rb_cv_binary_elf" = yes], [
LDFLAGS="$LDFLAGS -rdynamic"
@@ -27,7 +27,7 @@
], [
test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED='$(LD) -Bshareable'
])
-@@ -3724,6 +3723,7 @@
+@@ -3724,6 +3724,7 @@ AS_CASE("$enable_shared", [yes], [
SOLIBS='$(LIBS)'
LIBRUBY_SO='lib$(RUBY_SO_NAME).$(SOEXT).$(MAJOR)$(MINOR)'
LIBRUBY_SONAME='$(LIBRUBY_SO)'
diff --git a/lang/ruby25/files/patch-ext-openssl-extconf.rb b/lang/ruby25/files/patch-ext-openssl-extconf.rb
deleted file mode 100644
index be58b92ea90b..000000000000
--- a/lang/ruby25/files/patch-ext-openssl-extconf.rb
+++ /dev/null
@@ -1,28 +0,0 @@
-From 75de15ddcdab6efe7faf3ca1f6b5c6e5b6ba57cc Mon Sep 17 00:00:00 2001
-From: Kazuki Yamaguchi <k@rhe.jp>
-Date: Sat, 24 Mar 2018 01:44:37 +0900
-Subject: [PATCH] extconf.rb: fix build with LibreSSL 2.7.0
-
-Our compat implementation of accessor functions that were introduced in
-OpenSSL 1.1.0 conflicts with those from LibreSSL 2.7.0. Use the
-HAVE_OPAQUE_OPENSSL code path when LibreSSL 2.7 or newer is detected.
-
-Fix suggested by Joel Sing.
-
-Fixes: https://github.com/ruby/openssl/issues/192
-
---- ext/openssl/extconf.rb.orig
-+++ ext/openssl/extconf.rb
-@@ -157,8 +157,11 @@ def find_openssl_library
- have_func("SSL_is_server")
-
- # added in 1.1.0
-+if !have_struct_member("SSL", "ctx", "openssl/ssl.h") ||
-+ try_static_assert("LIBRESSL_VERSION_NUMBER >= 0x2070000fL", "openssl/opensslv.h")
-+ $defs.push("-DHAVE_OPAQUE_OPENSSL")
-+end
- have_func("CRYPTO_lock") || $defs.push("-DHAVE_OPENSSL_110_THREADING_API")
--have_struct_member("SSL", "ctx", "openssl/ssl.h") || $defs.push("-DHAVE_OPAQUE_OPENSSL")
- have_func("BN_GENCB_new")
- have_func("BN_GENCB_free")
- have_func("BN_GENCB_get_arg")
diff --git a/lang/ruby25/files/patch-lib_mkmf.rb b/lang/ruby25/files/patch-lib_mkmf.rb
index 0e629b51bec1..f333fdfd2e67 100644
--- a/lang/ruby25/files/patch-lib_mkmf.rb
+++ b/lang/ruby25/files/patch-lib_mkmf.rb
@@ -1,6 +1,6 @@
---- lib/mkmf.rb.orig 2015-12-16 09:25:48 UTC
+--- lib/mkmf.rb.orig 2018-10-09 14:09:35 UTC
+++ lib/mkmf.rb
-@@ -235,7 +235,7 @@ module MakeMakefile
+@@ -234,7 +234,7 @@ module MakeMakefile
end
$extmk ||= false
if not $extmk and File.exist?(($hdrdir = RbConfig::CONFIG["rubyhdrdir"]) + "/ruby/ruby.h")
diff --git a/lang/ruby25/files/patch-lib_rdoc_generator_json_index.rb b/lang/ruby25/files/patch-lib_rdoc_generator_json__index.rb
index 1211131e7e17..1152e4201544 100644
--- a/lang/ruby25/files/patch-lib_rdoc_generator_json_index.rb
+++ b/lang/ruby25/files/patch-lib_rdoc_generator_json__index.rb
@@ -1,6 +1,6 @@
---- ./lib/rdoc/generator/json_index.rb.orig 2017-11-12 19:37:25.144883000 -0500
-+++ ./lib/rdoc/generator/json_index.rb 2017-11-12 19:37:44.551836000 -0500
-@@ -175,7 +175,7 @@
+--- lib/rdoc/generator/json_index.rb.orig 2017-11-27 10:45:24 UTC
++++ lib/rdoc/generator/json_index.rb
+@@ -175,7 +175,7 @@ class RDoc::Generator::JsonIndex
debug_msg "Writing gzipped search index to %s" % outfile
Zlib::GzipWriter.open(outfile) do |gz|
@@ -9,7 +9,7 @@
gz.orig_name = search_index_file.basename.to_s
gz.write search_index
gz.close
-@@ -193,7 +193,7 @@
+@@ -193,7 +193,7 @@ class RDoc::Generator::JsonIndex
debug_msg "Writing gzipped file to %s" % outfile
Zlib::GzipWriter.open(outfile) do |gz|
diff --git a/lang/ruby25/files/patch-tool_mkconfig.rb b/lang/ruby25/files/patch-tool_mkconfig.rb
index fe3fa72e5eb9..66ad748e54d4 100644
--- a/lang/ruby25/files/patch-tool_mkconfig.rb
+++ b/lang/ruby25/files/patch-tool_mkconfig.rb
@@ -1,6 +1,6 @@
---- tool/mkconfig.rb.orig 2015-12-09 20:53:21 UTC
+--- tool/mkconfig.rb.orig 2017-05-02 12:45:07 UTC
+++ tool/mkconfig.rb
-@@ -168,8 +168,9 @@ def vars.expand(val, config = self)
+@@ -157,8 +157,9 @@ def vars.expand(val, config = self)
val.replace(newval) unless newval == val
val
end
@@ -11,4 +11,4 @@
+rubyarchdir = "/lib/ruby/#{major}.#{minor}/#{arch}"
relative_archdir = rubyarchdir.rindex(prefix, 0) ? rubyarchdir[prefix.size..-1] : rubyarchdir
puts %[\
- # frozen-string-literal: false
+ # encoding: ascii-8bit