aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby26
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-01-09 18:05:12 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-01-09 18:05:12 +0000
commit2fbd51f43e865c5e24d69915c3ef788057b3e7eb (patch)
tree93a158fba12f9e516e3df5377ab0cca5e02b5260 /lang/ruby26
parentb46f528c1d54cfbfad1959a9c6f1ed75a5d319ac (diff)
downloadports-2fbd51f43e865c5e24d69915c3ef788057b3e7eb.tar.gz
ports-2fbd51f43e865c5e24d69915c3ef788057b3e7eb.zip
lang/ruby26: fix build on powerpc
powerpc requires GCC after all to build this port: building .ext/include/powerpc-freebsd13/rb_mjit_min_header-2.6.5.h ./miniruby -I./lib -I. -I.ext/common ./tool/transform_mjit_header.rb "cc " rb_mjit_header.h .ext/include/powerpc-freebsd13/rb_mjit_min_header-2.6.5.h *** Signal 6
Notes
Notes: svn path=/head/; revision=522532
Diffstat (limited to 'lang/ruby26')
-rw-r--r--lang/ruby26/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/ruby26/Makefile b/lang/ruby26/Makefile
index d84920feb597..88da08f03a50 100644
--- a/lang/ruby26/Makefile
+++ b/lang/ruby26/Makefile
@@ -98,7 +98,7 @@ CONFIGURE_ARGS+=--disable-dtrace
LIB_DEPENDS+= libunwind.so:devel/libunwind
.endif
-.if defined(PPC_ABI) && ${PPC_ABI} == ELFv1
+.if (defined(PPC_ABI) && ${PPC_ABI} == ELFv1) || ${ARCH} == powerpc
USE_GCC= yes
.endif