aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby26
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-01-02 16:37:11 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-01-02 16:37:11 +0000
commit6e1232dd3910f859818b92e144ee74b77ea987da (patch)
tree1078eab3d3f1a441a3f92ca7579fee73c64a296e /lang/ruby26
parent90bdf3ab5a209bc77b0d9ac3da87b207bb14da23 (diff)
downloadports-6e1232dd3910f859818b92e144ee74b77ea987da.tar.gz
ports-6e1232dd3910f859818b92e144ee74b77ea987da.zip
lang/ruby26: fix build on powerpc, don't use GCC on powerpc64 elfv2
ruby currently has issues when compiling on powerpc with gcc9. Use base GCC instead. Also don't use GCC on powerpc64 elfv2, builds fine with clang. PR: 242630 Submitted by: nunovasconcellos@gmail.com Reported by: canardo909@gmx.com Approved by: portmgr (build fix blanket)
Notes
Notes: svn path=/head/; revision=521857
Diffstat (limited to 'lang/ruby26')
-rw-r--r--lang/ruby26/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/ruby26/Makefile b/lang/ruby26/Makefile
index 8975df79b7b1..d84920feb597 100644
--- a/lang/ruby26/Makefile
+++ b/lang/ruby26/Makefile
@@ -98,7 +98,7 @@ CONFIGURE_ARGS+=--disable-dtrace
LIB_DEPENDS+= libunwind.so:devel/libunwind
.endif
-.if (${ARCH} == powerpc || ${ARCH} == powerpc64)
+.if defined(PPC_ABI) && ${PPC_ABI} == ELFv1
USE_GCC= yes
.endif