aboutsummaryrefslogtreecommitdiff
path: root/lang/rust-bootstrap
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-06-19 18:53:57 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-06-19 18:53:57 +0000
commit6ce663a762b96656915f3a7967cfc54a173bd731 (patch)
treea59fe1fc8dc38b5efd02be4b7b4d2df5eff1b03e /lang/rust-bootstrap
parentda246cc364245f18e107e2a7b655a682a650942c (diff)
downloadports-6ce663a762b96656915f3a7967cfc54a173bd731.tar.gz
ports-6ce663a762b96656915f3a7967cfc54a173bd731.zip
lang/rust-bootstrap: Keep the (amd64-native) cross compilers around
Notes
Notes: svn path=/head/; revision=539672
Diffstat (limited to 'lang/rust-bootstrap')
-rw-r--r--lang/rust-bootstrap/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/lang/rust-bootstrap/Makefile b/lang/rust-bootstrap/Makefile
index 10a8bfa61e35..f4a92a31c3d1 100644
--- a/lang/rust-bootstrap/Makefile
+++ b/lang/rust-bootstrap/Makefile
@@ -2,6 +2,7 @@
PORTNAME= rust
PORTVERSION= 1.44.1
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= https://static.rust-lang.org/dist/:rust \
LOCAL/tobik:armbase \
@@ -204,11 +205,11 @@ do-build:
cargo src/librustc src/libstd
do-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/rust-bootstrap
- ${INSTALL_DATA} ${WRKSRC}/build/dist/*-${_RUST_TARGET}*${EXTRACT_SUFX} \
- ${STAGEDIR}${PREFIX}/rust-bootstrap
+ @${MKDIR} ${STAGEDIR}${PREFIX}/rust-bootstrap/${FLAVOR}
+ ${INSTALL_DATA} ${WRKSRC}/build/dist/*-unknown-${OPSYS:tl}${EXTRACT_SUFX} \
+ ${STAGEDIR}${PREFIX}/rust-bootstrap/${FLAVOR}
.if ${FLAVOR:Mpowerpc64_*}
- @cd ${STAGEDIR}${PREFIX}/rust-bootstrap && for f in *${EXTRACT_SUFX}; do \
+ @cd ${STAGEDIR}${PREFIX}/rust-bootstrap/${FLAVOR} && for f in *${EXTRACT_SUFX}; do \
${MV} $$f $${f%%${EXTRACT_SUFX}}-${FLAVOR:S/_/ /:[2]}${EXTRACT_SUFX}; \
done
.endif