aboutsummaryrefslogtreecommitdiff
path: root/lang/rust
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2020-02-12 16:59:46 +0000
committerMikael Urankar <mikael@FreeBSD.org>2020-02-12 16:59:46 +0000
commitde3daa4dbf8570ae3407d2312ccb5781b1ee650e (patch)
tree8fb4dea19194c08782b99bf4478b385bced4ab5a /lang/rust
parent25c81037b26020f150a643dafce312996e99f976 (diff)
downloadports-de3daa4dbf8570ae3407d2312ccb5781b1ee650e.tar.gz
ports-de3daa4dbf8570ae3407d2312ccb5781b1ee650e.zip
Trim whitespace
Reviewed by: tobik, manu Approved by: manu (mentor) Differential Revision: https://reviews.freebsd.org/D23649
Notes
Notes: svn path=/head/; revision=525920
Diffstat (limited to 'lang/rust')
-rw-r--r--lang/rust/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index e44b6e3bef4d..337796959b11 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -125,7 +125,7 @@ post-patch:
@${ECHO_MSG} "Bootstrap date and version after patching:"
@${GREP} -E '^(date|rustc|cargo)' ${WRKSRC}/src/stage0.txt
.if ${ARCH} == powerpc64
-# Starting with 13.0 powerpc64 is ELFv2 while 12.0 is ELFv1. Pass the correct LLVM target triple.
+# Starting with 13.0 powerpc64 is ELFv2 while 12.0 is ELFv1. Pass the correct LLVM target triple.
@${REINPLACE_CMD} 's,powerpc64-unknown-freebsd,powerpc64-unknown-freebsd${OSREL},' \
${WRKSRC}/src/librustc_target/spec/powerpc64_unknown_freebsd.rs
.endif
@@ -166,8 +166,8 @@ do-configure:
@${ECHO_CMD} 'cxx="${CXX}"' >> ${WRKSRC}/config.toml
.if ${ARCH} == armv6
# fails to link with base ld.bfd: rustc_codegen_llvm.e2557spx-cgu.11:(.text._ZN89_$LT$rustc_target..abi..call..CastTarget$u20$as$u20$rustc_codegen_llvm..abi..LlvmType$GT$9llvm_type17h1296210ab461fc57E+0x54): relocation truncated to fit: R_ARM_CALL against symbol `__aeabi_uldivmod' defined in .text.__aeabi_uldivmod section in /tmp/rustcdnGbao/libcompiler_builtins-ee65b414e4115a8f.rlib(compiler_builtins-ee65b414e4115a8f.compiler_builtins.ay8p39ey-cgu.13.rcgu.o)
- @${PRINTF} '#!/bin/sh\nexec ${CC} -fuse-ld=lld "$$@"' > ${WRKDIR}/cc-wrapper
- @${CHMOD} +x ${WRKDIR}/cc-wrapper
+ @${PRINTF} '#!/bin/sh\nexec ${CC} -fuse-ld=lld "$$@"' > ${WRKDIR}/cc-wrapper
+ @${CHMOD} +x ${WRKDIR}/cc-wrapper
@${ECHO_CMD} 'linker="${WRKDIR}/cc-wrapper"' >> ${WRKSRC}/config.toml
.else
@${ECHO_CMD} 'linker="${CC}"' >> ${WRKSRC}/config.toml