aboutsummaryrefslogtreecommitdiff
path: root/lang/sagittarius-scheme
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
commit5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf (patch)
tree3291541f3b73432c893dec35f4f23770dd07732a /lang/sagittarius-scheme
parent9c92503171817f96d944009b9ea88d3c083c9a45 (diff)
downloadports-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.tar.gz
ports-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.zip
Make ninja opt-out in cmake.mk
Using ninja instead of make (1) can lead to significant speed ups while building. Therefore switch from having the ninja generator opt-in to having it opt-out. Previously cmake-ports that wanted to use ninja could set CMAKE_NINJA=yes now, ports that do not work with ninja can set cmake:<existing args>,noninja Note, that needing this should be an exception and most often points to a broken cmake of the port. The ports using cmake were modified * removed USES=gmake, if ninja is used * removed MAKE_ARGS, if ninja is used * added the cmake-argument noninja if necessary PR: 219629 PR: 213331 Exp-run by: antoine Reviewed by: rakuco Differential Revision: https://reviews.freebsd.org/D10748
Notes
Notes: svn path=/head/; revision=444324
Diffstat (limited to 'lang/sagittarius-scheme')
-rw-r--r--lang/sagittarius-scheme/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/sagittarius-scheme/Makefile b/lang/sagittarius-scheme/Makefile
index f1bd75ccb2b2..c43f9b8b4594 100644
--- a/lang/sagittarius-scheme/Makefile
+++ b/lang/sagittarius-scheme/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libffi.so:devel/libffi \
libgc-threaded.so:devel/boehm-gc-threaded
USE_LDCONFIG= yes
-USES= cmake gmake pkgconfig
+USES= cmake pkgconfig
ONLY_FOR_ARCHS= amd64 i386
MAKE_JOBS_UNSAFE= yes