aboutsummaryrefslogtreecommitdiff
path: root/lang/sagittarius-scheme
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2015-04-27 10:46:39 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2015-04-27 10:46:39 +0000
commitb038e15a90350fcf22c7fb8c57d226c76efe968d (patch)
tree045dfcd61379ef4ec51247077da7867ec02f1999 /lang/sagittarius-scheme
parentc5167c49ba2e934bffbaacba422b57db6393c037 (diff)
downloadports-b038e15a90350fcf22c7fb8c57d226c76efe968d.tar.gz
ports-b038e15a90350fcf22c7fb8c57d226c76efe968d.zip
- Update to 0.6.3
- Remove upstreamed diffs - Add dependency on pkgconfig, required for detecting boehm-gc
Notes
Notes: svn path=/head/; revision=384820
Diffstat (limited to 'lang/sagittarius-scheme')
-rw-r--r--lang/sagittarius-scheme/Makefile4
-rw-r--r--lang/sagittarius-scheme/distinfo4
-rw-r--r--lang/sagittarius-scheme/files/patch-cmake_FindGC.cmake40
-rw-r--r--lang/sagittarius-scheme/files/patch-ext_crypto_libtomcrypt-1.17_src_headers_tomcrypt__macros.h107
-rw-r--r--lang/sagittarius-scheme/pkg-plist21
5 files changed, 25 insertions, 151 deletions
diff --git a/lang/sagittarius-scheme/Makefile b/lang/sagittarius-scheme/Makefile
index 8153feb7218b..b164ca46565c 100644
--- a/lang/sagittarius-scheme/Makefile
+++ b/lang/sagittarius-scheme/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= sagittarius
-PORTVERSION= 0.6.1
+PORTVERSION= 0.6.3
CATEGORIES= lang
MASTER_SITES= http://distfiles.pirateparty.in/%SUBDIR%/ \
${MASTER_SITE_LOCAL}
@@ -20,7 +20,7 @@ LIB_DEPENDS= libffi.so:${PORTSDIR}/devel/libffi \
libgc-threaded.so:${PORTSDIR}/devel/boehm-gc-threaded
USE_LDCONFIG= yes
-USES= cmake gmake
+USES= cmake gmake pkgconfig
ONLY_FOR_ARCHS= amd64 i386
MAKE_JOBS_UNSAFE= yes
diff --git a/lang/sagittarius-scheme/distinfo b/lang/sagittarius-scheme/distinfo
index 067d2b5d5f03..c87e51b9df16 100644
--- a/lang/sagittarius-scheme/distinfo
+++ b/lang/sagittarius-scheme/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sagittarius-0.6.1.tar.gz) = 57d15f90f3e0083e5cacfc6647934e30c20e1bd0a5a735e8512e78f4969d9211
-SIZE (sagittarius-0.6.1.tar.gz) = 6039440
+SHA256 (sagittarius-0.6.3.tar.gz) = cc833a591855189efc883cd988283f7d9ae78e647a7057b0975c14a69ec68647
+SIZE (sagittarius-0.6.3.tar.gz) = 6135093
diff --git a/lang/sagittarius-scheme/files/patch-cmake_FindGC.cmake b/lang/sagittarius-scheme/files/patch-cmake_FindGC.cmake
deleted file mode 100644
index f26c6652fa52..000000000000
--- a/lang/sagittarius-scheme/files/patch-cmake_FindGC.cmake
+++ /dev/null
@@ -1,40 +0,0 @@
-
-$FreeBSD$
-
---- cmake/FindGC.cmake.orig
-+++ cmake/FindGC.cmake
-@@ -55,9 +55,9 @@
- # then use it
- INCLUDE(${CMAKE_ROOT}/Modules/CheckCSourceCompiles.cmake)
- # not sure if this links properly...
-- FIND_LIBRARY(BOEHM_GC_LIBRARIES NAMES gc
-+ FIND_LIBRARY(BOEHM_GC_LIBRARIES NAMES gc-threaded
- HINTS ${PC_BDW_GC_LIBDIR} ${PC_BDW_GC_LIBRARY_DIRS})
-- SET(CMAKE_REQUIRED_LIBRARIES "gc")
-+ SET(CMAKE_REQUIRED_LIBRARIES "gc-threaded")
- SET(CMAKE_REQUIRED_DEFINITIONS "-DGC_THREADS")
- SET(CMAKE_REQUIRED_INCLUDES "${BOEHM_GC_INCLUDE_DIR}")
- SET(CMAKE_REQUIRED_FLAGS "-L${PC_BDW_GC_LIBRARY_DIRS}")
-@@ -69,22 +69,6 @@
- return 0;
- }
- " GC_GET_PARALLEL_WORKS)
-- IF (NOT GC_GET_PARALLEL_WORKS)
-- MESSAGE(STATUS "Try gc-threaded")
-- SET(CMAKE_REQUIRED_LIBRARIES "gc-threaded")
-- SET(CMAKE_REQUIRED_DEFINITIONS "-DGC_THREADS")
-- SET(CMAKE_REQUIRED_INCLUDES "${BOEHM_GC_INCLUDE_DIR}")
-- SET(CMAKE_REQUIRED_FLAGS "-L${PC_BDW_GC_LIBRARY_DIRS}")
-- FIND_LIBRARY(BOEHM_GC_LIBRARIES NAMES gc-threaded
-- HINTS ${PC_BDW_GC_LIBDIR} ${PC_BDW_GC_LIBRARY_DIRS})
-- CHECK_C_SOURCE_RUNS(
-- "#include <gc.h>
--int main() {
--int i=GC_get_parallel();
--return 0;
--}
--" GC_GET_THREADED_PARALLEL_WORKS)
-- ENDIF()
- ELSE()
- FIND_LIBRARY(BOEHM_GC_LIBRARIES NAMES gc
- HINTS ${PC_BDW_GC_LIBDIR} ${PC_BDW_GC_LIBRARY_DIRS})
diff --git a/lang/sagittarius-scheme/files/patch-ext_crypto_libtomcrypt-1.17_src_headers_tomcrypt__macros.h b/lang/sagittarius-scheme/files/patch-ext_crypto_libtomcrypt-1.17_src_headers_tomcrypt__macros.h
deleted file mode 100644
index 793e3fe55954..000000000000
--- a/lang/sagittarius-scheme/files/patch-ext_crypto_libtomcrypt-1.17_src_headers_tomcrypt__macros.h
+++ /dev/null
@@ -1,107 +0,0 @@
-
-$FreeBSD$
-
---- ext/crypto/libtomcrypt-1.17/src/headers/tomcrypt_macros.h.orig
-+++ ext/crypto/libtomcrypt-1.17/src/headers/tomcrypt_macros.h
-@@ -262,21 +262,19 @@
-
- #ifndef LTC_NO_ROLC
-
--static inline unsigned ROLc(unsigned word, const int i)
--{
-- asm ("roll %2,%0"
-- :"=r" (word)
-- :"0" (word),"I" (i));
-- return word;
--}
-+#define ROLc(word, i) ({ \
-+ unsigned _word = word; \
-+ asm ("roll %2,%0" \
-+ :"=r" (_word) \
-+ :"0" (_word),"I" (i)); \
-+ _word; })
-
--static inline unsigned RORc(unsigned word, const int i)
--{
-- asm ("rorl %2,%0"
-- :"=r" (word)
-- :"0" (word),"I" (i));
-- return word;
--}
-+#define RORc(word, i) ({ \
-+ unsigned _word = word; \
-+ asm ("rorl %2,%0" \
-+ :"=r" (_word) \
-+ :"0" (_word),"I" (i)); \
-+ _word; })
-
- #else
-
-@@ -305,21 +303,19 @@
-
- #ifndef LTC_NO_ROLC
-
--static inline unsigned ROLc(unsigned word, const int i)
--{
-- asm ("rotlwi %0,%0,%2"
-- :"=r" (word)
-- :"0" (word),"I" (i));
-- return word;
--}
-+#define ROLc(word, i) ({ \
-+ unsigned _word = word; \
-+ asm ("rotlwi %0,%0,%2" \
-+ :"=r" (_word) \
-+ :"0" (_word),"I" (i)); \
-+ _word; })
-
--static inline unsigned RORc(unsigned word, const int i)
--{
-- asm ("rotrwi %0,%0,%2"
-- :"=r" (word)
-- :"0" (word),"I" (i));
-- return word;
--}
-+#define RORc(word, i) ({ \
-+ unsigned _word = word; \
-+ asm ("rotrwi %0,%0,%2" \
-+ :"=r" (_word) \
-+ :"0" (_word),"I" (i)); \
-+ _word; })
-
- #else
-
-@@ -361,21 +357,19 @@
-
- #ifndef LTC_NO_ROLC
-
--static inline unsigned long ROL64c(unsigned long word, const int i)
--{
-- asm("rolq %2,%0"
-- :"=r" (word)
-- :"0" (word),"J" (i));
-- return word;
--}
-+#define ROL64c(word, i) ({ \
-+ unsigned long _word = word; \
-+ asm ("rolq %2,%0" \
-+ :"=r" (_word) \
-+ :"0" (_word),"J" (i)); \
-+ _word; })
-
--static inline unsigned long ROR64c(unsigned long word, const int i)
--{
-- asm("rorq %2,%0"
-- :"=r" (word)
-- :"0" (word),"J" (i));
-- return word;
--}
-+#define ROR64c(word, i) ({ \
-+ unsigned long _word = word; \
-+ asm ("rorq %2,%0" \
-+ :"=r" (_word) \
-+ :"0" (_word),"J" (i)); \
-+ _word; })
-
- #else /* LTC_NO_ROLC */
-
diff --git a/lang/sagittarius-scheme/pkg-plist b/lang/sagittarius-scheme/pkg-plist
index 4b29029fc2f8..dbbcb4ad2e2f 100644
--- a/lang/sagittarius-scheme/pkg-plist
+++ b/lang/sagittarius-scheme/pkg-plist
@@ -245,7 +245,9 @@ libdata/pkgconfig/%%PORTNAME%%.pc
%%DATADIR%%/%%PORTVERSION%%/sitelib/binary/pack-aux.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/binary/parse.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/binary/pack.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/cache/lru.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/char-set.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/compression/huffman.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/curly-infix.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/dbi.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/dbm.scm
@@ -294,6 +296,12 @@ libdata/pkgconfig/%%PORTNAME%%.pc
%%DATADIR%%/%%PORTVERSION%%/sitelib/rfc/gzip.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/rfc/hmac.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/rfc/http.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/rfc/http2/client.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/rfc/http2/conditions.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/rfc/http2/frame.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/rfc/http2/hpack-code-table.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/rfc/http2/hpack-static-table.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/rfc/http2/hpack.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/rfc/mime.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/rfc/pem.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/rfc/quoted-printable.scm
@@ -318,11 +326,14 @@ libdata/pkgconfig/%%PORTNAME%%.pc
%%DATADIR%%/%%PORTVERSION%%/sitelib/rpc/json.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/rpc/message.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/rpc/transport/http.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/rsa/pkcs/%3a10.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/rsa/pkcs/%3a12.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/rsa/pkcs/%3a12/cipher.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/rsa/pkcs/%3a12/keystore.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/rsa/pkcs/%3a5.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/rsa/pkcs/%3a8.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/%%PORTNAME%%/aspect.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/%%PORTNAME%%/bv-string.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/%%PORTNAME%%/cgen.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/%%PORTNAME%%/cgen/cise.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/%%PORTNAME%%/cgen/literal.scm
@@ -368,6 +379,13 @@ libdata/pkgconfig/%%PORTNAME%%.pc
%%DATADIR%%/%%PORTVERSION%%/sitelib/scribble/convert.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/scribble/parser.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/scribble/plugin.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/security/keystore.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/security/keystore/interface.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/security/keystore/jceks.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/security/keystore/jceks/cipher.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/security/keystore/jceks/keystore.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/security/keystore/jks.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/security/keystore/pkcs12.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/shorten.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/slib/alist.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/slib/qp.scm
@@ -523,9 +541,12 @@ libdata/pkgconfig/%%PORTNAME%%.pc
%%DATADIR%%/%%PORTVERSION%%/sitelib/time.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/tlv.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/trace.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/util/buffer.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/util/bytevector.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/util/concurrent.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/util/concurrent/executor.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/util/concurrent/future.scm
+%%DATADIR%%/%%PORTVERSION%%/sitelib/util/concurrent/shared-queue.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/util/deque.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/util/file.scm
%%DATADIR%%/%%PORTVERSION%%/sitelib/util/hashtables.scm