aboutsummaryrefslogtreecommitdiff
path: root/lang/see
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2008-01-29 09:36:03 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2008-01-29 09:36:03 +0000
commit6653ee67f4e78fc8108b3bbb71a0f9997ee51cc3 (patch)
tree6a7720fec07ab629ea591fe0cf42e651250474e9 /lang/see
parent036f2082eb526560073d0c9d60915c201a408b05 (diff)
downloadports-6653ee67f4e78fc8108b3bbb71a0f9997ee51cc3.tar.gz
ports-6653ee67f4e78fc8108b3bbb71a0f9997ee51cc3.zip
Upgrade to 2.0.1131.
PR: ports/120082 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=206358
Diffstat (limited to 'lang/see')
-rw-r--r--lang/see/Makefile33
-rw-r--r--lang/see/distinfo6
-rw-r--r--lang/see/files/patch-include_see_Makefile.in13
-rw-r--r--lang/see/files/patch-libsee_dtoa__config.h11
-rw-r--r--lang/see/files/patch-libsee_input__utf8.c20
-rw-r--r--lang/see/files/patch-libsee_obj__Date.c38
-rw-r--r--lang/see/pkg-descr3
-rw-r--r--lang/see/pkg-plist9
8 files changed, 58 insertions, 75 deletions
diff --git a/lang/see/Makefile b/lang/see/Makefile
index 06079d909789..3a21f2cc9000 100644
--- a/lang/see/Makefile
+++ b/lang/see/Makefile
@@ -1,40 +1,47 @@
# New ports collection makefile for: see
-# Date created: 22 September 2004
-# Whom: numisemis@yahoo.com
+# Date created: 29 Oct 2005
+# Whom: Simun Mikecin <numisemis@yahoo.com>
#
# $FreeBSD$
#
PORTNAME= see
-PORTVERSION= 1.3.1
-PORTREVISION= 1
+PORTVERSION= 2.0.1131
CATEGORIES= lang devel
-MASTER_SITES= http://www.powerband.net.au/~david.leonard/
+MASTER_SITES= http://www.powerband.net.au/~david.leonard/ \
+ http://freshmeat.net/redir/see/45974/url_tgz/
MAINTAINER= numisemis@yahoo.com
COMMENT= Simple ECMAScript Engine (SEE)
+OPTIONS= GC "Use Boehm-Weiser garbage collection package" on \
+ OPTIMIZED_CFLAGS "Enable some additional optimizations" off \
+ SEE_DEBUG "Internal SEE library debugging" off
+
CONFLICTS= see-devel-[0-9]*
-OPTIONS= GC "Use Boehm-Weiser garbage collection pkg" on \
- OPTIMIZED_CFLAGS "Enable some additional optimizations" off
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
-USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
+USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_PERL5_BUILD= yes
CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.pre.mk>
+.if !defined(WITH_SEE_DEBUG)
+CFLAGS+= -DNDEBUG
+.endif
+
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -fomit-frame-pointer
.endif
-.if !defined(WITHOUT_GC)
+.if defined(WITH_GC)
LIB_DEPENDS+= gc:${PORTSDIR}/devel/boehm-gc
.else
CONFIGURE_ARGS+= --without-boehm-gc
@@ -49,7 +56,7 @@ post-patch:
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${DOCSDIR}
-.for f in doc/USAGE.html AUTHORS NEWS README TODO
+.for f in doc/USAGE.html AUTHORS NEWS README TODO COPYING
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif
diff --git a/lang/see/distinfo b/lang/see/distinfo
index d4a01d4b3e4b..3a55956416d2 100644
--- a/lang/see/distinfo
+++ b/lang/see/distinfo
@@ -1,3 +1,3 @@
-MD5 (see-1.3.1.tar.gz) = 472e88b13bb090b29d1bb553adbff454
-SHA256 (see-1.3.1.tar.gz) = 50ed56794bea742e9106914a0c0d1d79eaea15090f02542006c34f3c23d8b066
-SIZE (see-1.3.1.tar.gz) = 523226
+MD5 (see-2.0.1131.tar.gz) = 02d8e5d7581acde2212969217d5bab96
+SHA256 (see-2.0.1131.tar.gz) = 0d398fd5f7a2e86ddbe361a80d9658bf0f0f6c11dad186953c3c064c56d12d93
+SIZE (see-2.0.1131.tar.gz) = 948647
diff --git a/lang/see/files/patch-include_see_Makefile.in b/lang/see/files/patch-include_see_Makefile.in
deleted file mode 100644
index 9633e1fa21e5..000000000000
--- a/lang/see/files/patch-include_see_Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- include/see/Makefile.in.orig Wed Jan 18 14:22:20 2006
-+++ include/see/Makefile.in Wed Jul 19 19:49:40 2006
-@@ -253,8 +253,8 @@
- > inc-subst
- $(PERL) -n -e \
- 'print if s!^#define\s+(\S+)\s+(.+)!s,\\\@$$1\\\@,$$2/*$$1*/,g;!; \
-- print if s:^/\*\s*#undef\s+(\S+)\s*\*/.*:s,\\\@$$1\\\@,0/*!$$1*/,g;:; \
-- ' < $(CONFIG_HEADER) >> inc-subst
-+ print if s:^/\*\s*#undef\s+(\S+)\s*\*/.*:s,\\\@$$1\\\@,0/*!$$1*/,g;:;' \
-+ < $(CONFIG_HEADER) >> inc-subst
-
- error.h: error.h.in inc-subst
- $(PERL) -p inc-subst < $(srcdir)/error.h.in > error.h
diff --git a/lang/see/files/patch-libsee_dtoa__config.h b/lang/see/files/patch-libsee_dtoa__config.h
deleted file mode 100644
index 517f9c611103..000000000000
--- a/lang/see/files/patch-libsee_dtoa__config.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- libsee/dtoa_config.h.orig Wed Jan 18 13:51:50 2006
-+++ libsee/dtoa_config.h Tue Jan 31 16:52:54 2006
-@@ -12,7 +12,7 @@
-
- #include <see/type.h>
-
--#if defined(__i386__) || defined(__amd64__)
-+#if defined(__i386__) || defined(__amd64__) || defined(__ia64__) || defined(__alpha__)
- # define IEEE_8087
- #endif
-
diff --git a/lang/see/files/patch-libsee_input__utf8.c b/lang/see/files/patch-libsee_input__utf8.c
new file mode 100644
index 000000000000..d86e4286f7f5
--- /dev/null
+++ b/lang/see/files/patch-libsee_input__utf8.c
@@ -0,0 +1,20 @@
+--- libsee/input_utf8.c.orig Wed Jan 18 12:40:19 2006
++++ libsee/input_utf8.c Tue Dec 12 08:48:44 2006
+@@ -63,7 +63,7 @@
+
+ struct input_utf8 {
+ struct SEE_input inp;
+- const char * s;
++ const unsigned char * s;
+ };
+
+ static SEE_unicode_t
+@@ -141,7 +141,7 @@
+ inpu->inp.inputclass = &input_utf8_class;
+ inpu->inp.filename = NULL;
+ inpu->inp.first_lineno = 1;
+- inpu->s = s;
++ inpu->s = (const unsigned char *)s;
+ SEE_INPUT_NEXT((struct SEE_input *)inpu); /* prime */
+ return (struct SEE_input *)inpu;
+ }
diff --git a/lang/see/files/patch-libsee_obj__Date.c b/lang/see/files/patch-libsee_obj__Date.c
index 12c3a0614c74..320710c4078a 100644
--- a/lang/see/files/patch-libsee_obj__Date.c
+++ b/lang/see/files/patch-libsee_obj__Date.c
@@ -1,35 +1,11 @@
---- libsee/obj_Date.c.orig Wed Jan 18 13:51:50 2006
-+++ libsee/obj_Date.c Mon Mar 27 10:56:41 2006
-@@ -2167,20 +2167,12 @@
- DaylightSavingTA(t)
+--- libsee/obj_Date.c.orig Sun May 7 06:43:55 2006
++++ libsee/obj_Date.c Tue Sep 5 09:11:09 2006
+@@ -335,7 +335,7 @@
+ struct SEE_interpreter *interp;
SEE_number_t t;
{
-- SEE_number_t ysec = t - TimeFromYear((SEE_number_t)YearFromTime(t));
-- int ily = InLeapYear(t);
-- int wstart = WeekDay(TimeFromYear((SEE_number_t)YearFromTime(t)));
-- int equiv_year = yearmap[ily][wstart];
- struct tm tm;
- time_t dst_time, nodst_time;
-+ time_t tt;
-+ tt=t/1000;
-+ tm=*localtime(&tt);
-
-- memset(&tm, 0, sizeof tm);
-- tm.tm_sec = SecFromTime(ysec);
-- tm.tm_min = MinFromTime(ysec);
-- tm.tm_hour = HourFromTime(ysec);
-- tm.tm_mday = DateFromTime(ysec);
-- tm.tm_mon = MonthFromTime(ysec) - 1;
-- tm.tm_year = equiv_year - 1900;
- tm.tm_isdst = -1;
-
- if (tm.tm_isdst == 0) return 0;
-@@ -2189,7 +2181,7 @@
- tm.tm_isdst = 0;
- nodst_time = mktime(&tm);
-
-- return (dst_time - nodst_time) * 1000;
-+ return -(dst_time - nodst_time) * 1000;
+- return t + LocalTZA(interp) + DaylightSavingTA(interp, t);
++ return t + LocalTZA(interp) - DaylightSavingTA(interp, t);
}
- static void
+ /*
diff --git a/lang/see/pkg-descr b/lang/see/pkg-descr
index 5d0e5e37e335..5bcf69e029b9 100644
--- a/lang/see/pkg-descr
+++ b/lang/see/pkg-descr
@@ -1,6 +1,3 @@
Library that provides an ECMAScript (JavaScript) run-time environment.
WWW: http://www.adaptive-enterprises.com.au/~d/software/see/
-
-- Simun Mikecin
-numisemis@yahoo.com
diff --git a/lang/see/pkg-plist b/lang/see/pkg-plist
index 3207d7a9688d..b0ff9a4f2edf 100644
--- a/lang/see/pkg-plist
+++ b/lang/see/pkg-plist
@@ -9,6 +9,7 @@ include/see/input.h
include/see/intern.h
include/see/interpreter.h
include/see/mem.h
+include/see/module.h
include/see/native.h
include/see/no.h
include/see/object.h
@@ -22,11 +23,17 @@ include/see/version.h
lib/libsee.a
lib/libsee.la
lib/libsee.so
-lib/libsee.so.0
+lib/libsee.so.1
+lib/see/libFile.a
+lib/see/libFile.la
+lib/see/libFile.so
+lib/see/libFile.so.0
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%%%DOCSDIR%%/USAGE.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/see
+@dirrm lib/see