aboutsummaryrefslogtreecommitdiff
path: root/lang/seed7
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2016-03-08 11:20:23 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2016-03-08 11:20:23 +0000
commitb2d9aa469e7d935aca87bd8da7959dc9b6d737a4 (patch)
tree5eafd2f3d7be97bd0d5ad0883e77a1b4b5b87edd /lang/seed7
parent98a87eef3aa745504d53fad8f59e19bef1c84230 (diff)
downloadports-b2d9aa469e7d935aca87bd8da7959dc9b6d737a4.tar.gz
ports-b2d9aa469e7d935aca87bd8da7959dc9b6d737a4.zip
lang/seed7: update to 05_20160229
Changes: - The function fltCmp in flt_rtl.c has been improved to work correct in the case that isnan returns neither 0 nor 1 (Many thanks go to Arnel L. for reporting this problem). - The function determineGetaddrlimit in chkccomp.c has been improved to include <sys/types.h> before <sys/resource.h>. FreeBSD needs that to work correctly (Many thanks go to Pietro Cerutti for providing a fix and explaining the background). - The function getOsCwd has been added to cmd_rtl.c. With this function it is possible to read (e.g. under Linux) a current working directory that is longer than PATH_MAX. - Documentation comments have been improved in encoding.s7i. - The program chkccomp.c has been improved to write definitions of USE_DIRENT, USE_DIRWIN, OS_WIDE_DIR_INCLUDE_DIR_H, os_DIR, os_dirent_struct, os_opendir, os_readdir, os_closedir, INCLUDE_SYS_UTIME, os_utimbuf_struct, USE_ALTERNATE_UTIME, os_utime_orig, os_utime, os_chdir, OS_GETCWD_MAX_BUFFER_SIZE, os_getcwd, os_mkdir, os_rmdir, OS_CHMOD_INCLUDE_IO_H, os_chmod, os_remove, os_rename, os_system, os_fopen, os_popen, os_pclose, DEFINE_WGETENV, os_getenv - The functions keys_helem and values_helem in hshlib.c and hsh_rtl.c have been improved to use a loop instead of a tail recursion. For compilers that don't recognize the tail recursion this results in a speed improvement (Gcc recognizes tail recursions so there is no speed improvement). - The functions free_helem and free_hash in hsh_rtl.c have been improved to stop searching for helems as soon as the last helem has been freed. - The functions helem_data_to_list and helem_key_to_list have been improved to use a loop instead of a tail recursion (see above).
Notes
Notes: svn path=/head/; revision=410611
Diffstat (limited to 'lang/seed7')
-rw-r--r--lang/seed7/Makefile3
-rw-r--r--lang/seed7/distinfo4
-rw-r--r--lang/seed7/files/patch-chkccomp.c28
-rw-r--r--lang/seed7/files/patch-heaputl.c10
4 files changed, 3 insertions, 42 deletions
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
index 4fc96bcac8e0..899a003aef04 100644
--- a/lang/seed7/Makefile
+++ b/lang/seed7/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= seed7
-DISTVERSION= 05_20160130
+DISTVERSION= 05_20160229
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}/
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -23,7 +23,6 @@ USE_XORG= x11
ONLY_FOR_ARCHS= i386 amd64 sparc64
-TEST_TARGET= do-test
WRKSRC= ${WRKDIR}/${PORTNAME}/src
MAKEFILE= makefile
MAKE_ENV+= S7_LIB_DIR=${S7_LIB_DIR} \
diff --git a/lang/seed7/distinfo b/lang/seed7/distinfo
index 8a931188a5e6..1dd93db30bb9 100644
--- a/lang/seed7/distinfo
+++ b/lang/seed7/distinfo
@@ -1,2 +1,2 @@
-SHA256 (seed7_05_20160130.tgz) = 654a938a385b2969b78d7b1f37c3b8c6eda532e746f5a275cc846b32be042771
-SIZE (seed7_05_20160130.tgz) = 2591149
+SHA256 (seed7_05_20160229.tgz) = a6e78443ec25864fff236f40d0cceda3e398a8c6775a7c65e6873b98ba2be79a
+SIZE (seed7_05_20160229.tgz) = 2592420
diff --git a/lang/seed7/files/patch-chkccomp.c b/lang/seed7/files/patch-chkccomp.c
deleted file mode 100644
index 3ec825d35917..000000000000
--- a/lang/seed7/files/patch-chkccomp.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- chkccomp.c.orig 2016-01-28 21:32:12 UTC
-+++ chkccomp.c
-@@ -1925,14 +1925,14 @@ void determineGetaddrlimit (FILE *versio
- int has_getrlimit;
-
- /* determineGetaddrlimit */
-- has_getrlimit = compileAndLinkOk("#include <stdio.h>\n#include <sys/resource.h>\n"
-+ has_getrlimit = compileAndLinkOk("#include <stdio.h>\n#include <sys/types.h>\n#include <sys/resource.h>\n"
- "int main(int argc, char *argv[]){\n"
- "struct rlimit rlim;\n"
- "printf(\"%d\\n\", getrlimit(RLIMIT_STACK, &rlim) == 0);\n"
- "return 0;}\n") && doTest() == 1;
- fprintf(versionFile, "#define HAS_GETRLIMIT %d\n", has_getrlimit);
- if (has_getrlimit) {
-- if (assertCompAndLnk("#include <stdio.h>\n#include <sys/resource.h>\n"
-+ if (assertCompAndLnk("#include <stdio.h>\n#include <sys/types.h>\n#include <sys/resource.h>\n"
- "int main(int argc, char *argv[]){\n"
- "struct rlimit rlim;\n"
- "getrlimit(RLIMIT_STACK, &rlim);"
-@@ -1943,7 +1943,7 @@ void determineGetaddrlimit (FILE *versio
- "return 0;}\n")) {
- fprintf(versionFile, "#define SOFT_STACK_LIMIT %lu\n", (unsigned long) doTest() * 1024);
- } /* if */
-- if (assertCompAndLnk("#include <stdio.h>\n#include <sys/resource.h>\n"
-+ if (assertCompAndLnk("#include <stdio.h>\n#include <sys/types.h>\n#include <sys/resource.h>\n"
- "int main(int argc, char *argv[]){\n"
- "struct rlimit rlim;\n"
- "getrlimit(RLIMIT_STACK, &rlim);"
diff --git a/lang/seed7/files/patch-heaputl.c b/lang/seed7/files/patch-heaputl.c
deleted file mode 100644
index 136b94ee0431..000000000000
--- a/lang/seed7/files/patch-heaputl.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- heaputl.c.orig 2015-08-29 06:55:33 UTC
-+++ heaputl.c
-@@ -37,6 +37,7 @@
- #include "stdlib.h"
- #include "stdio.h"
- #if HAS_GETRLIMIT && defined STACK_SIZE
-+#include "sys/types.h"
- #include "sys/resource.h"
- #endif
-