aboutsummaryrefslogtreecommitdiff
path: root/lang/spidermonkey17
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2021-01-01 23:51:48 +0000
committerMark Linimon <linimon@FreeBSD.org>2021-01-01 23:51:48 +0000
commit553b088a0505b32e910f454bc2a296fca47ac9dd (patch)
treeb95d03e698b9ef7fe36e585725c5dcfc5aee36d0 /lang/spidermonkey17
parent6b5efb1b8820c67344543e6cd051a864862f5a8f (diff)
downloadports-553b088a0505b32e910f454bc2a296fca47ac9dd.tar.gz
ports-553b088a0505b32e910f454bc2a296fca47ac9dd.zip
Mark ports that are BROKEN due to sbrk on aarch64, also BROKEN on riscv64
where appropriate. While here, pet portlint (Makevar order; whitespace). Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=559890
Diffstat (limited to 'lang/spidermonkey17')
-rw-r--r--lang/spidermonkey17/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/lang/spidermonkey17/Makefile b/lang/spidermonkey17/Makefile
index 52b6571297d4..d0d6bfb4a0fd 100644
--- a/lang/spidermonkey17/Makefile
+++ b/lang/spidermonkey17/Makefile
@@ -11,6 +11,13 @@ DISTNAME= js-${DISTVERSION}
MAINTAINER= citric@cubicone.tmetic.com
COMMENT= Standalone JavaScript interpreter from the Mozilla project
+BROKEN_aarch64= fails to link: missing sbrk
+BROKEN_armv6= fails to link: final link failed: Nonrepresentable section on output
+BROKEN_armv7= fails to link: /nxb-bin/usr/bin/ld: FreeBSD12.0-CURRENT_DBG.OBJ/js: hidden symbol `__aeabi_uidivmod' in /usr/lib/libgcc.a(aeabi_uidivmod.o) is referenced by DSO
+BROKEN_mips64= fails to link: final link failed: Nonrepresentable section on output
+BROKEN_riscv64= fails to link: missing sbrk
+BROKEN_sparc64= fails to link
+
LIB_DEPENDS= libnspr4.so:devel/nspr
MAKE_ARGS+= JS_THREADSAFE=YES \
@@ -18,12 +25,6 @@ MAKE_ARGS+= JS_THREADSAFE=YES \
LDFLAGS="-L${LOCALBASE}/lib"
CFLAGS+= -I${LOCALBASE}/include/nspr
-BROKEN_aarch64= fails to link: missing sbrk
-BROKEN_armv6= fails to link: final link failed: Nonrepresentable section on output
-BROKEN_armv7= fails to link: /nxb-bin/usr/bin/ld: FreeBSD12.0-CURRENT_DBG.OBJ/js: hidden symbol `__aeabi_uidivmod' in /usr/lib/libgcc.a(aeabi_uidivmod.o) is referenced by DSO
-BROKEN_mips64= fails to link: final link failed: Nonrepresentable section on output
-BROKEN_sparc64= fails to link
-
USES= gmake ncurses readline
MAKEFILE= Makefile.ref
ALL_TARGET= ${OPSYS}`${UNAME} -r`_DBG.OBJ/js