aboutsummaryrefslogtreecommitdiff
path: root/lang/spl
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-08 06:57:17 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-08 06:57:17 +0000
commit3ef85d598ad13ca1057523ec0ebef7c8858aa628 (patch)
tree866f372f8cc0e61fa9918653e22a551f335460c6 /lang/spl
parentdbf29bba50cc3ec0b92ecafcf2125de4f0d30501 (diff)
downloadports-3ef85d598ad13ca1057523ec0ebef7c8858aa628.tar.gz
ports-3ef85d598ad13ca1057523ec0ebef7c8858aa628.zip
Stagify.
Notes
Notes: svn path=/head/; revision=356982
Diffstat (limited to 'lang/spl')
-rw-r--r--lang/spl/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/lang/spl/Makefile b/lang/spl/Makefile
index 9c344705bb00..4fc444690a61 100644
--- a/lang/spl/Makefile
+++ b/lang/spl/Makefile
@@ -15,7 +15,6 @@ USES= bison gmake
ALL_EXAMPLES= Makefile fibonacci.spl fibonacci2.spl guess.spl hello.spl \
primes.spl reverse.spl shakesbeer.spl
-NO_STAGE= yes
post-patch:
.for f in . examples
${REINPLACE_CMD} -e 's,= gcc,?= gcc,' -e 's,^CCFLAGS.*,CFLAGS += -Wall,' \
@@ -25,10 +24,10 @@ post-patch:
-e 's,free(,//free(,g' ${WRKSRC}/makescanner.c
do-install:
- ${TAR} -C ${WRKSRC}/spl -cf - . | ${TAR} -C ${PREFIX} -xf -
+ ${TAR} -C ${WRKSRC}/spl -cf - . | ${TAR} -C ${STAGEDIR}${PREFIX} -xf -
.if !defined(NOPORTDOCS)
- ${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC}/examples && ${INSTALL_DATA} ${ALL_EXAMPLES} ${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${INSTALL_DATA} ${ALL_EXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>