aboutsummaryrefslogtreecommitdiff
path: root/lang/spl
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-03-02 22:40:17 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-03-02 22:40:17 +0000
commitd0ff1198e78be2abf6c942b19893b498bcdb8011 (patch)
treedb2c0003b8d069aa6be8feb8fb7a6bf81594f5b2 /lang/spl
parent4e639dae272756d12c3c15e2e5d496fefd8fd491 (diff)
downloadports-d0ff1198e78be2abf6c942b19893b498bcdb8011.tar.gz
ports-d0ff1198e78be2abf6c942b19893b498bcdb8011.zip
Add spl 1.2.1, the Shakespeare programming language.
PR: 30395 Submitted by: Hye-Shik Chang <perky@fallin.lv>
Notes
Notes: svn path=/head/; revision=55419
Diffstat (limited to 'lang/spl')
-rw-r--r--lang/spl/Makefile35
-rw-r--r--lang/spl/distinfo1
-rw-r--r--lang/spl/pkg-comment1
-rw-r--r--lang/spl/pkg-descr7
-rw-r--r--lang/spl/pkg-plist12
5 files changed, 56 insertions, 0 deletions
diff --git a/lang/spl/Makefile b/lang/spl/Makefile
new file mode 100644
index 000000000000..0a0d4656caf6
--- /dev/null
+++ b/lang/spl/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: spl
+# Date created: 6 September 2001
+# Whom: Hye-Shik Chang <perky@fallin.lv>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spl
+PORTVERSION= 1.2.1
+CATEGORIES= lang
+MASTER_SITES= http://shakespearelang.sourceforge.net/download/
+
+MAINTAINER= perky@fallin.lv
+
+USE_BISON= yes
+USE_GMAKE= yes
+
+ALL_EXAMPLES= Makefile fibonacci.spl fibonacci2.spl guess.spl hello.spl \
+ primes.spl reverse.spl shakesbeer.spl
+
+post-patch:
+ @${PERL} -pi -e 's,= gcc,?= gcc,; s,^CCFLAGS.*,CFLAGS += -Wall,; \
+ s,CCFLAGS,CFLAGS,g' \
+ ${WRKSRC}/Makefile ${WRKSRC}/examples/Makefile
+
+do-install:
+ ${TAR} -C ${WRKSRC}/spl -cf- . | ${TAR} -C ${PREFIX} -xpf-
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${INSTALL_DATA} ${ALL_EXAMPLES} ${EXAMPLESDIR}
+ @${PERL} -pi -e 's,^SPLPATH =.*,SPLPATH =${PREFIX},g' \
+ ${EXAMPLESDIR}/Makefile
+.endif
+
+.include <bsd.port.mk>
diff --git a/lang/spl/distinfo b/lang/spl/distinfo
new file mode 100644
index 000000000000..6cb3c81302f8
--- /dev/null
+++ b/lang/spl/distinfo
@@ -0,0 +1 @@
+MD5 (spl-1.2.1.tar.gz) = c31de8415af80819eb944a1cecadddde
diff --git a/lang/spl/pkg-comment b/lang/spl/pkg-comment
new file mode 100644
index 000000000000..1b41ddecb113
--- /dev/null
+++ b/lang/spl/pkg-comment
@@ -0,0 +1 @@
+The Shakespeare programming language
diff --git a/lang/spl/pkg-descr b/lang/spl/pkg-descr
new file mode 100644
index 000000000000..69e98b1b2b5f
--- /dev/null
+++ b/lang/spl/pkg-descr
@@ -0,0 +1,7 @@
+The Shakespeare programming language is another esoteric
+programming language like Chef, Sorted! and others. The
+main purpose of this language is to make the source code
+for programs written with it resemble a Shakespeare play.
+Yes, it's totally unnecessary, but also very fun.
+
+WWW: http://shakespearelang.sourceforge.net
diff --git a/lang/spl/pkg-plist b/lang/spl/pkg-plist
new file mode 100644
index 000000000000..76ca78b69821
--- /dev/null
+++ b/lang/spl/pkg-plist
@@ -0,0 +1,12 @@
+bin/spl2c
+include/spl.h
+lib/libspl.a
+%%PORTDOCS%%share/examples/spl/Makefile
+%%PORTDOCS%%share/examples/spl/hello.spl
+%%PORTDOCS%%share/examples/spl/primes.spl
+%%PORTDOCS%%share/examples/spl/reverse.spl
+%%PORTDOCS%%share/examples/spl/fibonacci.spl
+%%PORTDOCS%%share/examples/spl/fibonacci2.spl
+%%PORTDOCS%%share/examples/spl/guess.spl
+%%PORTDOCS%%share/examples/spl/shakesbeer.spl
+%%PORTDOCS%%@dirrm share/examples/spl