aboutsummaryrefslogtreecommitdiff
path: root/lang/tcl86
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-04-18 08:20:59 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-04-18 08:20:59 +0000
commit80feea0bb30bd2dbb0bedc105fb652ab1afeef52 (patch)
treed5d9c36f74d1ecd4b3d080ec234fbbd428a64fa1 /lang/tcl86
parent958adf68c7547b2c380b8fa327e87d0379454b4a (diff)
downloadports-80feea0bb30bd2dbb0bedc105fb652ab1afeef52.tar.gz
ports-80feea0bb30bd2dbb0bedc105fb652ab1afeef52.zip
- Fix a long standing problem in tclConfig.sh and tkConfig.sh, where paths
were set based on WRKSRC instead of PREFIX. This mainly affected TEA-based extensions that source tclConfig.sh / tkConfig.sh to set important variables. An example is TCL_SRC_DIR, which is used to locate Tcl/Tk private header files such as tclUnixPort.h or tkUnixPort.h. This variable was previously set to WRKSRC, which caused ports to need additional tweaks to CFLAGS or CONFIGURE_ARGS. It should now be possible to build TEA-based extensions by specifying only the CONFIGURE_ARGS --with-tcl=${TCL_LIBDIR} / --with-tk=${TK_LIBDIR}. Feature safe: yes Approved by: bapt (portmgr)
Notes
Notes: svn path=/head/; revision=316025
Diffstat (limited to 'lang/tcl86')
-rw-r--r--lang/tcl86/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/lang/tcl86/Makefile b/lang/tcl86/Makefile
index c2bd5281f580..ffb1b01901dd 100644
--- a/lang/tcl86/Makefile
+++ b/lang/tcl86/Makefile
@@ -77,6 +77,12 @@ BROKEN= Does not build on arm
.endif
post-patch:
+ ${REINPLACE_CMD} -e \
+ 's|@TCL_BUILD_LIB_SPEC@|@TCL_LIB_SPEC@|; \
+ s|@TCL_BUILD_STUB_LIB_SPEC@|@TCL_STUB_LIB_SPEC@|; \
+ s|@TCL_BUILD_STUB_LIB_PATH@|@TCL_STUB_LIB_PATH@|; \
+ s|@TCL_SRC_DIR@|${PREFIX}/include/tcl${TCL_VER}|' \
+ ${WRKSRC}/tclConfig.sh.in
.if !${PORT_OPTIONS:MTCLMAN}
@${FIND} ${WRKSRC}/../pkgs -name Makefile.in | ${XARGS} ${REINPLACE_CMD} \
-e '/^install:/s|install-doc||'