aboutsummaryrefslogtreecommitdiff
path: root/lang/tcl86
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-08-08 10:51:03 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-08-08 10:51:03 +0000
commitb01c64d84376c3367d58a74232318cad69e24944 (patch)
tree14efa8ebb5ced1c4d519801be63426e388b7c25d /lang/tcl86
parent975394c1de7c4f7cd951e2a661e7a3703d6a4d04 (diff)
downloadports-b01c64d84376c3367d58a74232318cad69e24944.tar.gz
ports-b01c64d84376c3367d58a74232318cad69e24944.zip
- Fix installation of stripped libraries
- Fix pkg-config file [1] Obtained from: upstream (http://core.tcl.tk/tcl/info/667dfe5615) [1]
Notes
Notes: svn path=/head/; revision=364351
Diffstat (limited to 'lang/tcl86')
-rw-r--r--lang/tcl86/Makefile6
-rw-r--r--lang/tcl86/files/patch-unix-Makefile.in11
-rw-r--r--lang/tcl86/files/patch-unix-tcl.pc.in15
3 files changed, 26 insertions, 6 deletions
diff --git a/lang/tcl86/Makefile b/lang/tcl86/Makefile
index 9c4edd8561af..205c10b28647 100644
--- a/lang/tcl86/Makefile
+++ b/lang/tcl86/Makefile
@@ -27,7 +27,7 @@ MODULES_DESC= Install Tcl common modules
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}/unix
ALL_TARGET= all
-INSTALL_TARGET= install install-libraries
+INSTALL_TARGET= install-strip install-libraries
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -97,10 +97,6 @@ post-configure:
-e 's,-DNO_MEMMOVE=1,,' -e 's,-DNO_STRING_H=1,,' \
-e 's,^COMPAT_OBJS.*,,' ${WRKSRC}/Makefile
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/tclsh${TCL_VER}
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtcl${SHORT_TCL_VER}.so.1
-
regression-test: build
cd ${WRKSRC} && LC_ALL=C ${MAKE} test
diff --git a/lang/tcl86/files/patch-unix-Makefile.in b/lang/tcl86/files/patch-unix-Makefile.in
index f2083b53a6f5..871237685bb6 100644
--- a/lang/tcl86/files/patch-unix-Makefile.in
+++ b/lang/tcl86/files/patch-unix-Makefile.in
@@ -1,5 +1,5 @@
--- Makefile.in.orig 2013-09-19 22:17:13.000000000 +0200
-+++ Makefile.in 2014-04-28 10:32:43.000000000 +0200
++++ Makefile.in 2014-08-08 12:36:53.000000000 +0200
@@ -54,6 +54,8 @@
# Directory in which to install the include file tcl.h:
@@ -22,6 +22,15 @@
# Package search path.
TCL_PACKAGE_PATH = @TCL_PACKAGE_PATH@
+@@ -152,7 +154,7 @@
+ # distribution, which is slower but guaranteed to work.
+
+ INSTALL_STRIP_PROGRAM = -s
+-INSTALL_STRIP_LIBRARY = -S -x
++INSTALL_STRIP_LIBRARY = -s
+
+ INSTALL = $(SHELL) $(UNIX_DIR)/install-sh -c
+ INSTALL_PROGRAM = ${INSTALL}
@@ -611,9 +613,9 @@
# Start of rules
#--------------------------------------------------------------------------
diff --git a/lang/tcl86/files/patch-unix-tcl.pc.in b/lang/tcl86/files/patch-unix-tcl.pc.in
new file mode 100644
index 000000000000..9c161a15231c
--- /dev/null
+++ b/lang/tcl86/files/patch-unix-tcl.pc.in
@@ -0,0 +1,15 @@
+--- tcl.pc.in.orig 2014-08-08 11:15:04.000000000 +0200
++++ tcl.pc.in 2014-08-08 11:15:11.000000000 +0200
+@@ -8,8 +8,8 @@
+ Name: Tool Command Language
+ Description: Tcl is a powerful, easy-to-learn dynamic programming language, suitable for a wide range of uses.
+ URL: http://www.tcl.tk/
+-Version: @TCL_VERSION@
+-Requires:
+-Conflicts:
+-Libs: -L${libdir} @TCL_LIBS@
++Version: @TCL_VERSION@@TCL_PATCH_LEVEL@
++Requires.private: zlib >= 1.2.3
++Libs: -L${libdir} @TCL_LIB_FLAG@ @TCL_STUB_LIB_FLAG@
++Libs.private: @TCL_LIBS@
+ Cflags: -I${includedir}