aboutsummaryrefslogtreecommitdiff
path: root/lang/tolua++
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-03-07 19:42:56 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-03-07 19:42:56 +0000
commit5767a87a7fc44483017ccff52229d78530214bf0 (patch)
tree0e2e5cc0ea4c371e11c5d870a36c9f6b19bf5c87 /lang/tolua++
parenta45fa4a92770c966f21591381662b15071c4a9f6 (diff)
downloadports-5767a87a7fc44483017ccff52229d78530214bf0.tar.gz
ports-5767a87a7fc44483017ccff52229d78530214bf0.zip
- Update to 1.0.93
PR: 154168 Submitted by: Rusty Nejdl <rnejdl@ringofsaturn.com>
Notes
Notes: svn path=/head/; revision=270459
Diffstat (limited to 'lang/tolua++')
-rw-r--r--lang/tolua++/Makefile3
-rw-r--r--lang/tolua++/distinfo5
-rw-r--r--lang/tolua++/files/patch-gcc43-fixes130
-rw-r--r--lang/tolua++/files/patch-src-lib-SCsub16
4 files changed, 15 insertions, 139 deletions
diff --git a/lang/tolua++/Makefile b/lang/tolua++/Makefile
index 03bce96e89ff..d4ec10baf749 100644
--- a/lang/tolua++/Makefile
+++ b/lang/tolua++/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= tolua++
-PORTVERSION= 1.0.92
-PORTREVISION= 3
+PORTVERSION= 1.0.93
CATEGORIES= lang devel
MASTER_SITES= http://www.codenix.com/~tolua/ \
http://mirror.amdmi3.ru/distfiles/
diff --git a/lang/tolua++/distinfo b/lang/tolua++/distinfo
index edc78f47bdf9..f018695077db 100644
--- a/lang/tolua++/distinfo
+++ b/lang/tolua++/distinfo
@@ -1,3 +1,2 @@
-MD5 (tolua++-1.0.92.tar.bz2) = f4682e065b7d6d4de5eec13e6b7d347c
-SHA256 (tolua++-1.0.92.tar.bz2) = fd2199f669d7d7c11f5451001ee1601add263203b2522363b3632411437e4fac
-SIZE (tolua++-1.0.92.tar.bz2) = 153961
+SHA256 (tolua++-1.0.93.tar.bz2) = 90df1eeb8354941ca65663dcf28658b67d3aa41daa71133bdd20c35abb1bcaba
+SIZE (tolua++-1.0.93.tar.bz2) = 163956
diff --git a/lang/tolua++/files/patch-gcc43-fixes b/lang/tolua++/files/patch-gcc43-fixes
deleted file mode 100644
index 1e982f2b1214..000000000000
--- a/lang/tolua++/files/patch-gcc43-fixes
+++ /dev/null
@@ -1,130 +0,0 @@
---- include/tolua++.h.orig 2006-04-27 05:33:40.000000000 +0200
-+++ include/tolua++.h 2008-03-13 23:20:12.000000000 +0100
-@@ -53,7 +53,7 @@
- #define TOLUA_NOPEER LUA_REGISTRYINDEX /* for lua 5.1 */
-
- TOLUA_API const char* tolua_typename (lua_State* L, int lo);
--TOLUA_API void tolua_error (lua_State* L, char* msg, tolua_Error* err);
-+TOLUA_API void tolua_error (lua_State* L, const char* msg, tolua_Error* err);
- TOLUA_API int tolua_isnoobj (lua_State* L, int lo, tolua_Error* err);
- TOLUA_API int tolua_isvalue (lua_State* L, int lo, int def, tolua_Error* err);
- TOLUA_API int tolua_isboolean (lua_State* L, int lo, int def, tolua_Error* err);
-@@ -84,16 +84,15 @@
- TOLUA_API int tolua_register_gc (lua_State* L, int lo);
- TOLUA_API int tolua_default_collect (lua_State* tolua_S);
-
--TOLUA_API void tolua_usertype (lua_State* L, char* type);
--TOLUA_API void tolua_beginmodule (lua_State* L, char* name);
-+TOLUA_API void tolua_usertype (lua_State* L, const char* type);
-+TOLUA_API void tolua_beginmodule (lua_State* L, const char* name);
- TOLUA_API void tolua_endmodule (lua_State* L);
--TOLUA_API void tolua_module (lua_State* L, char* name, int hasvar);
--TOLUA_API void tolua_class (lua_State* L, char* name, char* base);
--TOLUA_API void tolua_cclass (lua_State* L, char* lname, char* name, char* base, lua_CFunction col);
--TOLUA_API void tolua_function (lua_State* L, char* name, lua_CFunction func);
--TOLUA_API void tolua_constant (lua_State* L, char* name, double value);
--TOLUA_API void tolua_variable (lua_State* L, char* name, lua_CFunction get, lua_CFunction set);
--TOLUA_API void tolua_array (lua_State* L,char* name, lua_CFunction get, lua_CFunction set);
-+TOLUA_API void tolua_module (lua_State* L, const char* name, int hasvar);
-+TOLUA_API void tolua_cclass (lua_State* L, const char* lname, const char* name, const char* base, lua_CFunction col);
-+TOLUA_API void tolua_function (lua_State* L, const char* name, lua_CFunction func);
-+TOLUA_API void tolua_constant (lua_State* L, const char* name, double value);
-+TOLUA_API void tolua_variable (lua_State* L, const char* name, lua_CFunction get, lua_CFunction set);
-+TOLUA_API void tolua_array (lua_State* L, const char* name, lua_CFunction get, lua_CFunction set);
-
- /* TOLUA_API void tolua_set_call_event(lua_State* L, lua_CFunction func, char* type); */
- /* TOLUA_API void tolua_addbase(lua_State* L, char* name, char* base); */
---- src/lib/tolua_is.c.orig 2005-12-19 02:13:05.000000000 +0100
-+++ src/lib/tolua_is.c 2008-03-13 23:11:27.000000000 +0100
-@@ -85,7 +85,7 @@
- return lua_tostring(L,-1);
- }
-
--TOLUA_API void tolua_error (lua_State* L, char* msg, tolua_Error* err)
-+TOLUA_API void tolua_error (lua_State* L, const char* msg, tolua_Error* err)
- {
- if (msg[0] == '#')
- {
---- src/lib/tolua_map.c.orig 2006-03-13 23:37:49.000000000 +0100
-+++ src/lib/tolua_map.c 2008-03-13 23:21:58.000000000 +0100
-@@ -389,7 +389,7 @@
- * It creates the correspoding metatable in the registry, for both 'type' and 'const type'.
- * It maps 'const type' as being also a 'type'
- */
--TOLUA_API void tolua_usertype (lua_State* L, char* type)
-+TOLUA_API void tolua_usertype (lua_State* L, const char* type)
- {
- char ctype[128] = "const ";
- strncat(ctype,type,120);
-@@ -403,7 +403,7 @@
- /* Begin module
- * It pushes the module (or class) table on the stack
- */
--TOLUA_API void tolua_beginmodule (lua_State* L, char* name)
-+TOLUA_API void tolua_beginmodule (lua_State* L, const char* name)
- {
- if (name)
- {
-@@ -426,7 +426,7 @@
- * It creates a new module
- */
- #if 1
--TOLUA_API void tolua_module (lua_State* L, char* name, int hasvar)
-+TOLUA_API void tolua_module (lua_State* L, const char* name, int hasvar)
- {
- if (name)
- {
-@@ -462,7 +462,7 @@
- lua_pop(L,1); /* pop module */
- }
- #else
--TOLUA_API void tolua_module (lua_State* L, char* name, int hasvar)
-+TOLUA_API void tolua_module (lua_State* L, const char* name, int hasvar)
- {
- if (name)
- {
-@@ -518,7 +518,7 @@
- /* Map C class
- * It maps a C class, setting the appropriate inheritance and super classes.
- */
--TOLUA_API void tolua_cclass (lua_State* L, char* lname, char* name, char* base, lua_CFunction col)
-+TOLUA_API void tolua_cclass (lua_State* L, const char* lname, const char* name, const char* base, lua_CFunction col)
- {
- char cname[128] = "const ";
- char cbase[128] = "const ";
-@@ -577,7 +577,7 @@
- /* Map function
- * It assigns a function into the current module (or class)
- */
--TOLUA_API void tolua_function (lua_State* L, char* name, lua_CFunction func)
-+TOLUA_API void tolua_function (lua_State* L, const char* name, lua_CFunction func)
- {
- lua_pushstring(L,name);
- lua_pushcfunction(L,func);
-@@ -600,7 +600,7 @@
- /* Map constant number
- * It assigns a constant number into the current module (or class)
- */
--TOLUA_API void tolua_constant (lua_State* L, char* name, double value)
-+TOLUA_API void tolua_constant (lua_State* L, const char* name, double value)
- {
- lua_pushstring(L,name);
- tolua_pushnumber(L,value);
-@@ -611,7 +611,7 @@
- /* Map variable
- * It assigns a variable into the current module (or class)
- */
--TOLUA_API void tolua_variable (lua_State* L, char* name, lua_CFunction get, lua_CFunction set)
-+TOLUA_API void tolua_variable (lua_State* L, const char* name, lua_CFunction get, lua_CFunction set)
- {
- /* get func */
- lua_pushstring(L,".get");
-@@ -663,7 +663,7 @@
- /* Map an array
- * It assigns an array into the current module (or class)
- */
--TOLUA_API void tolua_array (lua_State* L, char* name, lua_CFunction get, lua_CFunction set)
-+TOLUA_API void tolua_array (lua_State* L, const char* name, lua_CFunction get, lua_CFunction set)
- {
- lua_pushstring(L,".get");
- lua_rawget(L,-2);
diff --git a/lang/tolua++/files/patch-src-lib-SCsub b/lang/tolua++/files/patch-src-lib-SCsub
index 736f807b34b1..727e4bc96c90 100644
--- a/lang/tolua++/files/patch-src-lib-SCsub
+++ b/lang/tolua++/files/patch-src-lib-SCsub
@@ -1,8 +1,16 @@
---- src/lib/SCsub.orig 2005-11-28 16:51:15.000000000 +0300
-+++ src/lib/SCsub 2008-08-22 01:44:24.000000000 +0400
-@@ -10,4 +10,5 @@
+--- src/lib/SCsub.orig 2011-01-20 07:48:43.000000000 +0100
++++ src/lib/SCsub 2011-01-20 07:58:30.000000000 +0100
+@@ -9,10 +9,7 @@
+ 'tolua_to.c',
]
- env.lib_target = env.Library('#/lib/'+env['tolua_lib'], sources)
+-env.lib_target_static = env.Library('#/lib/'+env['tolua_lib']+'_static', sources)
+-
+-if env['shared']:
+- env.lib_target = env.SharedLibrary('#lib/'+env['tolua_lib'], sources)
+-else:
+- env.lib_target = env.Library('#/lib/'+env['tolua_lib'], sources)
++env.lib_target_static = env.Library('#/lib/'+env['tolua_lib'], sources)
++env.lib_target = env.Library('#/lib/'+env['tolua_lib'], sources)
+env.lib_target += env.SharedLibrary('#/lib/'+env['tolua_lib'], sources)