aboutsummaryrefslogtreecommitdiff
path: root/lang/tuareg-mode.el
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-02-20 23:22:14 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-02-20 23:22:14 +0000
commit44293853a0d362bf4ad370b4819e87900774f542 (patch)
tree2db042f10ff02dbd7372d89f19c945742c23cc9d /lang/tuareg-mode.el
parentb8765532491728e0ef809eb4ee2c230c934a32a1 (diff)
downloadports-44293853a0d362bf4ad370b4819e87900774f542.tar.gz
ports-44293853a0d362bf4ad370b4819e87900774f542.zip
- Drag from attic
- Update to 1.45.6 - Bump portepoch - Pass maintainership to submitter Tuareg is a Caml mode for GNU Emacs and XEmacs. It handles automatic indentation of Objective Caml and Camllight codes. Key parts of the code are hilighted using Font-Lock. Support to run an interactive Caml toplevel and debbuger is provided. This mode attempts to give better results than the one provided in the standard distribution OCaml 3.x. Indentation rules are slightly different but closer to classical functional languages. There is no relation with the Tuareg People, except their reputation of great CAMEL riders and breeders. PR: ports/120494 Submitted by: Michael Grunewald <michael.grunewald@laposte.net> (maintainer)
Notes
Notes: svn path=/head/; revision=207676
Diffstat (limited to 'lang/tuareg-mode.el')
-rw-r--r--lang/tuareg-mode.el/Makefile55
-rw-r--r--lang/tuareg-mode.el/distinfo3
-rw-r--r--lang/tuareg-mode.el/pkg-descr17
-rw-r--r--lang/tuareg-mode.el/scripts/batch-compile.el11
4 files changed, 86 insertions, 0 deletions
diff --git a/lang/tuareg-mode.el/Makefile b/lang/tuareg-mode.el/Makefile
new file mode 100644
index 000000000000..9a6a44997172
--- /dev/null
+++ b/lang/tuareg-mode.el/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: tuareg-mode
+# Date created: 28 October 2004
+# Whom: dd
+#
+# $FreeBSD$
+#
+
+PORTNAME= tuareg-mode
+PORTVERSION= 1.45.6
+PORTEPOCH= 1
+CATEGORIES= lang elisp
+MASTER_SITES= http://www-rocq.inria.fr/~acohen/tuareg/mode/
+
+MAINTAINER= michael.grunewald@laposte.net
+COMMENT= Emacs major mode for editing Caml code
+
+USE_EMACS= yes
+USE_BZIP2= yes
+
+DOC_FILES= README HISTORY append-tuareg.el custom-tuareg.el
+DOC_DIR= share/doc/tuareg-mode
+ELISP_FILES= camldebug.el tuareg.el
+
+PLIST_FILES= ${ELISP_FILES:S/^/${EMACS_SITE_LISPDIR}\//} \
+ ${ELISP_FILES:S/^/${EMACS_SITE_LISPDIR}\//S/$/c/} \
+ ${DOC_FILES:S/^/${DOC_DIR}\//}
+PLIST_DIRS= ${DOC_DIR}
+
+# Note: append-tuareg.el and custom-tuareg.el are example files,
+# they are thus considered part of the documentation.
+
+#
+# Operations
+#
+
+# We do provide our own build and install procedures, instead of using
+# mainstream author's one.
+
+do-build:
+.for tuareg_mode_f in ${ELISP_FILES}
+ cd ${WRKSRC} &&\
+ ${EMACS_CMD} -batch -q -l ${SCRIPTDIR}/batch-compile.el ${tuareg_mode_f}
+.endfor
+
+do-install:
+.for tuareg_mode_f in ${ELISP_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${tuareg_mode_f} ${WRKSRC}/${tuareg_mode_f}c \
+ ${PREFIX}/${EMACS_SITE_LISPDIR}
+.endfor
+ ${MKDIR} ${PREFIX}/${DOC_DIR}
+.for tuareg_mode_f in ${DOC_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${tuareg_mode_f} ${PREFIX}/${DOC_DIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/lang/tuareg-mode.el/distinfo b/lang/tuareg-mode.el/distinfo
new file mode 100644
index 000000000000..46bf5ab6d0de
--- /dev/null
+++ b/lang/tuareg-mode.el/distinfo
@@ -0,0 +1,3 @@
+MD5 (tuareg-mode-1.45.6.tar.bz2) = 75df362cba2d32e9828eebe80716009f
+SHA256 (tuareg-mode-1.45.6.tar.bz2) = 2f22834259a6b0c065a6528a519eda3d0164a9bf2de8a5f7c041d6a91777261b
+SIZE (tuareg-mode-1.45.6.tar.bz2) = 46822
diff --git a/lang/tuareg-mode.el/pkg-descr b/lang/tuareg-mode.el/pkg-descr
new file mode 100644
index 000000000000..39066462f13d
--- /dev/null
+++ b/lang/tuareg-mode.el/pkg-descr
@@ -0,0 +1,17 @@
+From the web site:
+
+ Tuareg is a Caml mode for GNU Emacs and XEmacs. It handles automatic
+ indentation of Objective Caml and Camllight codes. Key parts of the
+ code are hilighted using Font-Lock. Support to run an interactive
+ Caml toplevel and debbuger is provided.
+
+ This mode attempts to give better results than the one provided in
+ the standard distribution OCaml 3.x. Indentation rules are slightly
+ different but closer to classical functional languages.
+
+ There is no relation with the Tuareg People, except their reputation
+ of great CAMEL riders and breeders.
+
+Documentation is installed into share/doc/tuareg-mode
+
+WWW: http://www-rocq.inria.fr/~acohen/tuareg/
diff --git a/lang/tuareg-mode.el/scripts/batch-compile.el b/lang/tuareg-mode.el/scripts/batch-compile.el
new file mode 100644
index 000000000000..1a18140118f1
--- /dev/null
+++ b/lang/tuareg-mode.el/scripts/batch-compile.el
@@ -0,0 +1,11 @@
+(setq load-path (cons "." load-path))
+(batch-byte-compile)
+END-of-tuareg-mode.el/scripts/batch-compile.el
+echo x - tuareg-mode.el/distinfo
+sed 's/^X//' >tuareg-mode.el/distinfo << 'END-of-tuareg-mode.el/distinfo'
+MD5 (tuareg-mode-1.45.6.tar.bz2) =3D 75df362cba2d32e9828eebe80716009f
+SHA256 (tuareg-mode-1.45.6.tar.bz2) =3D 2f22834259a6b0c065a6528a519eda3d01=
+64a9bf2de8a5f7c041d6a91777261b
+SIZE (tuareg-mode-1.45.6.tar.bz2) =3D 46822
+END-of-tuareg-mode.el/distinfo
+exit