aboutsummaryrefslogtreecommitdiff
path: root/lang/ucc/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-12-31 08:10:20 +0000
committerWen Heping <wen@FreeBSD.org>2011-12-31 08:10:20 +0000
commita151b7a0adba107b05b5d7810a943e100f492fcb (patch)
treedee69ee4fb686b2e8b888af10af24560599377db /lang/ucc/Makefile
parent4e860ae744a936a88ab824dacfe1957610ddfa09 (diff)
downloadports-a151b7a0adba107b05b5d7810a943e100f492fcb.tar.gz
ports-a151b7a0adba107b05b5d7810a943e100f492fcb.zip
Notes
Diffstat (limited to 'lang/ucc/Makefile')
-rw-r--r--lang/ucc/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/lang/ucc/Makefile b/lang/ucc/Makefile
index 667c6dd02b02..210822b7105e 100644
--- a/lang/ucc/Makefile
+++ b/lang/ucc/Makefile
@@ -15,9 +15,19 @@ MAINTAINER= wenheping@gmail.com
COMMENT= C Compiler Which Implements the ANSI C89 Standard
USE_ZIP= yes
+USE_DOS2UNIX= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_GMAKE= yes
USE_LDCONFIG= yes
+post-patch: .SILENT
+ ${REINPLACE_CMD} 's/make/$$(MAKE)/' \
+ ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e '/^CC[[:blank:]]*=/d' \
+ -e '/^CFLAGS/ { s/=/+=/; s/-g//; }' \
+ -e '/:[[:blank:]]/s/\.c/.o/g' \
+ -e 's/$$^/$$>/g' \
+ ${WRKSRC}/driver/Makefile \
+ ${WRKSRC}/ucl/Makefile
+
.include <bsd.port.mk>