aboutsummaryrefslogtreecommitdiff
path: root/lang/v8-devel
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-03-27 09:22:54 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-03-27 09:22:54 +0000
commit613e9d821af9c4e33dd2cf62b32629069697f728 (patch)
tree3e275872db4039ab2828e6343c06ae9cce560aa6 /lang/v8-devel
parentb253dc3f2b49e82d611f9eb14532836323f5cfc0 (diff)
downloadports-613e9d821af9c4e33dd2cf62b32629069697f728.tar.gz
ports-613e9d821af9c4e33dd2cf62b32629069697f728.zip
Notes
Diffstat (limited to 'lang/v8-devel')
-rw-r--r--lang/v8-devel/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/lang/v8-devel/Makefile b/lang/v8-devel/Makefile
index 3690105651a8..7ebad47c3f40 100644
--- a/lang/v8-devel/Makefile
+++ b/lang/v8-devel/Makefile
@@ -19,9 +19,8 @@ LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
CONFLICTS= v8-3.19.*
-USES= gmake shebangfix compiler
+USES= gmake shebangfix compiler tar:xz
SHEBANG_FILES= ${WRKSRC}/build/gyp/gyp
-USE_XZ= yes
USE_PYTHON= 2
USE_LDCONFIG= yes
ALL_TARGET= native
@@ -38,6 +37,9 @@ CFLAGS+= -Wno-unused-private-field -Wno-unused-variable
.if ${COMPILER_VERSION} >= 33
CFLAGS+= -Wno-nested-anon-types -Wno-unused-function
.endif
+.if ${COMPILER_VERSION} >= 34
+CFLAGS+= -Wno-unused-const-variable
+.endif
.else
MAKE_ARGS+= strictaliasing=off
USE_GCC= any