aboutsummaryrefslogtreecommitdiff
path: root/lang/v8
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-12-05 17:12:42 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-12-05 17:12:42 +0000
commit0bb9587da477445db151a5b05d57189a00454937 (patch)
treee5c706078efb351ba04b7b3f44a6a9403ba7a54c /lang/v8
parentacd27e6a47b7213cefa491ff9d34bbf5789c84f4 (diff)
downloadports-0bb9587da477445db151a5b05d57189a00454937.tar.gz
ports-0bb9587da477445db151a5b05d57189a00454937.zip
- Fix build with clang 3.5.0
PR: ports/195666 Submitted by: dim
Notes
Notes: svn path=/head/; revision=374059
Diffstat (limited to 'lang/v8')
-rw-r--r--lang/v8/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/lang/v8/Makefile b/lang/v8/Makefile
index 80d365184c8f..eb378737eb07 100644
--- a/lang/v8/Makefile
+++ b/lang/v8/Makefile
@@ -38,6 +38,9 @@ MAKE_ENV+= LINK=clang++
CFLAGS+= -Wno-nested-anon-types -Wno-unused-function
.if ${COMPILER_VERSION} >= 34
CFLAGS+= -Wno-unused-const-variable
+.if ${COMPILER_VERSION} >= 35
+CFLAGS+= -Wno-tautological-undefined-compare
+.endif
.endif
.endif
.else