aboutsummaryrefslogtreecommitdiff
path: root/lang/xotcl
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-13 10:16:03 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-13 10:16:03 +0000
commit80eb2c68b227728e0aeb6ffc6c9c4e3a88e6cd14 (patch)
tree8bb37eb8f2eff57d0655030f1d0886bff52f05b0 /lang/xotcl
parent007189ceb1c4954f478e5f420c10a83d7f771697 (diff)
downloadports-80eb2c68b227728e0aeb6ffc6c9c4e3a88e6cd14.tar.gz
ports-80eb2c68b227728e0aeb6ffc6c9c4e3a88e6cd14.zip
Notes
Diffstat (limited to 'lang/xotcl')
-rw-r--r--lang/xotcl/Makefile16
-rw-r--r--lang/xotcl/files/patch-Makefile.in28
-rw-r--r--lang/xotcl/files/patch-configure11
-rw-r--r--lang/xotcl/files/patch-configure.in11
-rw-r--r--lang/xotcl/files/patch-library::store::XOTclGdbm::configure11
-rw-r--r--lang/xotcl/files/patch-library::store::XOTclGdbm::configure.in11
-rw-r--r--lang/xotcl/pkg-plist86
7 files changed, 165 insertions, 9 deletions
diff --git a/lang/xotcl/Makefile b/lang/xotcl/Makefile
index e87e07ab992f..d66c7ed840b4 100644
--- a/lang/xotcl/Makefile
+++ b/lang/xotcl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xotcl
PORTVERSION= 1.5.3
+PORTREVISION= 1
CATEGORIES= lang tcl83 tcl84
MASTER_SITES= http://media.wu-wien.ac.at/download/
@@ -17,12 +18,13 @@ GNU_CONFIGURE= yes
USE_TCL= yes
USE_TCL_BUILD= yes
ALL_TARGET= all test-nohttp
-INSTALL_TARGET= install-binaries install-libraries
+INSTALL_TARGET= install
USE_LDCONFIG= yes
USE_GMAKE= yes
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-OPTIONS= AOLSERVER "AOL server module" off \
+OPTIONS= ACTIWEB "Include actiweb" on \
+ AOLSERVER "AOL server module" off \
THREADS "Force threaded build" off \
TUTORIAL "Install XOTcl tutorial" off
@@ -34,11 +36,19 @@ CONFIGURE_ARGS+= --exec-prefix=${PREFIX} \
.include <bsd.port.pre.mk>
+.if defined(WITH_ACTIWEB)
+CONFIGURE_ARGS+= --with-actiweb --with-gdbm=${LOCALBASE}/include,${LOCALBASE}/lib
+LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
+PLIST_SUB+= ACTIWEB=""
+.else
+PLIST_SUB+= ACTIWEB="@comment "
+.endif
+
.if defined(WITH_AOLSERVER)
BUILD_DEPENDS+= ${LOCALBASE}/aolserver/bin/init.tcl:${PORTSDIR}/www/aolserver
RUN_DEPENDS+= ${BUILD_DEPENDS}
PLIST_SUB+= AOLSERVER=""
-INSTALL_TARGET= install-aol
+INSTALL_TARGET+= install-aol
.else
PLIST_SUB+= AOLSERVER="@comment "
.endif
diff --git a/lang/xotcl/files/patch-Makefile.in b/lang/xotcl/files/patch-Makefile.in
index 668f24179f19..dcfd077c8198 100644
--- a/lang/xotcl/files/patch-Makefile.in
+++ b/lang/xotcl/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig Wed Sep 27 16:21:56 2006
-+++ Makefile.in Wed Sep 27 16:43:46 2006
-@@ -261,11 +261,11 @@
+--- Makefile.in.orig Thu Sep 28 11:19:12 2006
++++ Makefile.in Tue Dec 12 15:58:50 2006
+@@ -262,11 +262,11 @@
#========================================================================
# This rule installs platform-independent files, such as header files.
#========================================================================
@@ -15,7 +15,7 @@
done;
@echo "Installing Libraries to $(DESTDIR)$(pkglibdir)/"
@for i in $(libdirs) ; do \
-@@ -283,7 +283,7 @@
+@@ -284,7 +284,7 @@
$(INSTALL_DATA) $(src_lib_dir)/$$i $(DESTDIR)$(pkglibdir)/$$i ; \
done;
cat unix/pkgIndex.unix >> $(DESTDIR)$(pkglibdir)/pkgIndex.tcl
@@ -24,7 +24,23 @@
@echo "Installing Applications to $(DESTDIR)$(pkglibdir)/apps/"
@for i in $(appdirs) ; do \
echo " Installing $$i/" ; \
-@@ -534,7 +534,6 @@
+@@ -292,7 +292,15 @@
+ mkdir -p $(DESTDIR)$(pkglibdir)/apps/$$i; \
+ chmod 755 $(DESTDIR)$(pkglibdir)/apps/$$i; \
+ for j in $(src_app_dir)/$$i/* ; do \
++ if test -d $$j; then \
++ mkdir -p $(DESTDIR)$(pkglibdir)/$$j; \
++ chmod 755 $(DESTDIR)$(pkglibdir)/$$j; \
++ for k in $$j/* ; do \
++ $(INSTALL) $$k $(DESTDIR)$(pkglibdir)/$$j ; \
++ done; \
++ else \
+ $(INSTALL) $$j $(DESTDIR)$(pkglibdir)/apps/$$i/; \
++ fi; \
+ done; \
+ done;
+ @for i in $(appsrc) ; do \
+@@ -535,7 +543,6 @@
else \
echo " $(RANLIB) $(DESTDIR)$(pkglibdir)/$$p"; \
$(RANLIB) $(DESTDIR)$(pkglibdir)/$$p; \
@@ -32,7 +48,7 @@
fi; \
ext=`echo $$p|sed -e "s/.*\.//"`; \
if test "x$$ext" = "xdll"; then \
-@@ -591,12 +590,12 @@
+@@ -592,12 +599,12 @@
rm -f $(DESTDIR)$(bindir)/$$p; \
done
diff --git a/lang/xotcl/files/patch-configure b/lang/xotcl/files/patch-configure
new file mode 100644
index 000000000000..945173dd370f
--- /dev/null
+++ b/lang/xotcl/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Tue Dec 12 14:22:44 2006
++++ configure Tue Dec 12 14:22:59 2006
+@@ -11206,7 +11206,7 @@
+ for subdir in ${subdirs}
+ do
+ echo "==================== configure $subdir ====================="
+- if test x"${srcdir}" == x. ; then
++ if test x"${srcdir}" = x. ; then
+ confdir=.
+ else
+ mkdir -p $subdir
diff --git a/lang/xotcl/files/patch-configure.in b/lang/xotcl/files/patch-configure.in
new file mode 100644
index 000000000000..9a649e5827ee
--- /dev/null
+++ b/lang/xotcl/files/patch-configure.in
@@ -0,0 +1,11 @@
+--- configure.in.orig Tue Dec 12 14:23:37 2006
++++ configure.in Tue Dec 12 14:23:42 2006
+@@ -439,7 +439,7 @@
+ for subdir in ${subdirs}
+ do
+ echo "==================== configure $subdir ====================="
+- if test x"${srcdir}" == x. ; then
++ if test x"${srcdir}" = x. ; then
+ confdir=.
+ else
+ mkdir -p $subdir
diff --git a/lang/xotcl/files/patch-library::store::XOTclGdbm::configure b/lang/xotcl/files/patch-library::store::XOTclGdbm::configure
new file mode 100644
index 000000000000..d3d818616621
--- /dev/null
+++ b/lang/xotcl/files/patch-library::store::XOTclGdbm::configure
@@ -0,0 +1,11 @@
+--- library/store/XOTclGdbm/configure.orig Tue Dec 12 14:50:53 2006
++++ library/store/XOTclGdbm/configure Tue Dec 12 14:51:03 2006
+@@ -6150,7 +6150,7 @@
+ # This defines PKG(_STUB)_SOURCES, PKG(_STUB)_OBJECTS, PKG_HEADERS
+ # and PKG_TCL_SOURCES.
+ #-----------------------------------------------------------------------
+-if test ! "${with_gdbm}" == no; then
++if test ! "${with_gdbm}" = no; then
+ GDBM_INC_DIR="`echo $with_gdbm |cut -f1 -d,`"
+ GDBM_LIB_DIR="`echo $with_gdbm |cut -f2 -d, -s`"
+ fi
diff --git a/lang/xotcl/files/patch-library::store::XOTclGdbm::configure.in b/lang/xotcl/files/patch-library::store::XOTclGdbm::configure.in
new file mode 100644
index 000000000000..07fa88ff1fbf
--- /dev/null
+++ b/lang/xotcl/files/patch-library::store::XOTclGdbm::configure.in
@@ -0,0 +1,11 @@
+--- library/store/XOTclGdbm/configure.in.orig Tue Dec 12 14:50:49 2006
++++ library/store/XOTclGdbm/configure.in Tue Dec 12 14:51:09 2006
+@@ -87,7 +87,7 @@
+ # This defines PKG(_STUB)_SOURCES, PKG(_STUB)_OBJECTS, PKG_HEADERS
+ # and PKG_TCL_SOURCES.
+ #-----------------------------------------------------------------------
+-if test ! "${with_gdbm}" == no; then
++if test ! "${with_gdbm}" = no; then
+ GDBM_INC_DIR="`echo $with_gdbm |cut -f1 -d,`"
+ GDBM_LIB_DIR="`echo $with_gdbm |cut -f2 -d, -s`"
+ fi
diff --git a/lang/xotcl/pkg-plist b/lang/xotcl/pkg-plist
index a418f8beb63d..adeb6e0bccc0 100644
--- a/lang/xotcl/pkg-plist
+++ b/lang/xotcl/pkg-plist
@@ -1,3 +1,77 @@
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/actiweb/Agent.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/actiweb/AgentManagement.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/actiweb/HtmlPlace.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/actiweb/HttpPlace.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/actiweb/Invoker.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/actiweb/PlaceAccessControl.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/actiweb/SecureHtmlPlace.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/actiweb/SecureHttpPlace.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/actiweb/SendStrategy.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/actiweb/UserMgt.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/actiweb/WebAgent.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/actiweb/WebDocument.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/actiweb/WebObject.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/actiweb/pageTemplate.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/actiweb/pkgIndex.tcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/rdf/RDFCreator.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/rdf/RDFTriple.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/rdf/pkgIndex.tcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/rdf/rdfExample.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/rdf/rdfRecreatorVisitor.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/rdf/xoRDF.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/registry/Registry.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/registry/pkgIndex.tcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/store/JufGdbmStorage.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/store/MemStorage.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/store/MultiStorage.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/store/Persistence.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/store/Storage.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/store/TclGdbmStorage.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/store/TextFileStorage.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/store/persistenceExample.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/store/pkgIndex.tcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/xml/pkgIndex.tcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/xml/printVisitor.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/xml/sgml.tcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/xml/xml.tcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/xml/xml.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/xml/xmlExample.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/xml/xmlRecreatorVisitor.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/xml/xoXML.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/patterns/ChainOfResponsibility.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/patterns/OnCalleeProxy.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/patterns/Singleton.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/patterns/SortedComposite.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/patterns/adapter.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/patterns/composite.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/patterns/link.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/patterns/manager.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/patterns/observer.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/patterns/pkgIndex.tcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/apps/actiweb/AgentClient.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/apps/actiweb/Counter.README
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/apps/actiweb/Counter.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/apps/actiweb/Counter2.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/apps/actiweb/Counter3.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/apps/actiweb/Counter4.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/apps/actiweb/FormsWithState.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/apps/actiweb/MC.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/apps/actiweb/Receiver.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/apps/actiweb/examples.README
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/apps/actiweb/securePlaceDemo.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/apps/actiweb/univ/UNIVERSAL.css
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/apps/actiweb/univ/UNIVERSAL.jpg
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/apps/actiweb/univ/UNIVERSAL.rdf
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/apps/actiweb/univ/UNIVERSAL.xotcl
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/apps/actiweb/univ/server.key
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/apps/actiweb/univ/server.pem
+%%ACTIWEB%%lib/xotcl%%PORTVERSION%%/apps/persistence/persistenceTest.xotcl
+%%ACTIWEB%%lib/xotclexpat0.9/libxotclexpat0.9.so
+%%ACTIWEB%%lib/xotclexpat0.9/pkgIndex.tcl
+%%ACTIWEB%%lib/xotclsdbm1.2/libxotclsdbm1.2.so
+%%ACTIWEB%%lib/xotclsdbm1.2/pkgIndex.tcl
+%%ACTIWEB%%lib/xotclgdbm1.2/libxotclgdbm1.2.so
+%%ACTIWEB%%lib/xotclgdbm1.2/pkgIndex.tcl
%%AOLSERVER%%aolserver/modules/tcl/xotcl.tcl
bin/xotclsh
include/xotcl%%PORTVERSION%%/xotcl.h
@@ -161,6 +235,18 @@ lib/xotcl%%PORTVERSION%%/xotclConfig.sh
%%TUTORIAL%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%/announces
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%ACTIWEB%%@dirrm lib/xotcl%%PORTVERSION%%/actiweb
+%%ACTIWEB%%@dirrm lib/xotcl%%PORTVERSION%%/rdf
+%%ACTIWEB%%@dirrm lib/xotcl%%PORTVERSION%%/registry
+%%ACTIWEB%%@dirrm lib/xotcl%%PORTVERSION%%/store
+%%ACTIWEB%%@dirrm lib/xotcl%%PORTVERSION%%/xml
+%%ACTIWEB%%@dirrm lib/xotcl%%PORTVERSION%%/patterns
+%%ACTIWEB%%@dirrm lib/xotcl%%PORTVERSION%%/apps/actiweb/univ
+%%ACTIWEB%%@dirrm lib/xotcl%%PORTVERSION%%/apps/actiweb
+%%ACTIWEB%%@dirrm lib/xotcl%%PORTVERSION%%/apps/persistence
+%%ACTIWEB%%@dirrm lib/xotclexpat0.9
+%%ACTIWEB%%@dirrm lib/xotclsdbm1.2
+%%ACTIWEB%%@dirrm lib/xotclgdbm1.2
@dirrm include/xotcl%%PORTVERSION%%
@dirrm lib/xotcl%%PORTVERSION%%/apps/comm
@dirrm lib/xotcl%%PORTVERSION%%/apps/scripts